Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bizarre issue with harddrive's CHS geometry

04 Nov 2011   #1

Windows 7 Professional SP1 32-bit
Bizarre issue with harddrive's CHS geometry

My PC's harddisk is a Samsung HD321KJ (32MB cache, 7200rpm, 320GB).

I was messing around with partitions today in a futile attempt to align my Windows system, and eventually just gave up and restored an image I had made just before.

In the process I noticed something totally weird...the drive itself suddenly reports a different CHS geometry. It used to be something like 38913, 255, 63 but now it reports 43009, 255, 57. Now all my partition software thinks track 0 is just 57 sectors long.

The total number of sectors on the HD remains the same, and there's no other ill effect so far. the heck did this happen? Can I convince the drive to reset its reported CHS numbers? How?

My System SpecsSystem Spec
05 Nov 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

I don't know the answer to your question, but I did have to go into the interwebs and expand my knowledge. Here are two interesting articles on the subject:
Cylinder-head-sector - Wikipedia, the free encyclopedia
Disk formatting - Wikipedia, the free encyclopedia

My take is that CHS geometry is a largely abandoned process that is ignored by most modern operating systems (pre-XP).

Are you running a dual boot with an old OS (DOS or similar) where this "low level format" is important? Is this condition causing an issue?
My System SpecsSystem Spec
05 Nov 2011   #3

Windows 7 Professional SP1 32-bit

No, no issue at all. Not dualbooting either.

I ran a DOS-based diagnosis tool from Samsung called ESTool and it offered low-level format and other options to reset the drive's reported size to its native size. Oddly, the native size is 625142448 but it would only "reset" to 625142447, exactly one sector less.

However, I unexpectedly solved the issue by simply wiping the HD with a diskpart -> clean command and then restoring my latest system backup to a freshly created partition. Now the drive reports the old, proper CHS data again.

Totally weird, as I was convinced it was a problem with the drive's own firmware settings. But...chalking this one up to the God of Computing Glitches and marking it solved.

Thanks :)
My System SpecsSystem Spec


 Bizarre issue with harddrive's CHS geometry

Thread Tools

Similar help and support threads
Thread Forum
Bizarre USB port issue
Hi all, Since the hard drive got replaced on my laptop about a year ago, I've only had one working USB port on my laptop. This hasn't been an issue, as I've coped by using a USB splitter. Unfortunately, my laptop has recently started to behave differently depending on what I plug into the...
Hardware & Devices
Bizarre issue with saved files not existing
Hi folks, new user here. Hopefully someone can help me with this. So here's the situation: I am using ConTEXT editor to write script for photoshop. Everything is going along normally, until I save the script. I saved it to C:\Program Files\Adobe\Adobe Photoshop\Presets\Scripts\script.jsx. Now, that...
General Discussion
bizarre issue
To start off, I had Windows 7 Professional loaded and working on a HP dv6700CTO. I upgraded from Windows Vista Ultimate. I had win7 working for about two days until one morning I opened my laptop lid and it gave me a black screen with the error "Operating System not found." I started the laptop...
BSOD Help and Support
Totally Bizarre Issue with Opera/XP/W7
I've been running w7 as a work machine for a month or two now, currently on 7100. I have XP dual booted. I have Opera on both. Opera installed last year on XP and a month ago on W7 The bizarre problem, I copied over some profile stuff for opera to the w7 install. I booted into XP loaded up...
Bizarre Intermittent Typing Issue
I'm getting a bizarre off-and-on issue in Windows 7. Every now and again when posting here and elsewhere, my "S" key refuses to type...both on my Bluetooth and my wired PS/2 keyboard. It only happens now and again - very weird if you ask me...and I know you aren't....LOL I get around it by...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App