Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't eject hard drives

07 Nov 2011   #1

Windows 7 Professional 32-bit
Can't eject hard drives

Just added this to my computer

Safely Remove Hardware Shortcut - Create

and when I try and eject using the right click on the desktop I get

Problem Ejecting XXXXXx USB Device

The 'XXXXXXXXX' device is not removable and cannot be ejected or unplugged

This is when I try any combination of clicking stop on the drive name and drive letter in the window.

My System SpecsSystem Spec
07 Nov 2011   #2

Windows 7 Ultimate x64, & Mac OS X 10.9.2

what happens if you try ejecting them in my computer?
My System SpecsSystem Spec
08 Nov 2011   #3

Windows 7 Professional 32-bit

can't do it from my computer. There isn't an option for hard drives.

Using the icon in the bottom right works fine though
My System SpecsSystem Spec

08 Nov 2011   #4

Windows 7 Professional SP1 32-bit

Bit confused here - what are you trying to eject? Harddisks or USB drives?
My System SpecsSystem Spec
08 Nov 2011   #5

Windows 7 Professional 32-bit

Sorry I thought I'd said, usb hard drive

edit: just tried with a usb stick and it's the same
My System SpecsSystem Spec

 Can't eject hard drives

Thread Tools

Similar help and support threads
Thread Forum
Constantly Unable to Eject External Drives
For some reason Windows is being really clingy with my externals. Sometimes it's svchost.exe, on this particular occasion it's Explorer. Except in Process Explorer I went in and removed those handles, and now according to Unlocker nothing is holding my drive. But I still get an error when I try...
Hardware & Devices
USB drives won't eject
It suddenly started happening and I can assure you there is no other program using it. I've used process explorer to see what's being handled and I always get this: I:\$Extend\$RmMetadata\$TxfLog\$TxfLog.blf I:\$Extend\$RmMetadata\$TxfLog\$TxfLogContainer00000000000000000001...
Hardware & Devices
How can I delete or eject non-existing drives?
Hi, Can someone help me to delete or eject drives which physically no where to be found? When I go to disk management I can see bunch of removable media but there's no removable media inserted in my PC. When I plug my USB my USB drive letter will become J because the F,G,H and I were already...
Hardware & Devices
problem to eject external drives
hi.i have a problem since now.i cant eject and safe remove my external drives and memory sticks.when i try to click on the list to any device 'eject drive' from the notification area,nothing message any more that i cant remove with safety my device.sometimes then,there is no list when i...
USB drives wont eject.
Everytime I attempt to eject any of my USB drives, I get the following error. They are closed, and I can't see what programs can be using them. Anyone with some wisdom, please??
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:17.
Twitter Facebook Google+