Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WD External Hard drive not recognized

16 Nov 2011   #11

Windows 7 x64

Quote   Quote: Originally Posted by Golden View Post
Quote   Quote: Originally Posted by bal1985 View Post
I've tried every port. I have no tried a different USB cable, I only have the Cable that came with my external hard drive. Where could I get one, as I really do not have the money for this.

Did you try a different USB cable as suggested by Mars? These are dirt cheap and can be purchased at any local PC retailer.

I went to Best Buy and they didn't have any, they said its a special cable. WD is sending me a replacement cable in the mail, I'll get it in 3-5 business days I believe. Geek Squad said there is a 20% chance that the cable is the problem and that if it isn't that they do believe that they could recover the data. The don't see a way of opening the case with out hurting the hard drive.

My System SpecsSystem Spec
16 Nov 2011   #12

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

You are on the right track. Good luck.

And yes, cracking open the case to get the hard drive out could damage the unit and void your warranty, which is why I suggested the Geek Squad first. But if you need your data more than the cost of the drive then you will get out that proverbial nutcracker. The plastic case snaps together in two pieces. A little model glue will repair any damage caused.
My System SpecsSystem Spec
13 Apr 2012   #13

Windows 7 Pro 64-bit SP 1

I recently started suddenly having intermittent USB connectivity issues with one of my MyBook Essential 2 TB drives after using it for a little over a year with no problems (I was not using the WD software). I could see all of my files, but when I'd start writing to it, etc., the USB connection would drop off.

As it was still under warranty, I called WD tech support and they suggested the same; a faulty USB cable...

I tried the USB cable and power unit from my other MyBook, and duplicated the issue on two different laptops (other laptop is Windows XP).

WD then agreed to replace the unit on an RMA; however, I told them that I had over a TB of personal backup data I wanted to preserve and was not willing to send the unit back to them without wiping the drive.

I asked them for permission to crack the case open and pull the hard disk out without losing my warranty. They granted that to me, so I went and bought a dual SATA bare drive docking unit (BlacX Duet) and a WD Caviar 2 TB drive.

I found a page that shows how to disassemble a MyBook with written instructions:

Written instructions:

There are some YouTube videos as well, but the units they were working on are different than mine.

The only problem I encountered was that Windows 7 wanted to initialize the disk I pulled out of the MyBook and loaded into the docking unit – not sure why, it was formatted NTFS.

You don’t want to initialize it (!) unless you want to scrap the data. I learned later from AddRam that there are utilities like Partition Wizard that you can use to fix the partition and access it.

I lost my data, but was able to reformat the drive prior to reassembling the unit and sending it off to WD on an RMA for replacement.

Overall, WD was very accommodating, and even agreed to send me a bare Caviar drive instead of another MyBook, so that I can use it in my new BlacX docking unit…
My System SpecsSystem Spec

19 Apr 2012   #14

windows 7 pro 64 bit
Problem with External harddrive

I have a unique problem with my western digital my essential portable drive. It was working fine until last week on my windows 7 home edition.
After I upgraded my laptop to windows7 pro I started facing problems. To being with the drive was detected, it asked me for an unlowck password, after unlocking it showed me the drive and the data. But the drive soon disappeared within

few seconds and I had reconnect to see the problem recur. I tried uninstalling the usb drivers and installing them freshly it did not help. Now the situation is so bad that when I connect it shows me the WD Unlock VCD. When I run

unlock.exe and enter the password, it says unlocked but doest show me the drive. If I try to perform any more operations on the drive, the machine hangs. I have tried the following but unable to solve the problem. Do you have


1. In Device manager > Disk Drives > uninstall drivers, reconnect the drive and windows automatically installs the drivers.
[outcome]- The problem is not solved

2. In DiskManagemnt all I see is a small partition of 27 MB called WD Unlock. I changed the Drive letter and tried
[outcome]- The problem is not solved

3. Installed WDSmartware updater on my machine (this is a illogical action, but just outof hope)
[outcome]- The problem is not solved

4. Went to WD support center, downloaded the latest firmware for the drive and tried to update it onto the drive by running the executible
[outcome] - the software intallation dialog box says that the drive already has the latest firmware. When I continued installation, it tried to install and came back saying update failure.

5. Called Western Digital Support
[outcome] - They say that because windows is detecting the drive, there must be some problem with the disk, it must be corrupt. They suggested that I eceover my data using freeware like photorec, if it fails pay for expect data retrieval

professionals. After that they can replace the harddrive as it was under warranty. This is a bad solution for me as I can't pay for the expert service

6. Ran TestDisk a free utility from CGSecurity
[outcome] - After a full scan it returns with disk read error/error reading sectors

7. Ran photorec a free data recovery utility from CGSecurity
[outcome] - After a full scan it returns with disk read error/error reading sectors

8. Tried on windows XP machine with antivirus disabled
[outcome]- The problem is not solved

I am almost helpless in getting this resolved. Any ideas please?
My System SpecsSystem Spec
19 Apr 2012   #15

Windows 7 Pro 64-bit SP 1

You might try burning a bootable Partition Wizard CD (free) to see if you can fix the partition and recover the data. Link:

Partition Wizard Bootable CD allows user to manage partition directly with partition manager bootable CD.

You might also try uninstalling the WD software. I never use it, instead set up as a disk in Windows
My System SpecsSystem Spec
15 Aug 2012   #16

windows 7 professional 32 bit

bal1985 ..
how did you solve your problem? let me know. I have the same issue.
Did the new cable work?

My WD is out of warranty and I have 3 of those damn things. so I might get the cables if that solved your problem.
My System SpecsSystem Spec
28 Aug 2012   #17

Windows 7 Ultimate 64-bit

I tried different USB Cables, different ports, different computers.
Whenever I try to write, after some time it is getting stuck.
This happened after I changed it from gpt to mbr.
Before that, everything was perfect.
Now, I am dealing with it and trying to solve the problem, no luck so far.
Windows sees the drive in safely remove hardware and devices and printers, but most of the time it doesn't see it in disk management and windows explorer; I have to turn it off and on again.
Updating the firmware or using WD Formatter didn't help.
I wasn't using the smartware anyway.
I hope people will post their progress, so we can learn from them.
Right when I am typing this, it ejected, and inserted itself.
My System SpecsSystem Spec
28 Aug 2012   #18

windows 7 professional 32 bit

Thanks for the update. I bypassed the problem as i had a pcmia slot and bought the pcmia to usb 3.0 and a usb hub and i am up and running now.

2 things came out of this
1. I got my on usb 3.0
2. I got a nas server so dont have the need for usb anymore. I have the 3.0 as backup
My System SpecsSystem Spec
05 Nov 2012   #19

Windows 7 x64

Hey, I was having the same problem with a brand new drive and did what this guy did to great effect:

WD My Passport Not Recognized On My Computer - Western Digital Community

This was the only thing that worked for me, but it worked right away. Only drawback is you lose all your information if you have anything stored on it...
My System SpecsSystem Spec
23 Dec 2013   #20

Win7 Pro 32-bit and XP Pro (17 windows machines)

I realize this post is a year later, but others keep on having the same problem. There are other fixes which don't have to be as drastic as reformatting the drive:

1. Hook the WD to an external POWERED hub, not one on your computer. This is especially important for laptops.

2. CHANGE THE CORD. The WD cords supplied with the units are glitchy. Sometimes they also absorb static, so will work for awhile then quit. To dissipate the static, just unplug the cord and plug it in again. But a different 3.0 cord, is better. Don't get the cheapest one in Amazon, get a brand name (Amazon Basics is great, so too Tripp Lite).

3. REBOOT WINDOWS and then plug in the unit again. Until Windows detects that the unit needs a 'WD SES' driver, it won't be reliable. This is true for either XP or Windows 7 (32-bit, I don't know about 64-bit). So you'd boot, then plug in the drive, and see if Windows recognizes it needs that driver. It will want to go get it from the database, if it's not already on your computer. Telling it where the file is ON the WD won't work.

In all events, there's no need to use the WD software to install the thing. I have six of these Passport drives, and am fixing to buy more. I use them on 2.0 USB ports, and on 3.0 laptop ports, now for over a year.

Since the same thing just happened to me now as happened to forum participants here, and that's how I (again, really) solved the problem, you know it's solvable with any new WD Passports you may have just purchased (mine are a week to a year old, Ultra recent and plain WD Passport, a year old, 500 GB and 1TB).

Yell at me if you need more info.
My System SpecsSystem Spec

 WD External Hard drive not recognized

Thread Tools

Similar help and support threads
Thread Forum
External Hard Drive not recognized
So every time I plug my external hard drive in it pops up with a message saying it is not recognized. This is followed by a message saying device driver not installed correctly. I have tried uninstalling it from the Device Manager section and then plugging it in (this worked shortly after the...
Hardware & Devices
External Hard drive Not Recognized
I have a toshiba external 200G hard drive. It was used on a Dell computer which ran Windows XP. I now have a new computer which runs windows 7. However when i connect the external hard drive to the new computer i start to experience problems with the files on there. So there are a number of...
Hardware & Devices
External hard drive not being recognized
I had an external hard drive that was working fine for about two months, then suddenly stopped working. The power light still turns on when it's plugged in, but it isn't recognized by disk management or anything. I tried it on a friend's computer and got the same result. What are the odds of...
Hardware & Devices
External Hard Drive not recognized
As the title suggest my external Seagate hard drive is no longer being recognized by my system. The information on this is absolutely critical to me- I am a DJ and Producer and this particular drive contains all of my song stems, acapellas, instrumentals, sample kits, and also backups of every...
Hardware & Devices
My External Hard Drive Isn't Recognized
Yesterday, I backed up everything on my computer because I was going to restore it and format the drive. So I transfered everything over to my Seagate 500gb hard drive. Once I finished formatting and reinstalling windows, I installed all my neccessary chipset drivers, ect.. and connected my...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App