Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Copying to USB is inaccessible!!!

26 Nov 2011   #1

Windows 7 x86 Ultimate
Copying to USB is inaccessible!!!

My USB was unknowingly configured so that I cannot copy files from others PC to a my USB pen drive. It only allows my pc.

When I try to do this, I get the following message:
"Destination Folder Access Denied
You need permission to perform this action."

There is definitely enough room on the USB drive.
The USB drive is configured with a password, which I entered correctly after plugging in the drive. After doing this, I am able to see the files from the drive. The configuration is such that I can copy files from the USB drive to the PC's hard drive, but I can't copy in the other direction, which is what I need to do.

This sounds like a Windows permissions issue to me. I have taken ownership of the file in question, and I have assigned full control to that file. That has not solved the problem.

My System SpecsSystem Spec
26 Nov 2011   #2

Windows 7 Home Premium 64 Bit OS

If you are trying to copy files from someone elses machine then
maybe they have their security locked down so this is not possible.

If this is the case you would need a user account with administrative
priveledges and unless the administarator gives you the permission
you require (full control) you will continue to have difficulties trying
to transfer the required files/ folders.

As for transferring files from your own machine to the pen drive, if you
have taken ownership of the file this still doesn't neccessarily apply
the permissions you require all in the one step. I think you still need
to take control of the parent folder if the file is a child folder, or at
least check the permissions of the parent folder because in Windows
the folder permissions are inherited from the parent folder (or directory if you prefer)
So make sure that you have full control of the folder/ s you
are trying to transfer either by way of your administrator account
or by allowing your user account the permission to do so.

Further info here: How to set, view, change, or remove special permissions for files and folders in Windows XP
Understanding Windows NTFS Permissions

I hope this helps and at the least hasn't caused to
much confusion- it's a process!!
My System SpecsSystem Spec
25 Apr 2014   #3

Fixed my issue

I was trying to build a Windows 7 bootable USB drive and encountered this error. What I found was when I was trying to copy the "autorun.ini" file (my directions were to select all from the Win7 disc, copy and paste to my bootable USB disk...) was causing the error. Apparently you don't need it anyhow. After trial and error; copying and pasting each folder from my source DVD to my USB disk I found it was that file.
My System SpecsSystem Spec


 Copying to USB is inaccessible!!!

Thread Tools

Similar help and support threads
Thread Forum
4Tb drive inaccessible
I created a 4Tb partition using GBT. However, when I try to open it, I get a "D: is not accessible - access is denied" error. What's wrong?
Hardware & Devices
send to folder inaccessible
I went to RUN and typed in sendto in order to add a couple of locations (first time I've bothered to do this, or needed to) and it came up with a window stating C:\Users\Keith\SendTo is not accessible Access is denied I turned on view hidden files and show etc but it did not help. I am...
General Discussion
Certain websites inaccessible
Hi, There are some websites that I have been unable to access. They display "Server not found" in my firefox, error 137 in my google Chrome. Even my iPad and my MacMini are unable to access these sites for some reason. However, when I connect to a VPN or using other wifi hotspots or internet...
Browsers & Mail
Disk is inaccessible
I had creat an briefcase 2 month ago putting some of my imp. files. now when i try to open it it says "This Briefcase cannot be opened because the disk is inaccessible." Verify that the disk is accessible. What should i do plz help me.
General Discussion
[Ask]HDD suddenly inaccessible
Hello, got some problem here I've got a WD 1TB NTFS harddisk When i turn on suddenly it became inaccessible The before i turn off my PC it's still ok and also i can still copy the content to another HDD And the problem comes when i turn it on Before it i delete some unknown files that just...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App