Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB SATA Eclosure with SSD installed drive not recognised fully.

20 Sep 2012   #21

Windows 10 Pro/ Windows 10 Pro Insider

Yes, I know. I was hoping the secure erase with Parted Magic would resolve that problem. Parted Magic will do it with it being your primary drive. You make either a USB thumb drive installation or a CD installation and boot into the USB or CD drive. Laptops make a lot of things more difficult, don't they. It is much easier with a desktop.

My System SpecsSystem Spec
20 Sep 2012   #22

Windows 8 Pro (32-bit)

Do you happen to have a desktop computer handy? if so, you could possibly temporarily connect the SSD to the desktop, using the cables normally used for your optical drive.

After that, you would problably want to use a firmware-level erase program or a erase program that's designed for SSDs

And how difficult is it to remove the drive? Some laptops allow you to just pop out the drive, while others require full dissassembally. it'd be nice to know so we can plan out questions and requests accordingly.
My System SpecsSystem Spec
20 Sep 2012   #23

Windows 7 Professional 64bit

I can have access to a desktop and plug in the SSD. If that works, then I can use the stock software to delete.

To remove the drive from the laptop is not difficult, one screw and plug.
My System SpecsSystem Spec

20 Sep 2012   #24

Windows 10 Pro/ Windows 10 Pro Insider

Using the desktop and the samsung Magician software for the secure erase would be the best solution. The Parted Magic software is simply a linux based program that contains several programs, one of which is HDErase. It offers several options. The last option is to issue an internal secure erase command to the SSD. It does nothing more than issue the command. The SSD controller does the secure erase. It is used and recommended by several SSD manufacturers.
My System SpecsSystem Spec
21 Sep 2012   #25

Windows 7 Professional 64bit

Just an quick and funny/silly update...I thought I had the right cable but didn't...darn!
My System SpecsSystem Spec
21 Sep 2012   #26

Windows 7 Professional 64bit

Solved or work around update - $99 one. I already used up half of 258GB ssd with software so I decided to purchase a HHD Caddy and use it as a data drive :) I am going to presume that it WILL be recognized as a second drive and allow me to format it completely. Stay tuned. The caddy arrives next week.
My System SpecsSystem Spec
19 Aug 2015   #27

W7 Pro 64 and 32 bit, 2 laptops


some what related to this topic.

I have recently destroyed my work laptop, I salvaged the SSD from it. It is hooked up as an external drive through USB, and similar to the beginning of the thread, I couldn't access it. I followed through and opened up the Disk Management.

I can see the SSD is one of the disks and "Healthy" partition(what I need to access) does not have a directory.

I also cannot open it because it has been faded out. I CANNOT partition it, I need to copy-and-paste this partition to clone to a new SSD for a new laptop.

How can I access this volume? I'd appreciate any insight ASAP, it's my work/research computer data. I do have backups, but latest backup is from few weeks ago.

I should also mention that the SSD belonged to a Linux laptop, it should have ext4 format.

Attached Thumbnails
USB SATA Eclosure with SSD installed drive not recognised fully.-upload.jpg  
My System SpecsSystem Spec
19 Aug 2015   #28

W7 Pro 64 and 32 bit, 2 laptops


I followed :3 Ways to Access Your Linux Partitions From Windows

I can read the files, but I cannot copy and paste it. Also, it says the size of my ~/Directory in the SSD is over 300GB, which is impossible because SSD is 120GB in total.
My System SpecsSystem Spec
19 Aug 2015   #29

Windows 10 Pro/ Windows 10 Pro Insider

See if this will help. It will work with most any Linux Distro Emergency Kit - save your files from a dead OS

Also note, this thread is 3 years old, so responses may be few and far between. You may be better off, if this does not work, to start your own thread.
My System SpecsSystem Spec
11 Sep 2015   #30

Buffalo External HD

I have the same issue but i cannot assign a drive letter. Its greyed out. my Device mgr shows an error :

Device USBSTOR\Disk&Ven_BUFFALO&Prod_External_HDD&Rev_0000\00000002058784B&0 could not be migrated.

Last Device Instance Id: USBSTOR\DISK&VEN_&PROD_&REV_8.07\14122955000203&0
Class Guid: {4d36e967-e325-11ce-bfc1-08002be10318}
Location Path:
Migration Rank: 0xF000FC000000F120
Present: false
Status: 0xC0000719

Not sure what that means. Have i lost all of my data ?? Also, the drive shows up everywhere except explorer. The driver is showing updated ive tried everything....Help ! I have family photos on there =(

Thank you so much!
My System SpecsSystem Spec

 USB SATA Eclosure with SSD installed drive not recognised fully.

Thread Tools

Similar help and support threads
Thread Forum
alienware 17 R2 BIOS not fully ACPI Compliant after A08 installed
Updating your Alienware to Bios level A08 from A06 will result in your Windows 7 system booting to a BSOD. Nothing you can do will repair this except reloading A06 again. If your Alienware has M2 SSD with Windows 10 loaded, you can use this system to downgrade to A06. Then Windows 7 is happy again....
BSOD Help and Support
SATA drive not recognised
Hi all, I had a pc with a SATA drive installed running XP. It got a virus that i couldn't shift and so decided to go to W7. Bought a new machine etc and now wanted to connect the SATA drive via USB to get the uninfected files off. The issue i now have is that none of my new equipment...
Hardware & Devices
Secondary SATA drive not recognised
I bought a Seagate 2Tb internal 3.5 inch drive intending to install it in my desktop as a secondary drive. The desktop currently has two 500Gb disks in a Raid 0 (striped) array. One SATA port is free and I connected the new disk to this. The system did not recognise the disk so I put it in a caddy...
Hardware & Devices
Fully updated install, MSE, Ask Toolbar was installed, security risk?
Hello there. My father has a Windows 7 notebook, with nothing but the basics: Firefox (+Plugins), Thunderbird, VLC, Skype, MS Office 2010, SolidWorks, MS Security Essentials, everything updated. However, he told me that last week it began playing a sound like if a usb drive was plugged and Java...
System Security
Unable to assign drive letter to newly installed SATA drive.
I'm playing with a recently retired server running 32bit Windows 7 Professional. Originally it was configured as RAID 0 with 5 SATA drives. Those drives are gone but I want to install a spare 2TB SATA drive that I have. Using the RAID Management software I have created the drive and it shows the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:43.
Twitter Facebook Google+