Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Secondary Hard Drive freezes system before Windows launch

04 Dec 2011   #1

Windows 7 Home Premium 64 bit
Secondary Hard Drive freezes system before Windows launch

My system runs Windows 7, 64bit OS.
Replaced Socket 775 Mother board and CPU with Socket 1155.
ASUS was manufacturer of both old and new mobos.
Kept all hard drives and reinstalled them.
2 x Seagate 350Gb Sata 3.0 (one is the boot drive with OS)
1 x Western Digital Caviar Green 1.0 Tb Sata 3.0

PROBLEM: System would freeze at post, just before Windows launch.
Isolated to the WD hard drive as problem.
When disconnected, Windows booted normally and all other drives appeared.

I did a “Clean Install” of Windows 7, 64 bit. I reinstalled latest mobo bios and all chipset/device drivers, but problem continued.

Tried to “Hot Plug” the WD drive after windows launched and it worked. It booted and loaded drivers. When Hot Plugged it operated normally and was visible in both My Computer and Disk Management. I could see files and transfer to and from the disk.

HOWEVER, when I shut down and restarted, I was back to square one. Drive caused system to freeze before Windows launch.

The only way to access the drive is via Hot Plug, which is not realistic for an internal drive.

Anyone have a solution? Help Please. Thanks.

My System SpecsSystem Spec
04 Dec 2011   #2

Windows 7 Ultimate 64 bit

Does the main drive and the WD drive both have the OS loaded on it? Next question: What SATA port do you have it plug does make a difference? It should be plugged into sata ports 1 - 4. The other ports require either AHCI driver loaded to activate those ports or the RAID driver to use all port at the same time. It's a limation of the mobo do to the controller responseable for the remaining sata ports.
My System SpecsSystem Spec
04 Dec 2011   #3

Windows 7 Ultimate 64 bit

Haveing a look at your mobo manual, I see that is has 6 ports. 1 threw 4 are sata3g and ports 5-6 are sata6g. So make sure your have your hard drives plugged into one of the 3G ports. Here's a cut away of your mobo ports layout.

Secondary Hard Drive freezes system before Windows launch-sata-ports.png

My System SpecsSystem Spec

04 Dec 2011   #4

Windows 7 Home Premium 64 bit

OS only loaded on main drive.
Plugged into Sata Port #2.
AHCI is enabled
My System SpecsSystem Spec
05 Dec 2011   #5

Windows 7 Ultimate 64 bit

Plug it into port 5-6 and check it. If not then disable AHCI, plug back into port 2 and see if that doesn't do the trick.

Note: Not sure if a re-install is required to disable AHCI after OS is loaded. A re-install is required to enable it if the OS is all ready installed. I found that out the hard way myself...with an ASUS mobo. Not sure for other brands of mobo's.

Also check your BIOS to check how your HDD's are setup to be used....either IDE, SATA or AHCI/RAID. For SATA, select SATA and they must be in plugged into sata ports 1-4.
My System SpecsSystem Spec
05 Dec 2011   #6

Windows 7 Professional SP1 32-bit

Let's try a simple solution first - I have a nagging suspicion the WD disk contains weird bootcode in its MBR that's making the BIOS crash once it starts looking for bootable volumes.

Boot into the Windows rescue environment (or boot from your install DVD) and then hotplug your WD drive as you've been doing. Go to the command prompt by pressing Shift + F10 once the setup screen appears.

Now type "bootsect /nt60 /all /force" and press Enter. You should see various status messages indicating a successful bootcode update. At this point you're ready to close the command shell and restart your computer to Windows.

Is it now able to boot with the WD drive connected or does it still freeze up?
My System SpecsSystem Spec
05 Dec 2011   #7

Windows 7 Home Premium 64 bit

Solved… the hard way.
After trying everything from the simple ‘replace the sata cable’ to the more complex ‘Windows clean install’, nothing was working. Western Digital ‘support’ simply said the drive must not work with the motherboard I have?! ASUS suggested: Update drive firmware (no updates available); Try a larger power supply (already have 650W) and finally; Our motherboard must be defective – return it to CompUSA for a replacement (wasted my time with that one…).

Finally I came across something right here at SevenForums! On 10-16-2011 gregrocker posted a thread titled “Windows 7 – Frozen Bios Boot Screen”. Comments by TVeblen on 10-18 suggest that the hard drive has a controller chip that may get corrupted. Whether this is valid or not, the solution worked for me. Time consuming but painless.

I had to transfer all of the data off of the drive. I then ran Diskpart. I used the “Clean” command, which totally wipes the hard drive and apparently resets whatever has been corrupted.

When the “Clean” process was complete I had a drive that worked correctly again. I was able to shut down and restart without the system hanging at the Bios boot screen. Windows launched flawlessly.

Next I used Windows 7 Disk Management to partition and format the drive, assigning the original drive letters. Then I transferred all of my data back to the drive and everything is back to normal. I am in a happy place now.

Thanks for those who provided suggestions. Ultimately this forum did provide the answer.
My System SpecsSystem Spec
05 Dec 2011   #8

Windows 7 Home Premium 64 bit

Sorry Corazon, I missed your comments while I was going through the process I outlined. Seems the theory was correct about the corrupted boot code, but you have a much more direct fix. If it works it would have saved me hours of data transfers. Hopefully if someone else runs into this, they will see your comments and try the short route first.
My System SpecsSystem Spec
05 Dec 2011   #9

Windows 7 Professional SP1 32-bit

I'm sorry you missed it too, as I was hoping to save you all the reinstallation work you ended up having.

It's still possible my solution wouldn't even have worked, but using diskpart and the clean command pretty much wipes out any MBR and partition table corruption by simply blanking it out completely. In other words, that was the best thing you could've done to make the HD usable.

I'm glad you're back in business now. :)
My System SpecsSystem Spec
27 Jul 2012   #10

Windows 7 Ultimate x32
exactly the same problem

Hi there,

I've come across exactly the same problem after purchasing Western Digital WD20EARX Green (2TB internal HDD).

The motherboard is MSI-7176 (945P NEO) with P4 3.2, 3GB DDR2 800 (1gb +0.5gb x 2). 2 IDE slots and 4 SATA ports. 2 external storage HDD as USB.
I'm running win7 ultimate (32bit) with 2 SATA HDDs from Samsung. I mounted the new WD20EARX as slave SATA for storage only. On the first boot the BIOS recognized it properly, the OS loaded and I managed to (quick) format the drive and assign a drive letter to it.
Fie transfer went smooth as a breeze and the same for all read/write functions. Music, video etc... no problems at all. Happily, I called it a day and switched off the computer. The following day as I switched it back on, the computer would display the chipset logo and freeze. BIOS wouldn't load. After disconnecting the new HDD from its port and rebooting, everything would load normally. I've tried switching windows' Power Management off, flashing the BIOS afresh, updating drivers, switching SATA ports, switching power connectors and... nothing worked. I notified the WD desktop help by e-mail a day ago--and I'm still waiting for a response--and searched their troubleshooting archives and forum for a similar case but came up with zero. I was ready to announce the new hard-drive dead and seek replacement when accidentally enough, I came across this thread today which assured me to try hot-plugging the port. Apparently, the driver for the WD20EARX was still active on the system so no new install was necessary. A quick refresh in the Device Manager brought the WD20EARX back to life with all recent data intact. Trying to reboot the system after the hot-plugging has again failed so I had to repeat the above mentioned steps.

I followed Corazon's suggestions and created a boot rescue DVD, went into command prompt and typed "bootsect /nt60 /all /force". The command didn't trigger any checkup or updating; it just listed information about the various commands/functions available with bootsect. I guess, I didn't do it right, but I decided not to risk my system any further. I then followed tripdip's path and so far so good!

Nevertheless, here are some further suggestions:
1. Use "diskpart" (from the command prompt) cautiously. You have to "disk list" your drives and then "select disk", i.e., the malfunctioning disk (an asterisk will appear next to your choice). Only then type "clean".
2. The Hard-drive will appear again only at the: Control Panel-->Administrative Tools->Computer Management->Storage application. You'll need to reallocate it and reassign a drive letter to it.
3. If your HDD is not bigger than 2TB, use the MBR option.
4. Don't quick format it. Use the (slow) full format by unchecking the quick format option.
5. I bought my first HDD ever 15 years ago and it was Western Digital... it sucked even then. From a quick look at many forums, many of the WD hard-drive models have various functional defects. I suggest purchasing from a different manufacturer. My old SAMSUNG Seagates have been working splendidly for some years now with no extra hustle.
My System SpecsSystem Spec

 Secondary Hard Drive freezes system before Windows launch

Thread Tools

Similar help and support threads
Thread Forum
Deleted system reserved partition from my secondary hard drive
I was recently doing a fresh install on my SSD (primary). I saw a 100mb system reserved partition and deleted it thinking it was from the primary drive. But it was from my data drive/secondary hard drive. Now the data partition is there in secondary hard drive but I'm unable to access it. Windows...
Hardware & Devices
System will not boot with secondary hard drive connected
I have two hard drives, a 240 GB SSD with the OS, and a second internal hard drive, a WD black edition 2 TB drive. Everything worked fine until I temporarily attached a friends hard drive (OS drive running Windows 7 prof) to my system in order to recover some files. After removing the friend's...
General Discussion
Deleted System reserved partition on secondary hard drive
I've had two disks: 1- SSD drive with OS 2- HDD with 4 partitions + system reserved Because i wanted to get rid of system reserved partition i've deleted and extended one of those 4.. After that i formated and installed windows 7 x64 on my SSD. Right now the hdd partitions won't show up, and...
Backup and Restore
Secondary hard drive disappeared after install of Blu Ray DVD drive
Hello, I hope someone can help me with an issue I've just come across. I bought an LG BH14 Blu Ray DVD drive to replace my old LG drive. I unplugged my pc, pulled out the old unit, disconnected the two wires, connected them to my new unit, and popped it back in. Too easy, right? After...
Hardware & Devices
Installing Windows 7 Upgrade to secondary hard drive
Hello all. I have a bit of a strange question about installing the Windows 7 upgrade. I'll try to keep it as simple as I can. Firstly 1: I currently have Windows XP SP3 Home Edition installed (and activated) on my 160GB WD Caviar Blue hard drive, which has 8MB cache. It's getting a bit...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:49.
Twitter Facebook Google+