Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SSD wont boot through sata3

06 Dec 2011   #11

Windows 7 Professional SP1 32-bit

OMG. You're right, sorry, I completely misread the specs and thought all were SATA-3 ports.

I just re-read your original post and noticed you said that the boot process freezes "during the splash screen". I thought we were talking about a failure to boot from the SSD on SATA-3 at all, but obviously it does boot into Windows, it just crashes in the process.

I think I know why - since the SATA-3 ports run on the Marvell controller, my guess is you'll need a different SATA AHCI driver for Windows to use that controller. The one for the AMD chipset-based controller wouldn't work for the Marvell.

If the Marvell-specific driver is already installed on your system, then it might be necessary to add the driver to the CriticalDeviceDatabase key in the registry, so it's loaded at boot time and available for the boot process to continue to the desktop.

What can you tell us about the installed drivers for the AMD and Marvell controllers?

My System SpecsSystem Spec
06 Dec 2011   #12

Windows 7 Home Premium 64 bit

I think your missing one small point, the OCZ Vertex 3 does NOT have a Marvell controller it has a Sandforce SF-2281 controller.
My System SpecsSystem Spec
06 Dec 2011   #13

Windows 7 Professional SP1 32-bit

Quote   Quote: Originally Posted by 1Bowtie View Post
I think your missing one small point, the OCZ Vertex 3 does NOT have a Marvell controller it has a Sandforce SF-2281 controller.
I was never talking about the controller on the SSD itself.
I've been referring to the two separate SATA controllers on the motherboard. The SSD's Sandforce controller is irrelevant here.
My System SpecsSystem Spec

06 Dec 2011   #14

Windows 7 Ultimate x64, & Mac OS X 10.9.2

then its not the SSD's fault at all. Sounds to me like your marvel powered ports arent working period.
Have you got the latest bios for your mobo?

SATA3 ports are backwards compatible, so running a SATA2 device on it will be fine. My servers mobo has 4 SATA3 ports and nothing else. yet nothing i run off it is sata3
My System SpecsSystem Spec
06 Dec 2011   #15

Windows 7


yea it cant be the SSDs fault as a HDD plugged into the same ports has the same problem.... the bios is version F3, f4 is the most recent(but its in a BETA) and lists no improvements to any controllers

Corazon :

i have no idea what your talking about... you lost me
My System SpecsSystem Spec
06 Dec 2011   #16

Windows 7 Professional SP1 32-bit

Sorry about that. Let's clarify a couple of things because I'm a bit confused about a few details.

We've established that your SSD (which contains Windows) boots fine all the way to the desktop when connected to a SATA-2 port.
Windows will start booting from the SSD when it's connected to SATA-3, but freeze up during the boot while the splash screen is visible.

Am I correct so far?

Now what exactly do you mean when you said "the HDD doesn't boot either when I connect it to the SATA-3 port"? I'm assuming here that your HDD contains another Windows installation - is that Windows the exact same one you have on the SSD now? (i.e. did you clone it to the SSD?)

Are you saying the HDD won't boot at all, or does it get to the animated splash screen and freeze there just like the SSD?

We need to be clear about this, as the difference is important.
My System SpecsSystem Spec
07 Dec 2011   #17

Windows 7

Vertex 3

SATA : Boots all the way up, works 100%
- BUT -
has lag spikes and weird delay??

SATA3: Freezes at SPLASH (single beep for post)


SATA : Boots:Works

SATA3: Freezes at SPLASH (Single beep for post)

make sure to note by Splash i mean the splash screen for the MOBO with the option to BIOS/boot/recovery/postdetails/flash (also note it freezes before i can get into bios... although i can get into post details)
My System SpecsSystem Spec
07 Dec 2011   #18

Windows 7 Professional SP1 32-bit

OK, you mean the POST screen then. (That's not a splash screen, strictly speaking, so I thought you meant the Windows boot logo).

BTW, POST = power-on self test, which is what the BIOS does after turning the PC on or when restarting it.

I'm not really sure what's going on here then - the mere presence of something connected to one of the SATA3 ports (which are on the Marvell controller) prevents the machine from booting. I can only assume it's a hardware failure or possibly a SATA3 cable plugged in wrong - which shouldn't really be possible, mind you, but if the cable itself is damaged maybe it's creating a short circuit somewhere.

Do you have a different SATA3 cable to try with?

The lags and freezes you're experiencing with the SSD when running on SATA2 are a completely different issue and we'll have to deal with that one separately (if you want to). I don't know anything about the Vertex 3 but have heard of problems with it...does it have the latest available firmware installed?
My System SpecsSystem Spec
07 Dec 2011   #19

Windows 7

The firmware Version is 2.15 (Most recent)

i have tried with different cables(Same result)

it cant be a hardware failure on the HHD/SSD side as they both work just fine connected to a normal Sata port

that being said it could be the motherboard.. or a bios setting or software/controller/driver issue??

i haven't looked into the lag on the SATA2 port still have some hope of getting the sata3 to work .... that being said ill look into it
My System SpecsSystem Spec
07 Dec 2011   #20

windows 7

"changed some settings from IDE -> ahci in bios"
If you changed the BIOS to AHCI after you installed the OS you will ether have to re install the OS, or do a registry hack (change), or change it back to IDE mode.
My System SpecsSystem Spec

 SSD wont boot through sata3

Thread Tools

Similar help and support threads
Thread Forum
Dual-Boot Win7/Win10 on seprt HDD's - Both HDD's detected, 7 wont boot
I have a dual-boot setup on a Dell XPS 8900 that I've had since Feb/March. The dual boot setup has been working fine, with zero issues since then, then this week I just booted into Win7 a couple days ago and it ran chkdsk automatically, erased some files, restarted, and booted into Win7 fine. I...
Installation & Setup
Win 7 , Ubuntu dual boot, windows wont boot, startup disk doesnt help
Hi a couple of months ago my system crashed, windows 7 wouldnt boot, and I misplaced my installation disk. I had the problems several times since obtaining the computer several years ago. (Lenovo IDeaPad y450). I attributed the problem to what I believed was a bad hard disk, so I replaced it with a...
General Discussion
Need Help. W7 wont boot after resizing partition. Recovery wont work.
Hi first time poster Full specs: MSI Z68a-GD80 i5 2500k Gtx680 Asus Hitachi Deskstar 1tb (boot) KingstonSSD120gb (games) So last night I shrunk my HDD partition by 100gb, intending to dual boot W8. Never got round to installing it, but when I turned on my PC tjis morning it won't boot. It...
Installation & Setup
windows 7 wont boot, wont go to safe mode or start on windows 7 disk
hi, window will not boot goes to blue screen that says process 1 initizaltion failed and starts dumping, then reboots to reapir, wont repair, tried booting to reapir disc and used bitdefender rescue which showed no virus, then tried booting to my winodws 7 upgrade disc, it says loading files then...
BSOD Help and Support
windows7 wont boot past windows splash screen - will boot to safe mod
WIndows 7 premium home version on a lenovo laptop freezing at splash screen. I can boot into safe mode just fine. Whereby I have to run a system restore back to an older date but the issue still comes back up and this seems to be especially true when trying to wake it from sleep mode. beyond the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:57.
Twitter Facebook Google+