Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Non-existant i5-760S CPU ?!?!?

05 Dec 2011   #1
hucker

Windows 7 Ultimate x64
 
 
Non-existant i5-760S CPU ?!?!?

I've bought a 2nd hand i5-760S processor. Intel do not admit to ever having made one, but it's in my computer! The reason I'm concerned is the ad said it was 2.53GHz with a max turbo frequency of 3.33GHz. Well I am getting no turbo. It's stuck at 2.53GHz - any ideas?


My System SpecsSystem Spec
.
05 Dec 2011   #2
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Did you check the BIOS to see if Turbo is enabled?

Yes, it exists.
The link has the specs.
http://ark.intel.com/products/42917/...he-2_40-GHz%29
My System SpecsSystem Spec
05 Dec 2011   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Turbo is only used with high CPU load.
My System SpecsSystem Spec
.

05 Dec 2011   #4
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Intel® Core)

I didn't have any trouble finding it using Google.
Factory is 2.88GHz and turbo maximum is 3.33GHz.
My System SpecsSystem Spec
05 Dec 2011   #5
hucker

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Sardonicus View Post
Did you check the BIOS to see if Turbo is enabled?
Checked BIOS - I have tried both AUTO and ENABLED for Turbo technology (along with all the other settings on that page for CPU features.

Quote   Quote: Originally Posted by Sardonicus View Post
Yes, it exists.
The link has the specs.
Intel® Core
No, mine is a 760S, not a 750S.
My System SpecsSystem Spec
05 Dec 2011   #6
hucker

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by whs View Post
Turbo is only used with high CPU load.
I have it fully loaded on 4 cores using BOINC.
My System SpecsSystem Spec
05 Dec 2011   #7
hucker

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Hopalong X View Post
Intel® Core)

I didn't have any trouble finding it using Google.
Factory is 2.88GHz and turbo maximum is 3.33GHz.
That is a 760, I have a 760S - lower power, lower clock speed.
My System SpecsSystem Spec
05 Dec 2011   #8
Sardonicus

Windows 7 Home Premium 64 bit
 
 

What's mobo are you using?
Your specs show a 1366 Mobo, which I know isn't the mobo you're using.
My System SpecsSystem Spec
05 Dec 2011   #9
hucker

Windows 7 Ultimate x64
 
 

Sorry, different computer. The computer in question has a Gigabyte GA-P55-US3L motherboard.
My System SpecsSystem Spec
05 Dec 2011   #10
Hopalong X

Windows7 Pro 64bit SP-1; Windows XP Pro 32bit
 
 

Download this and open it> http://www.cpuid.com/downloads/cpu-z/1.59-setup-en.exe

Then post a screen shot or Snip please with the CPU tab showing.
It will give us your specs and settings of the CPU.
Voltages, multipliers and Turbo settings.
This would be very helpful.

Mike
My System SpecsSystem Spec
Reply

 Non-existant i5-760S CPU ?!?!?




Thread Tools




Similar help and support threads
Thread Forum
Non-existant Bd-rom drives spammed on startup
Hello, I have a windows 7 ultimate x64 system pc, and today I started getting a weird bug - as soon as the system loads, every couple of seconds bd-rom drives start getting created and placed in the device manager and file explorer. This overflows the displayable devices up to disk Z in the...
General Discussion
Nagging on non-existant drive
Once had an external drive (or camera??) on S:\ Now for no obvious reason W7 tries to access it and tries that every 5 secs, which makes the computer almost inoperable. When it happens I found it in My Computer, but trying to remove it fails. Only a restart helps. Then I checked Management but...
General Discussion
SP1, non existant, impossible to update to.
Ive installed windows 7 ultimate 64 bit like 5 times now, was having blue screens and stuff before, and was told to update to SP1, which i didnt even know about (head in the clouds) now im trying to install it and it seems damned near impossible. Ive tried downloading every possible windows...
Windows Updates & Activation
Win 7 asking for non-existant password
I have 3 computers on my home network. All are wired via gigabit connections. I have Windows 7 Professional installed on computers 1 & 2 and Windows 7 Home Premium on computer #3. All 3 computers see each other in the network display. All are set up for sharing and all can access the drives on...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App