Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Dell Bios Doesn't See IDE Hard Disks but Windows 7 Does & Works Fine.

07 Dec 2011   #1

Windows 7 Ultimate 32bit
Dell Bios Doesn't See IDE Hard Disks but Windows 7 Does & Works Fine.

I have Win7 Ultimate installed on a Dell Optiplex GX620 P4 hyperthread, approx 6 years old. Bios is most current Phoenix ROM Bios Plus 1.10 A11. I have 2 sata drives and 2 IDE drives installed. Boot is from SATA 0. SATA drives 2&3 are not present. All is well with this part of the equation.

I had been running a Seagate 250GB IDE drive (ST3250824A) as BIOS drive 4, master drive, jumper selected. I just installed a second 120gb Seagate IDE (ST3120026A) as a slave, BIOS drive 5. That was when things got interesting. When I rebooted BIOS took a long time to load, and then reported that neither IDE drive was present. I then did all the obvious things: Disconnected one drive at a time - BIOS would recognize the connected drive. Switched master & slave drive positions. Changed jumpering from master/slave to cable select. Installed a new ribbon cable. Checked that BIOS drive recognition was set to 'Auto' for both drives. Results are always the same: either drive is recognized when only one is connected but BIOS does not recognize them when both are installed. On boot I receive a warning that IDE Drives 4 & 5 are not present and have to press F1 to continue. When I enter Setup BIOS reports the drives as unknown drive type. When only one is connected BIOS accurately reports the drive model # & capacity.

After going through all this,I decided to bring WIn 7 up and see what would happen. To my surprise, W7 showed both drives and worked fine. Device Manager properly reported drive model & capacity. I have used the system in this configuration for several days and everything has worked fine.

This is not a problem, per se, since other than slow booting and having to press F1 every time I boot to bypass the BIOS "error" notice the system works fine but I am curious if anyone else has had this problem, and if they found a solution. I have considered forcing a reinstall of the BIOS but since it isn't really broken I don't want to try to fix it and make things worse. I googled this problem before coming here and could not find anyone with an identical situation on any tech site. Can I be the only one who's ever had this happen?

My System SpecsSystem Spec
07 Dec 2011   #2


The only time I've found something similar is when I had a CD drive as MASTER on an IDE port and a hard drive as slave. It seems BIOS would inquire or skip on the CD and not bother waiting for a response on the hard drive. Windows would see it fine as by that time, it was spun up, etc. But BIOS never showed it, only the CD drive. Access to hard drive was not a problem.
My System SpecsSystem Spec
07 Dec 2011   #3

Windows 7 Home Premium 64 bit

What happens when you remove the jumpers from both drives?
Hopefully the BIOS will see them. On newer systems, I'm not sure if using jumpers are necessary, but I could be wrong.

If using cable select, are both jumpers set to pins 5 and 6 on the drives?
My System SpecsSystem Spec

07 Dec 2011   #4

Windows 7 Ultimate 32bit


Have tried jumpers set to master/slave (jumper on master, none on slave) and cable select (both jumpers in same position). Not sure of pin numbers but I set them according to the diagrams on the drives. Removing jumpers on both drives would indicate both were slaves, but I guess its worth a try. Will have to wait till I get done resizing partitions on one of the drives to test this out, will get back to you with results. Thanks for the idea.
My System SpecsSystem Spec

 Dell Bios Doesn't See IDE Hard Disks but Windows 7 Does & Works Fine.

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 constantly locking up...while Win 10 works fine???
:confused: I have an old(er) HP Pavilion PC...couldn't tell you the correct specs because I had 3 towers hanging around at one point and so I combined the parts to make 1 fully functional PC. Anyways starting about 4 or 5 days ago my Windows 7(I have a dual boot config with Win 10 also) started...
General Discussion
Connecting HP printer works fine, but doesn't give me an icon...
I connected my HP Deskjet 450 and it downloaded the driver, it works fine, BUT it does not give me a notification icon or "safely remove hardware". So when I'm done printing I just disconnect the USB. ALSO, since it doesn't connect with the HP software, I can't see how much ink is left (!). ...
Hardware & Devices
Second Hard Drive doesn't show up in BIOS...(again)
hello everyone ^^ i have a problem with my second hard drive. my main/master hdd is a MAXTOR STM380215AS ATA with windows 7 and my second/slave it's a ST3250319AS ATA 250GB (i think T.T) windows XP Professional My second HDD it's newer then my maxtor(3-4 years) but the Seagate sometimes will...
Hardware & Devices
BIOS doesn't recognize hard drive but Windows does
First post, long time reader. Hopefully someone can help me with the following: I just recently got a hold of an older PC that I wanted to use for test purposes with Windows 7. The problem is that the BIOS on the PC does not recognize the Hard Drive. Upon startup I get the following message: ...
Hardware & Devices
Windows 7 Works fine except for Right clicking
Hey a few weeks ago i got a freshly installed windows 7.. works great, everything is good and clean. But last night I restarted my PC, suddenly sometimes when I right click the menu doesn't show up and the effect of the menu disappears. Ive tried searching for viruses and Trojans, a few showed up...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App