Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installed 4Gb Ram, only 2 Gb usable

19 Dec 2011   #1
OCModderz

Windows 7 Ultimate x64
 
 
Installed 4Gb Ram, only 2 Gb usable

Hi, new to the forums and I've been using my gaming rig for a while now. My motherboard is the ASUS Maximus III Formula, using Intel Core I5 760. And I recently did a dual boot on my system. One copy of Windows 7 Ultimate x64 on my original hard drive, and a Windows 7 Home premium x64 bit on another hard drive ( Hitachi ) and after a month or two, I had to format that ( Hitachi ) hard drive as I needed it for extra storage and now I'm getting only 2 Gb usable RAM but I installed 4Gb.

Please help


My System SpecsSystem Spec
.
19 Dec 2011   #2
OCModderz

Windows 7 Ultimate x64
 
 

additional information

My System SpecsSystem Spec
19 Dec 2011   #3
mgp1964

Windows 7 Pro x64
 
 

Strange, I would try clearing the CMOS, let us know if that works or not.
My System SpecsSystem Spec
.

19 Dec 2011   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Do you have the same situation with the other OS? If not, it is an OS problem we have to look for.
My System SpecsSystem Spec
19 Dec 2011   #5
OCModderz

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by mgp1964 View Post
Strange, I would try clearing the CMOS, let us know if that works or not.
I cleared a few times, nothing worked
My System SpecsSystem Spec
19 Dec 2011   #6
OCModderz

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by whs View Post
Do you have the same situation with the other OS? If not, it is an OS problem we have to look for.
I only have windows vista Ultimate 64 bit, should I install on another hard drive?
My System SpecsSystem Spec
20 Dec 2011   #7
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Quote   Quote: Originally Posted by OCModderz View Post
Quote   Quote: Originally Posted by whs View Post
Do you have the same situation with the other OS? If not, it is an OS problem we have to look for.
I only have windows vista Ultimate 64 bit, should I install on another hard drive?
No, I don't think that would help. You could try a live Linux disk and see whether that is the same.

Also, check in msconfig > Boot tab > Advanced options. Click the little box "Maximum Memory" - what does it say there and what happens when you set it to 4GBs
My System SpecsSystem Spec
20 Dec 2011   #8
OCModderz

Windows 7 Ultimate x64
 
 

When I checked the maximum memory box, it writes 4096
My System SpecsSystem Spec
20 Dec 2011   #9
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

So there does not seem to be any physical problem - like bad connection. Do you have any idea what piece of hardware could be using the 2GBs all of a sudden.
My System SpecsSystem Spec
20 Dec 2011   #10
OCModderz

Windows 7 Ultimate x64
 
 

Hmm, I might just found the cause of all this, I have a faulty DIMM slot but I don't know if I should RMA my motherboard because Im using a LGA1156 mobo. But thanks for the given suggestions and help :)
My System SpecsSystem Spec
Reply

 Installed 4Gb Ram, only 2 Gb usable




Thread Tools




Similar help and support threads
Thread Forum
4GB Installed only 2GB usable
Sorry guys, I had to post another topic about this. I already understand why PAE isn't enabled on 32-bit versions. This is making me uncomfortable seeing that only a half of the memory is being used and the remaining is sitting there doing nothing. I'm not even getting better performance it's...
Hardware & Devices
8 GB RAM installed (3.98) usable
Hi all, Have check everywhere for a solution do this. I have recently build my own pc and its going great But i have 2x4gb ram chips installed dual channel and its only detecting 4gb usable there is no memory mapping for my mobo and yes im on a 64 bit system have tried everything can...
General Discussion
Installed vs Usable Ram
I've got a new Dell XPS 8100, i5-750. Shows: Installed Ram: 6 gb (2.96 gb usable) System: 64 bit System managed paging, which shows a page size of 3 gb. I have a GTS 240 1 gb card. Shouldn't all my Ram be usable? Suggestions?
Performance & Maintenance
RAM: 4GB installed and only 2.93 usable.
I have 4GB installed and only 2.93 usable. I tried the solution given by rektalstab 1)Run 2)type "msconfig" 3)Go under the "boot" tab 4)click "advanced options" button 5)UNCHECK! "Maximum memory" 6)Reboot
Hardware & Devices
6 GB Installed (3 GB usable)
Howdy! So I've read up a bit on this from other posts of the same problem and here's what I've tried: Tried msconfig---every time I try to set the amount to anything above 2048 it resets. Tried deselecting "Max Memory" and it shows the same amount. Updated BIOS (Which only detected 3063...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:37.
Twitter Facebook Google+