Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to print "The printer has not yet responded, but the ..."

02 Jan 2012   #1

windows 7 home premium 64 bit
Unable to print "The printer has not yet responded, but the ..."

I am unable to print from any program. Printers seemed to be installed OK. When I select print, the program freezes and displays the message "The printer has not yet responded, but the Microsoft Office program may be able to proceed without printer information. Do you want to continue to wait for the printer?". If I say no I get the printer dialogue box with the printer line blank, but all printers displayed below the bank line. If I select one of the printers I get the message "The active directory domain services is currently unavailable".
I tried googling the problem, but cannot find an answer. Any ideas?

My System SpecsSystem Spec
02 Jan 2012   #2


Hi, are you using any printer sharing (USB device share) software? This can cause such behaviour. Additionally it could be a USB glitch - have you tried changing the printer to another USB port? If it's a network printer or you are trying to access a printer on another workstation then there would be other steps to take...

Obviously you need a printer that has sufficient consumables on hand, and silly as it sounds, make sure there are no paper jams...
My System SpecsSystem Spec
02 Jan 2012   #3
The Howling Wolves

Windows 7 Home Premium 64bit

Tagging along with Qdos....If not sharing the printer go into control panel/devices and printers/remove all printers/unplug USB connection/reboot.
After your system has started then plug in the printer's usb connection and Windows 7 should find a new device is being added.
I have been down that road before and the steps above corrected mine.
Post back if more help needed.
My System SpecsSystem Spec


 Unable to print "The printer has not yet responded, but the ..."

Thread Tools

Similar help and support threads
Thread Forum
"Access is denied" - "Unable to display current owner"
Hi, I just tried to install the latest iTunes update, but keep getting an error when it tries to access the C:\Program Files\iPod folder. When I try to access the iPod folder directly through Windows Explorer, I get "Access is denied". The same happens when logged in with the system...
Network & Sharing
Cannot print from "How do you want to print your picture screen?"
When I try to print from photoviewer screen headed "How do you want to print your pictures? , the botton part of the screen where the "PRINT" command is located is cut off from the screen. As I cannot click on this, I am unable to print the image. Is there any way that I can ge a full screen so...
General Discussion
Computer isnt seeing wireless printer when trying to add "New Printer"
I've had the worst luck with this HP Officejet 6500. For some reason my computer always sees it as "offline" Well the only way to get it back online is to delete the old printer & add a "New Printer" via Devices & Printers Usually that works even though it's severely a pain in the a**! ...
Network & Sharing
Printer Services Haywire & "Add Printer" Broken
Hi. I'm running Windows 7 Ultimate 64-bit. Suddenly, my printer no longer receives recognition from the computer. It worked just fine for over 6 months, and simply won't be recognized any longer. Re-installing drivers doesn't help. Any ideas? I have attached some pictures for reference. ...
Hardware & Devices
Cannot print to a "Shared" Printer on Win 7 Ultimate 64
I have searched and can't seem to find the solution!! Cannot print to a "Shared" Printer on Win 7 Ultimate 64 from a Vist 32bit machine. I can see the printer, but then it says that the drive is incorrect. It says that the *.inf file is not correct. I cannot figure this out!
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App