Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 16 GB SanDisk Cruzer suddenly becomes write protected!

02 Jan 2012   #1

Windows 7 Home Premium 64-bit
16 GB SanDisk Cruzer suddenly becomes write protected!

Got a 16 GB SanDisk Cruizer flash drive and it did well - until I swapped my hard drive for an SSD.

Since the SSD conversion, the ReadyBoost file on it does not work - Windows won't use it because I have an SSD - that' fine. The real problem is the SanDisk became write protected - can't format, can't delete.

Don't have a problem with a 1 GB flash drive - a SanDisk problem?

Already tried rededit, going to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\StorageDevicePolicies and entering WriteProtect = 0

My System SpecsSystem Spec
02 Jan 2012   #2

Windows 7 profesional

Well try to use a boot partition manager. This allows you to boot from a CD to manage partitions. You can use this to format your flash drive. Search google for boot partition manager.
My System SpecsSystem Spec

 16 GB SanDisk Cruzer suddenly becomes write protected!

Thread Tools

Similar help and support threads
Thread Forum
Sandisk cruzer blade 64GB not detected in my computer
Hello everyone! :) I just bought a new sandisk cruzer blade 64bit, it worked fine and the win 7 detected it, and I wanted to format it to NTFS, but I couldn't, so I formated it into Fat32, because it was on exFat, and then I converted from Fat32 to NTFS by using "Mini partition wizard" .. and I...
Hardware & Devices
Error with nearly-new 32Gb Sandisk Cruzer Glide
It now reports itself as a Sandisk Firebird with 64Mb total and it is reported by Win7 Home Premium x64 as of type RAW, when I know it should be either VFAT or FAT32. Have scanned drive with Easeus Partition Manager (nada, except same report) and Minitool Partition Wizard Home Edition (also, same...
Sandisk U3 Cruzer Micro won't load U3 software
I've updated my U3 drive to the newest version. When I plug in it occupies J: (the "CD Drive") and K:. When I try to run the U3 launcher it tells me Windows has mounted it on a drive that was already occupied and that I can't start it. Disk management won't let me change the drive letter of...
Hardware & Devices
Backing up to a sandisk 8 gb cruzer
I have been writing before in a different forum that had kind of died out. I just bought a Cruzer Blade USB flash drive, 8 gb, to back up my computer - windows 7. It still doesn't like it. I cannot get an external hard drive and this wasn't that expensive. It says to please insert a d/dvd/or...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:47.
Twitter Facebook