Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Printer stopped working for no apparent reason

14 Jan 2012   #1

Windows 7 Home Premium SP-1 64-bit
Printer stopped working for no apparent reason

I apologize in advance for how disorganized this post will probably be. I recently got a new PC, with Win 7 on it, which is new to me. I have had it for a month, and a week or two ago I noticed that the printer was no longer working - I don't use it that much, so I can't say exactly *when* it stopped working, but I *do* know that it did work when I first got the new system. This makes me suspect that a Windows Update hosed things at some point. BTW, I am running Win 7 Home Premium SP1.

Anyway, the actual problem is that every time I try to print now, the printer "uh-oh" box pops up in the middle of the screen and says "Printer not reponding". If I am not trying to print but just click on the little printer icon in the lower right task bar, I get the same box and the same msg. I remember having this problem periodically with the Toshiba laptop (with Windows Vista) that I had before I got this hot new system, but I could usually power-cycle the printer and get it to come back online and print. And it certainly was not totally dead as it now is with the new Win 7 system.

I have researched this a good deal on the net. I have re-started the Print Spooler Service, ran the Hardware Troubleshooter (which didn't help because it couldn't find a printer). This printer, a Kodak 5100 All-in-One, was set as default printer. The Kodak site told me to run the "Kodak Printer Setup Utility", which I did. It failed to find the much for that. Next, I un-installed all the Kodak software, then downloaded the latest version, with drivers, all of which was newer than what I had. When it was done installing the software, it went thru the printer detection sequence, and failed to find the printer just like its older version had.

I read in several places that I should delete the printer and re-add it, so I tried this. I was unable to re-add the printer, though, because the Kodak software can't find it - perhaps deleting it was not the wisest thing to do...oh well. I am dead in the water now because Windows is supposed to automaticcally detect a USB printer when it is connected (isn't it ?), and it doesn't find mine.

BTW, the printer itself works...I just used it earlier tonight as a phot-copier. I have also tried several different USB ports, both front and back of the system case (no hubs or extenders here). I had finally decided that the cable was the only thing I could think of that was left, since the printer itself does actually work. Then it occurred to me to dig out the cheap Toshiba laptop that this hot new system replaced and try it with the printer...after all, it worked before. So I connected it back up to the Toshiba laptop, and it won't work on it, either, now.

I decided that this was incontrovertible evidence that the printer cable was the culprit, so I bought a new one, connected it, and.....nothing. Still won't detect the printer with the new cable attached!!

Now I'm completely bumfuzzled. I am a veteran problem solver and trouble-shooter. I remember in my old programming days, running a hardware debugger and tracing DOS interrupts through the OS code, and now I can't figure out what's wrong with a printer? Sheesh....

One last pearl of information that only adds to the craziness: I noticed when booting the new system that the AMI BIOS message says "USB devices found: 1 keyboard, 2 mice, and 3 hubs". I thought the "2 mice" was kind of strange, so I went into Device Manager, where I found two entries under "Mice and other pointing devices"! Both are titled "HID-compliant mouse" and are identical. If I delete one, my mouse stops working. If I delete the other, mouse still works, but next time I reboot, I have two mouses in Device Manager again. I thought this might be the key, that perhaps my BIOS was detecting the USB printer as a 2nd mouse. This is one reason I went back to the Toshiba used to work, and *should* still work, esp. in the light of my "phantom mouse" theory, but it doesn't, and so I have hit the proverbial brick wall.

Sorry for this wall of text. I can certainly afford to buy a new printer, but this is driving me nutters and I want to figure it out. Any and all input will be appreciated!!

My System SpecsSystem Spec
14 Jan 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

The key to keep in mind here is that it is an all-in-one printer. Just because one of the functions works does not mean they all do (or should).

The printer can't be recognized on either PC so that indicates a possible failure on the chip in the printer. It may also explain the phantom devices, because if the printer cannot communicate it's hardware ID but there is still some electrical connection then the PC is going to start 'guessing'. Run the PC without the printer connected and see if the second mouse disappears.

Sometimes you can revive these devices if you can reset them. The easiest method is to shut down the printer, unplug it from the wall, press the power button and hold it for 20 seconds or so to dissipate any residual power in the board, and then start it up again.

If you check your manual there may be a reset hole somewhere where you can push a paperclip in to trip the rest button on the printed circuit board.

But it might be best to start preparing a eulogy.
Good Luck!
My System SpecsSystem Spec
08 Apr 2012   #3

windows 7 home premium
kodak 5300 stopped working

my kodak 5300 has also stopped working when using windows 7 on my main computer - compaq presario. Tried it on a sony netbook and can print from there so the problem seems to be with some sort of update on my main computer. Have uninstalled, removed device etc but when connecting up again it will try to load the latest software from Kodak but fails at the last part.
any ideas please?
My System SpecsSystem Spec

08 Apr 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

After uninstalling the printer, make sure it is unplugged before reinstalling the driver software and don't plug it in until it tells you to do so.
My System SpecsSystem Spec
11 Apr 2012   #5

windows 7 home premium
still no good!

Thanks for the suggestion about disconnecting power etc but it still failed to install the printer driver correctly. It seems to go through all the installation of the printer driver, scanner, etc but then just at the last stage it comes up with 'printer driver unsuccessful'
Back to square one again!
My System SpecsSystem Spec
11 Apr 2012   #6

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

It sounds like the OS can't "see" the printer, or vice versa. Some kind of communication error. You could try a different USB cable.

Are you certain you have the correct version of the Printer Driver for your version of Windows?
My System SpecsSystem Spec
19 Apr 2012   #7

windows 7 home premium

Have got the latest printer driver from Kodak and still it won't fully load. Also tried switching off the firewall while I was uploading this in case it was blocking out some part of the upload - no success. Tried the prinet on a different computer (Windows KP) and it works - so no issues with cables etc.
Kodak are trying to find out solution!
My System SpecsSystem Spec

 Printer stopped working for no apparent reason

Thread Tools

Similar help and support threads
Thread Forum
Multimedia key stopped working for some reason
Hi, i am using Esperanza Titanum Ranger TK105 which has some multimedia buttons. They worked fine with Winamp until i tested a keyboard for my friend, Esperanza Dallas. It had more multimedia buttons than mine, and they worked fine too. Then Windows Update said to install some HID Drivers, and i...
Hardware & Devices
Can't hear any sound for no apparent reason
Hi guys, My computer audio was working fine yesterday. I left it on throughout the night but now all of a sudden, I can't hear anything from it. I've checked a few common problems that may occur but to no avail. I've tried checking the: - Sound level sliders and mute settings (placed all on...
Sound & Audio
debug.log on start-up for no apparent reason?
Corrupt Index file Unable to move the cache: 5 Unable to move cache folder C:\Users\Gideon\AppData\Local\Facebook\Messenger\fbmessenger.cache to C:\Users\Gideon\AppData\Local\Facebook\Messenger\old_fbmessenger.cache_000 Unable to create cache WinHttpGetProxyForUrl failed: 12167 Corrupt...
Many programs 'stopped working' - what's the reason
Hello to all on this forum, Some time ago I restored system and after doing that some of the programs, like Autocad, Livemail, and some other .exe do not launch. It's just said 'program has stopped working and will be closed'. If it's about Live Mail, I tried almost everyghing - sfc...
General Discussion
BSODs for no apparent reason
BCCode: deaddead BCP1: 000000000F010012 BCP2: 00000000001C0410 BCP3: 0000000012BC0000 BCP4: 0000000000000000 OS Version: 6_1_7601
BSOD Help and Support
HG Sharing not working for no apparent reason
I had a homegroup on my network, composed of one desktop computer and 4 laptops (I'll call them Desktop, H, D, M and K for clarity). For a few weeks, everything was working fine. However, today I was on K and it was for some reason unable to connect to any of the other computers. I ran the HG...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App