Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot communicate with the scanner

27 Jul 2013   #11

Win 7 32
Cannot communicate with scanner

Quote   Quote: Originally Posted by Stokkers View Post
Hi all

I have just purchased an Epsom SX130

When selecting Epson Scan, I get the following error message:

'Cannot communicate with the scanner'

I have turned the printer off and back on again. Removed the power lead and plugged back in.

I have removed the USB lead and tried it in other ports, without hubs. I have also tried a brand new USB lead.

If I use PaintShop Pro X2 and select Import > Twain Acquire > I get the same message plus another message - 'No scanner Found', but if I select Twain source, I get the 'EPSON NX130/SX130/TX130/ME 340.

I can use the printer and copy functions with no problems, so, I am
assuming it may be something to do with the OS - Win 7 32 bit as I have tried using WIA and get the same results.

I have tried 2 other printers and am getting the same or similar reactions.

Is this a Windows problem and if so, is there a solution.

Back in November, I installed a new HDD and Win 7 Home Premium.

Similar problem reported in many forums for Canon, Epson, Dell etc scanners. Assuming power & USB or other signal connection OK reported solutions fall into two groups:
1. Win security & other settings as described in this forum.

2. Removing incompatible programs - the most likely source if it was OK then stopped working.
Reported culprits are Windows/Users/User name/App Data/Roaming/Microsoft/Windows/Network .... /My website on MSN or other file names; Box Sync and at least for me Apple Cloud for Windows.

All seem to be network related but MS network diagnostics do not seem to detect the problem.

My System SpecsSystem Spec
27 Mar 2014   #12

Windows 8.1 x86

I know this is an old post, however, people may still encounter this issue in the future. Although i could scan to my laptop,(epson sx230 printer) i could not do the same on my computer. Changing the usb cable from printer to pc solved the problem.
My System SpecsSystem Spec
27 Mar 2014   #13

Win 7 32
Different solution that worked for me

I have connected the same Cannon scanner to a WINXP desktop, WIN 7 laptop & WIN 8 laptop.
In each case the USB scanner was initially connected to a powered USB hub together with 2 other devices. After getting a variety of error messages, including unlocking the travel catch on the back, I connected it direct to a USB port on the PC. In each case it worked, & continues to work beautifully both when the PC's have been in home network mode & without.

I have also happened to notice that with the USB hub the PC/hub port numbers shown in Control Panel are not always the same.
My System SpecsSystem Spec

28 Mar 2014   #14

Windows 7

To everyone that might be having this problem. I found a solution posted by someone on the microsoft answers website that has also fixed the problem for me. Here is what the guy said.

"The problem is that the scanner is not finding your printer's IP address. You need to put it in manually to fix this. Go into the printers network settings and find out what IP address it is using. Then go to Epson Scan Settings and add a new printer with this IP address. Once you do that test the scanner's connection. I was having this exact problem with one of my two Epson printers and noticed that the one that had no issues had the IP address detected on its own while the one with problems couldn't find the IP address.

The scanner settings should be able to detect the IP address on its own. Not sure why it couldn't do it now when it did it successfully before for me. I don't know if the IP address might change everytime the printer or router is restarted as I haven't tested it yet. I wouldn't be surprised if it does as something triggered the scanner to fail and in my case, nothing was done apart from restarting an overheating router. Would be annoying having to manually change IP address all the time though."

Hope this solves the mystery for some people.
My System SpecsSystem Spec
03 Aug 2014   #15

Cannot communicate with scanner

You said to set the Epson Scan Settings manually to give PaperPort the correct IP address. I have a Canon MX870. I don't know where to find the settings in order to do this. Any ideas?
My System SpecsSystem Spec

 Cannot communicate with the scanner

Thread Tools

Similar help and support threads
Thread Forum
Cannot communicate with scanner, printer won't print, new problem
Windows 7 64-bit, Epson WF3520. Printer/scanner worked very well for 10 months, until about 10 days ago. Have uninstalled, reinstalled. Printer makes copies. Print jobs appear in que.
Hardware & Devices
NetBEUI not supported Win 7 - yet need to communicate with VPC 7
My laptop has virtualization HD support so I can run VPC 7 but since I do not have Premium et al but only Home Edition I cannot run XP Mode. Win 2000 inside VPC. Using Additions for 2004 I can get a decent screen display and mouse ability to not be locked in - but no data inside the HD of VPC can...
Network & Sharing
DNS server can't communicatE
My one year old laptop just randomly quit on me today and the dns won't connect Ipv6 is disabled I've tried making it static I've tried open dns I've tried the flushing renewing and all that And I've tried uninstalling the driver I'm completely out of ideas BTW my Xbox (wired) iPhone iPad...
Network & Sharing
Can't communicate with primary DNS
Hey guys. My girlfriend came to me with a computer problem. She can't use the wireless internet around home. I did some poking around and came up with the following information. (see attatched jpeg) and this from the command prompt But considering I'm a networking retard, I have no...
Network & Sharing
Printer unable to communicate with PC
Hi. I'm having problems with my printer (Dell V105 ) because every-time I try to print something I get the following: 'Printer unable to communicate with PC.' I have downloaded the latest driver software from the Dell website which seemed to install properly but the problem remains. Any...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:19.
Twitter Facebook Google+