Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot communicate with the scanner

14 Jan 2012   #1

Cannot communicate with the scanner

Hi all

I have just purchased an Epsom SX130

When selecting Epson Scan, I get the following error message:

'Cannot communicate with the scanner'

I have turned the printer off and back on again. Removed the power lead and plugged back in.

I have removed the USB lead and tried it in other ports, without hubs. I have also tried a brand new USB lead.

If I use PaintShop Pro X2 and select Import > Twain Acquire > I get the same message plus another message - 'No scanner Found', but if I select Twain source, I get the 'EPSON NX130/SX130/TX130/ME 340.

I can use the printer and copy functions with no problems, so, I am
assuming it may be something to do with the OS - Win 7 32 bit as I have tried using WIA and get the same results.

I have tried 2 other printers and am getting the same or similar reactions.

Is this a Windows problem and if so, is there a solution.

Back in November, I installed a new HDD and Win 7 Home Premium.


My System SpecsSystem Spec
14 Jan 2012   #2

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64

Some scanners require that you open ports in the Firewall.
Have you tried temporarily disabling the Windows firewall?
My System SpecsSystem Spec
14 Jan 2012   #3


Hi pb

Yep Have configured the firewall to accept the scanner. I have a feeling, after much chopping and changing, that the problem may have something to do with the USB connections, though I have now tried three leads and three printers. I have just reinstalled the software. It's also strange that the computer can send data to the printer, the copier scans and prints out, so, WHY can't the scanner scan to PC?

I will try anything to get this sorted.

My System SpecsSystem Spec

20 Jan 2012   #4

Windows 7 professional

Hi Stokkers
I have exactly the same problem with my Canon MP760 which I have been using successfully as both a printer and scanner for 6 months but last week recognition of the scanner funtion stopped after a MS update of my various programs. At the same time the Devices windows opened as a blank but the solution to that was on this forum by configuring Bluetooth to Auto.
When I open Paperport a message comes up saying the scanner is not attached but if I go to print I can print to the MP760.
There probably is a similar solution as with Bluetooth if I can find it.
Any ideas would be appreciated
My System SpecsSystem Spec
20 Jan 2012   #5

Windows 7 HP / Ultimate x64

The USB cable would be my suspect.

I used to receive such messages either while printing or scanning, simply because the USB cable wasn't firmly in place (or a little bent). Just straighten things out, move it around a bit, and voila! the device is detected again and the scanning/printing resumes.

One way of avoiding such problems is to get a sturdy, good quality Printer USB cable.
My System SpecsSystem Spec
20 Jan 2012   #6

Windows 7 professional

Hi Reviversoft
I have tried another USB cable which makes no difference and tried the MP760 on my P4 running XP Pro where it works fine.
There must be a MS glitch in the update or a reset somewhere waiting to be found.
My System SpecsSystem Spec
21 Jan 2012   #7

Windows 7 professional

Hi Stokkers
I found the problem in Administrative Tools/Component services/Services (local) where UPnP had been disabled, enabling it to start solved the problem and the scanner was connected.

Try It
My System SpecsSystem Spec
12 Aug 2012   #8

Windows 7 Home Premium x64
Both scanners stopped working

I am having a similar problem, but I have two scanners - a Canon dedicated flatbed and an Epson all-in-one. Both were working fine back in June. Somewhere between the middle of June and the 7th of July (2012) they both stopped working - as did my DVD burner.

Windows had done several critical updates and now neither scanner will work (the DVD I got working again).

I have uninstalled both scanners and reinstalled them separately. Both show up in Device Manager as working. The Epson Scan Setup utility shows the scanner as ready and the printer works (USB connection). However the Epson Scan driver - even called directly show the error "Cannot Communicate with the scanner". A very similar message shows up when trying to scan with the CanoScan.

I have been searching forums and trying everything I can, but to no avail. I don't know what changed, but it was definitely related to a Windows update - not addition of new hardware or software.

Also it cannot be the scanners themselves as they both were functional - not conflicting before this update. I had SP1 installed (Win7 Home Premium x64) prior to this update and everything was working smoothly. Now everything works but the scanners.

I have uninstalled both through Device Manager and through the Control Panel uninstall. I have allowed Windows to assign the drivers, and I have followed the original installation - all to no avail.

I have also tried direct connections and through the hub - no difference (the Epson is always direct connected) and the printer works fine, and I can perform a copy (scan and print) locally on the Epson.

Any help would be appreciated. This has me stumped (I did try the uPnP and it is enabled - also tried disabling).
My System SpecsSystem Spec
24 Aug 2012   #9

Windows 7 64bit
Fixed-Issue with scanner communication

I solved this issue with my Canon Pixma MP830 on Windows 7 as follows:
  • On the Control Panel go to "Find and Fix Problems" under System and Security
  • Next, under Programs select "Run Programs made for previous versions of Windows"
  • A box will appear (Program Compatibility). Press the "Next." It will begin to detect programs that may have compatibility problems with windows 7.
  • Scroll down and select MP Navigator 2.2 (or whatever scanning software came with your scanner), then select "Next"
  • Select "Fix Using Recommended Settings". It will next prompt you to test their recommended setting by starting the program (in my case running through Windows XP service pack 2 settings). Select "start the Program"
  • If the test works (as it did in my case) it will ask you to save the new settings. The problem is now resolved. I hope this helps.
It appears the issue is with the scanning image software (MP Navigator 2.2) and nothing with the scanner itself. Like many, my printer/scanner combo worked fine until an update earlier in the year. The printer worked fine, but the scanning function stopped working.
My System SpecsSystem Spec
30 Oct 2012   #10

Windows 10 (64 bit)

Sepuca thanks for the advice! I had a Fax program that after a Windows update did not pick up the correct Twain driver. After following your procedure I was able to scan from the fax program.
My System SpecsSystem Spec

 Cannot communicate with the scanner

Thread Tools

Similar help and support threads
Thread Forum
Cannot communicate with scanner, printer won't print, new problem
Windows 7 64-bit, Epson WF3520. Printer/scanner worked very well for 10 months, until about 10 days ago. Have uninstalled, reinstalled. Printer makes copies. Print jobs appear in que.
Hardware & Devices
NetBEUI not supported Win 7 - yet need to communicate with VPC 7
My laptop has virtualization HD support so I can run VPC 7 but since I do not have Premium et al but only Home Edition I cannot run XP Mode. Win 2000 inside VPC. Using Additions for 2004 I can get a decent screen display and mouse ability to not be locked in - but no data inside the HD of VPC can...
Network & Sharing
DNS server can't communicatE
My one year old laptop just randomly quit on me today and the dns won't connect Ipv6 is disabled I've tried making it static I've tried open dns I've tried the flushing renewing and all that And I've tried uninstalling the driver I'm completely out of ideas BTW my Xbox (wired) iPhone iPad...
Network & Sharing
Can't communicate with primary DNS
Hey guys. My girlfriend came to me with a computer problem. She can't use the wireless internet around home. I did some poking around and came up with the following information. (see attatched jpeg) and this from the command prompt But considering I'm a networking retard, I have no...
Network & Sharing
Printer unable to communicate with PC
Hi. I'm having problems with my printer (Dell V105 ) because every-time I try to print something I get the following: 'Printer unable to communicate with PC.' I have downloaded the latest driver software from the Dell website which seemed to install properly but the problem remains. Any...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:42.
Twitter Facebook Google+