Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Flashdrive could not be found - Error Code 39

15 Jan 2012   #1

Windows 7
USB Flashdrive could not be found - Error Code 39

Hello everyone,

i have a big problem with my usb ports.

I have the problem since 2 weeks. I think the problem started when i tried to reinstall Acronis True image. I had the version 2012 and couldnt deinstall it, so i deleted all acronis keys in registry. After some permission problems in registry i finaly have installed 2011 version again.

But problem now is, that no USB Flash Stick, USB external harddrive cant be found. im getting this error:

windows cannot load the device driver for this hardware. the driver may be corrupted or missing. (code 39)
But when i connect my iphone, and my digitalcamera everything works.

What i have tried:

to delete upperfilter, lowerfilters in registry. found some help solutions on google search. but did not helped. After deleting that keys i cannot start windows. it ends with a bluescreen and restarts. so i recovered the last restorepoint. ( i dont have an older restorepoint )

i tried to deinstall that driver and reinstall it, tried to update chipset drivers from mainboard.
tried to make a startup repair.
nothing helped.

Anyone else have some ideas how to repair ? I dont want to reinstall windows. I hate to reinstalling windows.

maybe you can help me

My System SpecsSystem Spec
15 Jan 2012   #2

Microsoft Community Contributor Award Recipient


Hello Tigerking and welcome to Seven Forums. Sorry to hear you're having these issues.

Don't know if this will help or not but it won't hurt to try running a System File Checker scan from an elevated command prompt (Option Two, this tutorial.) If any problems are noted, run the scan 3 times rebooting in between each scan.

SFC /SCANNOW Command - System File Checker

If your computer is from one of the big builders like HP, Dell, Acer, etc you could go to their support site and make sure you have the latest drivers for your machine.
My System SpecsSystem Spec
15 Jan 2012   #3

Windows 7 Home Premium 32 bit

Try this.

Download v0.8.1 from Drive Tools for Windows

Extract it to a folder. It will have two folders Win32 (for 32 bit Windows) and X64 (for 64 bit Windows) containing DriveCleanup.exe. Copy the appropritae .exe file to your C > Windows >System32 folder.

Unplug all USB devices (except the USB KB/Mouse).

Open an elevated Command Prompt, type drivecleanup.exe and press ENTER. ( Start Menu > All programs > Accessories > Right click on Command Prompt > Run as Administrator)

This will cleanup all the USB drivers and associated registry entries and you will be starting with a clean slate.

All devices will be recognised afresh as you plugin and the approprite drivers installed afresh.

Hope this resolves your problem.
My System SpecsSystem Spec

15 Jan 2012   #4

Windows 7

hi, thanks for the help. im ready to try everything. the System File checker havent found any errors. Not helped

The Drivecleanup tool i already tried, but without success.

Thank you.
My System SpecsSystem Spec
15 Jan 2012   #5

Windows 7 Home Premium 64 bit

Next thing to try is a earlier restore point prior to the problem. When you deleted all the Acronis files and folders you deleted something that was associated with the USB drivers. So you have to get back prior to the problem.
My System SpecsSystem Spec
15 Jan 2012   #6

Windows 7 Home Premium 32 bit

hmmm... I think your computer is very badly messed up with Acronis. Please wait to see if someone else can help you.

And yep if you have a restore point before you even touched anything Acronis it should help as 1Bowtie suggests.
My System SpecsSystem Spec
15 Jan 2012   #7

Windows 7

Thats the big problem. there is no restore point :/ damn
My System SpecsSystem Spec
15 Jan 2012   #8

win 7 X64 Ultimate SP1
2012 Web of Destruction

I did an uninstall of 2012 and it refused to give me back my computer. This link will describe some of the problems it presents.

Leftover Drivers? | Knowledge Base

The only solution for me in the end was a clean reinstall. Good Luck!
My System SpecsSystem Spec
15 Jan 2012   #9

Windows 7

oh damn acronis .... so much problems. the thread is interesting, but dificult to understand for me. What can i do ? Isnt there any registry backup, repair tool that can fix it ?
My System SpecsSystem Spec
15 Jan 2012   #10

win 7 X64 Ultimate SP1
Bad News

I do not know of any registry tools that will clean up the Acronis mess. If you have an image of your OS prior to installation of ATI 2012 that would work. If you don't have such an image I am afraid you are stuck. To get further help you need to fill out your "system specs".

System Info - See Your System Specs

Access System Specs from your user control panel or click the link at the left bottom of your post. That info will be of help to someone helping you.

Your disk drivers and hard to tell what else (in your case USB) are being "messed" over by the ATI entries left in the registry. In my case I couldn't find a way to rectify it with out a clean install. Your manufaturer should have some kind of restore to "new condition" software. Once again you need to post your specs so people can help you find what is available. I am afraid that you are headed for a clean install from scratch. When you post the specs there may be some more suggestions. There are tutorials availabe here for clean installs.

I have quit Acronis.
My System SpecsSystem Spec

 USB Flashdrive could not be found - Error Code 39

Thread Tools

Similar help and support threads
Thread Forum
Driver for USB controller is not found. Error code 28 in dev manager
Yesterday I did a fresh install of windows 7 home premium. Everything went well, until I installed the drivers for the motherboard. I have an Asus Sabertooth z77 motherboard. I installed all the drivers with the installation disc's I already had laying around. I have uploaded five images which may...
Error 'code: 0x80070035 The network path was not found (VMWare)
Hello, I have a problem with my setup, i think it is a pretty common problem but i still cant find a solution that works for me, so maybe someone can help. I get the following error message on my Win 7 Ultimate virtual machine on VMWare Workstation 11. "Error 'code: 0x80070035 The network path...
Network & Sharing
Error 'code: 0x80070035 The network path was not found
Hey everyone, I keep getting Error code: 0x80070035 The network path was not found error whenever I try to connect to any other computer (running windows 7 ultimate) on my network. I have another computer with windows 7 ultimate that does not have this problem. Firewalls are disabled on all...
Network & Sharing
No Wireless Network Found error code: 0x80131522
Hi all, This am I got onto my network fine. Shut down. Ran some errands. Came back and I can't get online. I get this message. Anyone ever see it?
Network & Sharing
Error Code 0-80070035 the network path was not found. PLEASE HELP!!
I have a lap-top and and a desktop that i am trying to share files between. They are both running windows 7 home premium and the laptop is 64bit and the desktop is 32bit. The desktop is able to access the lap-tops shared files but the lap-top cannot access the desktop however the desktop does...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:07.
Twitter Facebook Google+