Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: My mouse no longer works on this OS. Need help identifying issue

18 Jan 2012   #1
sketchygio

Seven
 
 
My mouse no longer works on this OS. Need help identifying issue

Hello all, I'm new at the forums, and I have an issue I'm hoping you can help me solve.

I have a cheap USB Gigaware mouse from radioshack that stopped working out of nowhere a few days ago. It may not sound strange but here's some interesting details:

I am running seven on my imac, and whenever I boot in the mac partition, the mouse works fine (same USB slot). But in windows as soon as it boots (or plug in the mouse) I get the small bubble notification saying that the computer found a new USB device (even though I've been using it for months now) and then gives me a new notification to tell me it's installed. However, the mouse does not respond to any input (no movement or clicking). After that, Windows proceeds to make the "new hardware is found" sound over and over again with 1-2 minute intervals. So I know the mouse is working, and it must be a software related issue.

I thought it might be a driver issue so I tried using the System Preparation Tool 3.14 (as directed in this guide Windows 7 Installation - Transfer to a New Computer) hoping to reset some drivers to default and that it would fix the issue, to no avail. Also I have tried doing a Repair install but an error will not allow me to do so.

So does anyone have any idea why a mouse that works fine would stop working all of a sudden?


My System SpecsSystem Spec
.
18 Jan 2012   #2
Qdos

 

W7 isn't designed to run on your hardware in truth.

Try swapping USB ports, and failing that then try a better mouse is all I can suggest.

No guarantees, your hardware setup isn't exactly orthodox
My System SpecsSystem Spec
18 Jan 2012   #3
sketchygio

Seven
 
 

Quote   Quote: Originally Posted by Qdos View Post
W7 isn't designed to run on your hardware in truth.

Try swapping USB ports, and failing that then try a better mouse is all I can suggest.

No guarantees, your hardware setup isn't exactly orthodox
No offense, but I knew I would get this sort of answer. While I understand what you mean, it's not really a justified answer. I'm running all sorts of hardware fine off the computer (from keyboards, speakers to a cintiq). Now I know it's not the native system for the OS. Of course I use the PC partition as a gaming platform and I run a plethora of programs quite flawlessly.

But please, without turning this thread into a "your computer is not supposed to have windows" discussion, let me reiterate that the mouse has been working fine for several months (we're not talking about a system failure, here). The only reason I brought up my Imac was to point out the functionality of both the mouse and USB ports. This is a problem with the OS and I'm sure it's something quite trivial to boot but it's killing me.

Edit: oh and I'm sorry I forgot to mention, yes I have tried switching ports and I am currently using a different mouse. All ports work fine and the Gigaware mouse works fine. But it's not being registered.
My System SpecsSystem Spec
.

18 Jan 2012   #4
Qdos

 

There was no offence in my earlier reply either. I'm sorry if you do not find the response to your liking. Good luck trying to resolve the issue - I've had issues with various mice under W7 full stop, it's just that a number of them are not properly supported and when you run into such issues it may prove necessary to change the device for something that is complaint.
My System SpecsSystem Spec
18 Jan 2012   #5
sketchygio

Seven
 
 

Yup, no offense taken! I do appreciate any advice given. But I do want to continue searching for a working solution as I do really like this mouse model (and buying a new one won't fix the issue).

So if you do have any other ideas, I would really appreciate that as well.
My System SpecsSystem Spec
19 Jan 2012   #6
sketchygio

Seven
 
 

Bump.

Still could use some help with this issue. This mouse mysteriously works on every other computer I tried it on...
My System SpecsSystem Spec
Reply

 My mouse no longer works on this OS. Need help identifying issue




Thread Tools




Similar help and support threads
Thread Forum
zoom scroll no longer works in mouse
Had to reinstal my Win7 after not being happy with Win 10 download - found I cannot use my cordless Logitec M210 mouse to zoom in & out using scroll anymore - tried Mouse settings/Control Panel & Keyboard sett's - no settings for zoom there. Can zoom in on pictures in Win Photo Viewer using...
Hardware & Devices
USB 3.0 no longer works
I bought an HP Pavilion 2 years ago. AMD A-10 proc with 8gig mem. Worked fine for 6 months. HDMI quit working. Started using VGA. Bought Seagate USB 3.0 2 TByte for backup. Worked fine. 18 months later MSI MS-7778 motherboard started giving me trouble on start up. I'd push the power button...
Hardware & Devices
Backup no longer works
Haven't run a backup with Backup and Restore for a while as I've been using Geniesoft Timeline, but I like to keep 2 backups and run B&R occasionally to an external drive M:. Today, I have the problem shown in screenshot attached. Not sure what it means. The external drive is accessible as I can...
Backup and Restore
Keyboard/Mouse wake up from Sleep no longer works
Something has recently changed and I can no longer wake up my Win7 Ultimate PC from Sleep state using mouse movement or "Sleep" button on multimedia keyboard. I have to push the power button on the PC itself. This worked fine up until a few days ago. I did not make any changes to the power...
General Discussion
Third Mouse Button No Longer Works.
My Third Mouse button stopped working out of the blue. I have no idea as to what might have caused this problem. I have a Logitech Wireless Mouse M205, and The Middle mouse button just won't work, the scroll wheel works fine, i've tried looking for a solution online but have yet to come up with...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App