Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Tosh A2OO reboots when both battery and PSU plugged in

18 Jan 2012   #1

Windows 7 Home Premium 64 Bit OS
Tosh A2OO reboots when both battery and PSU plugged in

Hey folks.

So I am looking for second and third opinions on what may be wrong with my
old Toshiba Satellite A2OO. The problem that I have is that when I plug in the PSU with the battery in the machine wants to shut down and restart.

I have just received shipment of a new compatible battery from Hong Kong believing the old battery to be the problem. The battery is definitely compatible and yet the problem persists. In fact the computer works fine on the new battery. I can connect the PSU while the machine is not powered up and the battery will charge to full, however if the machine IS powered on battery and then the PSU connected, the battery charge indicator shows that it is charging but then stops and the machine shuts down and restarts soon after (this happens in a loop).

I have tried the following:

1) Run the laptop only on battery (machine works fine)
2) Plugged in PSU while machine is running on battery (shutdown occurs)
3) Plugged in PSU with battery in before boot (shutdown and restart occurs)
4) Charged battery using PSU with machine powered down (successful battery charge)
5) Removed battery and powered on the machine with PSU ONLY (causes shutdowns and restarts)
6) Changed all power plan settings to the same for power as the battery (saw that this worked for someone elsewhere but no change for myself) and tried resetting all plans to default settings
7) Checked that I have the latest BIOS (affirmative)

This has been a well documented issue for older Toshiba models and I also found information about not using Bluetooth and Upek fingerprint utilities due to Wireless interference and other, but this to has caused no change. I am unable to find a definitive answer to the problem as fixes, or lack thereof seem to be different in each case.

IMO from what I have explained:
1) The battery is fine (the issue occured prior to replacement battery also)
2) The power supply is OK as it will charge the battery if the machine is not powered up
3) It is not an overheating issue as I have opened the laptop and cleaned the cooling system and re-applied thermal paste (problem was occuring prior to this and the machine is reassembled correctly)

I have come to the conclusion that this is more than likely a mainboard issue
ie: power regulation (bad regulator chip?)/ faulty capcitor losing charge and dropping current to the rest of the mobo/ bad capacitor/ bad resistor/ bad diode/ bad BGA chip.

If this is in fact the case then my dear old Tosh A200 is bound for ebay in parts (guess I could get a few dollars for wireless card etc etc).

In the meantime I am going to try to get a hold of a compatible PSU to fully eliminate that as a possibility. I am wondering though if the PSU would still charge the machine when powered down but may have a slight fault (ie: wiring?) which may cause shutdown/restarts when powered on?

Any ideas and/or second opinions appreciated

Thanks in advance.

Note: Also saw that Toshiba power management software can be a cause but I dont have this installed. This machine used to have Vista Ultimate (32 bit) factory installed. I have now got it running (sort of) a dual boot Windows 7 Pro 32 bit / Vista Ultimate 32 bit. Memtest has passed as has hard drive testing. Machine has 2Gig RAM and Intel Centrino Core 2 Duo.

My System SpecsSystem Spec
19 Jan 2012   #2
Fred Garvin


Not sure I can really add anything useful, but... Does the power supply have an LED light on it and if so, does it go out when you connect the PS while the battery is installed? Can you boot to a Memtest cd while the battery & PS are both connected to the laptop?
My System SpecsSystem Spec
19 Jan 2012   #3

Windows 7 Home Premium 64 Bit OS

Hey Fred

Thanks very much for your reply. Power supply has no LED indicator on the pack itself, I have
had the machine shut down for the last couple of hours with the PSU plugged in
and the light on the lappy is orange when charging and has now turned blue - I will assume that
means that it is now fully charged.

The problem is when I boot either of the OS's with PSU connected and battery in, it is
then that in the System Tray the charging indicator works for maybe 30 seconds and then stops - as in
if the indicator says 50% then it will pause at that level and soon thereafter the system shuts down,
reboots, asks if I want to start normally and if I do it will sometimes let me get to
the login screen, sometimes it will shut down and reboot before that, and sometimes it will let
me sign in and the system will run for random lengths of time before shutting down and rebooting itself.

Both of the OS installations are fresh with minimal program and device installs. As I said, I came across info about Bluetooth and fingerprint software so I have now uninstalled the Bluetooth and disabled
the fingerprint utility (uninstalled fingerprint from Programs but for some reason it keeps the driver listed in device manager and Windows keeps asking if I want to start it???).

As for booting memtest with both battery & PSU I did that when I clean installed the OS's. For some reason,
this seems to happen usually after I have installed the missing drivers that a Windows 7 install cant find.
Usually these are Texas Instruments multi card reader, Chicony 2.0 Webcam driver and an unknown device.
The unknown device is the Bluetooth stack for Windows by Toshiba. I don't really
use the Bluetooth so it doesn't really bother me to uninstall it.

I seem to keep going around in circles in relation to this problem. I'm getting to the point where I'm thinking of yet ANOTHER hard drive format with Killdisk and ANOTHER fresh OS install after which I will not install a thing including the Multi card Reader and the Webcam etc. That way I guess I can eliminate software as a cause if I power the machine and it stays on - I will run the machine and see if the problem recurs.

I had the machine turned on and running on the battery without a problem for 20 minutes. I then plugged the PSU in and I get the shutdown again!!!

If anyone else has any ideas please do tell.

Thanks in advance.
My System SpecsSystem Spec

19 Jan 2012   #4

Windows 7 Home Premium 64 Bit OS


So I have tried power options again with both Bluetooth Stack and Manager + the
Upek Fingerprint utility uninstalled - no difference unfortunately.

I did try the PSU in when the battery dropped to about 90% charge and the PSU did charge the battery
to capacity but soon after the shutdown/restart occured again.
After the restart I ran the machine on the battery until the battery was nearly fully out of charge
without a problem.

So - the story seems to be that the machine will not stay operating when both the battery is in and the PSU are connected at the same time. The battery will work by itself and the power supply will charge the battery so long as the machine is not booted.

Does that really only leave the motherboard and the things I have mentioned here?:
I have come to the conclusion that this is more than likely a mainboard issue
ie: power regulation (bad regulator chip?)/ faulty capcitor losing charge and dropping current to the rest of the mobo/ bad capacitor/ bad resistor/ bad diode/ bad BGA chip.
Please guys/gals - I am after a second opinion from one of the hardware people at the forum who do this stuff day in and day out and therefore have far more experience than me. I really don't want to scrap the machine if this could be something besides the mobo.
My System SpecsSystem Spec
19 Jan 2012   #5
Fred Garvin


AllontheBus, it sounds like you have done quite a bit of troubleshooting. The reason I asked if you were able to run Memtest with the battery and power supply installed is because that would have completely eliminated any interference with Windows, software or drivers. You could physically Remove the hard drive and boot to a PE disc like Memtest or Prime - anything that runs in RAM (w/o the need for temp files on a HD) - and see if you still have the shut down problem. No need to reinstall Windows.

Do you have another power supply with the same voltage and amperage to use as a test?

Yes, barring the above or a short, I would lean towards your conclusion of something like the voltage regulator circuit, but I'm not an electronics or circuit board expert by any means. On the other hand, if there was a problem in the circuit, your power lights *should* indicate the problem with a sequence of flashes/trouble codes. I know I've been through similar before. Here's a link I have bookmarked if it's any help.

Also, sending the mobo out for repair as a last resort isn't a bad option. The cost isn't usually that bad if you can R&R the board.
My System SpecsSystem Spec
19 Jan 2012   #6

Windows 7 Home Premium 64 Bit OS

Thanks again for the response Fred

Yes - quite a bit of troubleshooting (pulls last thread of hair out of head! )
Will run Memtest from Hirens today with both battery and PSU plugged in and see how
it goes. Will also boot Knoppix as a secondary test. I will run with hard drives in and out - what's
a bit more time gonna matter now hey.

I should mention that the A200 has 2 x 200GB hard drives. Upon purchase, one was used as the primary drive
and the other had the recovery partition and was used for backup. As previously mentioned I have run Killdisk over both hard drives to write zeros prior to installing the OS's. So the configuration now is C:Windows7 32bit, D:Vista Ultimate 32bit (second partition on drive 1) E: 2nd drive left empty for backing up.

Can't see that there would be any problem with the above setup and the way I have gone about the
procedure but if anyone recognises this as a file system or partitioning problem please advise.

Again Fred - thanks very much and I will post back results after running the tests.
I guess if Hirens runs, Memtest passes and Knoppix runs for an extended period then it's a
driver issue which I will point the finger at Bluetooth, fingerprint, or webcam.
I should probably also mention that in the past I have had major issues getting the webcam going as the driver (latest provided by Toshiba being Vista which is recommended on a 7 install) never worked and hence, I found an older version of the driver which does install and get the camera working. Am starting to think that this could also be a very real possibility. Anyway - the plastic and glass shards aren't flying off the brick wall yet!

Details will be posted (hopefully of success - not glass shards)
My System SpecsSystem Spec
19 Jan 2012   #7
Fred Garvin


If you're going to do the Memtest idea, why not download the ISO. I'm 99% sure it all runs in memory with no hard drive temp files. Not sure on Hirens. My point is to look outside the box and eliminate other software, Windows, etc, all together.

Somewhat like bench testing. If you can keep the computer running at the BIOS level or via a CD, with the battery & PS both plugged in, it would lead me to think the hardware is ok. Any power settings in BIOS that might be an issue?
My System SpecsSystem Spec
19 Jan 2012   #8

Windows 7 Home Premium 64 Bit OS

Hey Fred

Already had Memtest on a Hirens boot disk I had made from an ISO.
Have run Memtest on the machine since the time of last post, so say 3 hours
plus booted Knoppix and let run for half an hour give or take.

Results: 0 shutdows with both battery and PSU connected.

Have not tried these same tests with the hard drives out but considering the above results
I don't think there is really a need to. If both the Hirens boot disk and Knoppix live CD run from
RAM then I guess that safely eliminates a bad mobo altogether doesn't it?

If this is in fact the case, then I can safely assume that this has been a driver issue with as mentioed
previously the prime suspects being:
1) Bluetooth Stack (not worried about Bluetooth on this machine anyway so can stay uninstalled
2) Upek figerprint software (I think I can manage to type a Windows login password instead)
3) Chicony 2.0 webcam (I'll buy a $30 external if need be)

The only thing that annoys me is not being able to get all the devices working properly
as I have seen it as a bit of a challenge. The other annoyance is when I go to devices and printers I
have a yellow exclamation mark on computer (missing driver obviously) if (unsure of which) either the Bluetooth stack or the fingerprint software is not installed. I guess if it is one of these devices causing the random shutdowns I will have to sacrifice aesthetics for functionality. At least I will know that it is one of those devices causing that pesky exclamation mark so I'll learn to ignore it. The other option may be to try installing the Vista fingerprint software and Bluetooth stack and tell Windows 7 to run them in compatability mode?

I have included an image of the advanced settings of the Phoenix BIOS - I have F9ed this
to apply setup defaults. If you know of anything in there which may cause a problem please let me know.

Tosh A2OO reboots when both battery and PSU plugged in-1.jpg

I am about to do a System Restore to the earliest point possible. There won't be many restore points as I haven't installed to much but I'll see how it goes at removing the mentioned drivers and post back the results.

Thanks again

My System SpecsSystem Spec
19 Jan 2012   #9
Fred Garvin


Ok, that's progress IMO. Did this computer originally come with Vista and now has 7 installed on it? If so, did it have this problem with Vista installed? I'm thinking it's an ACPI issue and wonder if there is a BIOS firmware update available for your laptop. See if Toshiba lists an update on their website.

Nothing of interest or incorrect looking in that screenshot.
My System SpecsSystem Spec
19 Jan 2012   #10

Windows 7 Home Premium 64 Bit OS

Hey Fred

BIOS version running is 2.50.
Upon installing the fresh installations I did go to the Toshiba Support
site and downloaded the BIOS they had listed as the latest. I ran the
download and was told via a pop up message that I was already running the latest version.

I did a quick search around to see if I may have been doing something wrong in
regard to BIOS installation but there seemed to be no real technical procedure to
follow to install as there are with many other BIOS. I simply ran the download, got
the message about already having the latest and then left it at that.

The machine did come with Vista pre-installed. As I said before, I now have Windows 7 Pro 32 bit on
a C: and a Vista Ultimate 32 bit on D: partition of the same drive.

I have a valid serial for Win 7 Pro which I was entitled to as a student and I use an
OEM Vista disk and the original key from the sticker still on the bottom of my A200 for that install.

Is a BIOS update the ONLY thing required to fix ACPI issues? Is the error I get about BIOS
standard - I presume all is still well and that V2.50 is the latest so long as Toshiba are
keeping their support website up to date. Maybe an idea to look for a Phoenix BIOS
website?? HMMMM

Thanks for the fast reply.

Edit: The machine in mention had a mobo replacement after approx 1 and 1/2 years.
It took me 8 weeks to get it back and the workmanship was shoddy - the machine came back with
no Infra Red (CIR?) so my Toshiba remote for media center was a paperweight. I was not about
to wait another 8 weeks for a working machine though so I let it go!

I have to say that the experience I am having with this machine now is very similar
to that prior to the mobo replacement under warranty. The replacement fixed the shutdown/ restarts
which is the same sort of deal as now - I just want to make sure that I am not
throwing a machine that is salvageable.

If it does turn out to be the mobo then the cost of replacement is not worth it as
the cost of diagnosing that would not be worth it.
My System SpecsSystem Spec

 Tosh A2OO reboots when both battery and PSU plugged in

Thread Tools

Similar help and support threads
Thread Forum
Battery plugged in, not charging
My laptop was working fine yesterday, but when I booted it up this morning, I got the dreaded "Plugged in, not charging". I've tried the fix that's everywhere on the internet >Disconnect AC >Shutdown >Remove battery >Connect AC >Startup >In Device Manager, Under the Batteries category,...
Hardware & Devices
96% Battery plugged in but not charging
Acer laptop 2 months old I did the followings but did not fix it : Unplugged the machine Removed the battery Plugged everything back in ( except the battery ) and loaded the machine Turned off the machine Put the battery back in.
Performance & Maintenance
Battery says plugged I not charging
My dell inspirion says plugged In not charging I have replaced the motherboard,battery,and charger please help
Hardware & Devices
Plugged in, but running off battery..
Ok, before I start, I'm POSITIVE this is not a hardware issue, because when I'm in Ubuntu, it doesn't happen. Every 10 seconds or so, Windows will think my charger is unplugged. Then, it will proceed to switch back and fourth between plugged in and not, forcing my laptop to switch between power...
General Discussion
Laptop goes to sleep if no battery but AC plugged in
I haven't verified this yet, but I wondered if it's a possible bug? I bought a Dell XPS M1330 over a year ago and it came preloaded with Vista Home Premium. Since I want to keep the batteries in good condition I run the laptop with no battery connected and AC plugged in whenever it sits on my...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:46.
Twitter Facebook Google+