Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't access external HDD?!

16 Feb 2012   #11

Windows 7, 64Bit

that didn't work either.

My System SpecsSystem Spec
27 Jun 2012   #12

Windows 7 Ultimate x64
How about starting in Safe Mode?

I ran into a similar problem with my WD 2TB external HD. I frequently used the drive between systems running XP SP3 and Windows 7 Ultimate 64 bit. My son used my HD on his netbook while visiting. Afterwards, it would not work on either previous system.

I spent weeks trying different techniques and tricks. I had the drive for about 2 years and never registered the drive with WD (never had problems with any previous drives from them). I never even installed any of the recommended programs they had on there. So, my drive had never been backed up online or anything...

I downloaded a "WinDlg_124" program from their site based on the research for the problems I had. Tried running the tool to not much success after many hours of scanning. My system kept going into power down, sleep, or energy saver mode, thus giving me failed readings (which they said mean the drive was bad). So I tried running it in Safe Mode. After a few days of that, it finally gave me all the results I had been praying for. The drive wasn't bad at all... and my files were still on drive J:\.

The problem remained that Windows couldn't access the drive. In Safe Mode, I could transfer the files, but my internal HD couldn't store any more. And transferring all the important data to my 3TB external drive through USB 2.0 would take years.

I was able to straighten out the directory files using cmd.exe and running "CHKDSK J: /F" and "CHKDSK J: /R" but only while in Safe Mode. You may also want to verify your drive's designation through regedit but ONLY if you know how to do that properly.

Still am having problems with the driver installation disk on drive I:\ which hopefully lies somewhere on my HD drive. I think when uninstalling the device I accidentally uninstalled the drivers.

When last checked (a few days ago), my WD HD still won't allow me access in Windows 7. I've tried to download the drivers from WD, but one must register their drive to do so. I tried, and the site simply said I could not because my device is no longer under any warranty. Thank you very little WD support! However, I discovered today that my drive is fully functional in XP SP3!!! (Although no installer disk drive I:/ shows up at all)...

I wish you all success.
My System SpecsSystem Spec

 Can't access external HDD?!

Thread Tools

Similar help and support threads
Thread Forum
External Drive can't access
I accidentally (a stupid thing) denied permissions to everybody on the external drive (dumb) and now I can not access the dr. I can not access the properties security tap. I downloaded a file "take ownership file", but doesn't work. It's my backup drive. can any body help? Also I tried to access on...
Can't access files on my external HD
Ok, so I have a Storagebird 500gb external disk full of videos, pictures and stuff. Recently it started to load slowly and when I try to play files from it, it says 'Error -43: a file could not be found (''). The HD shows up in disk management and my computer, but I can only access a...
Hardware & Devices
Access Denied - External HDD
I have had a new problem develop on Friday. Whenever I try to access my external hard drive through my user account (which is an admin account) I get a message telling me that "access is denied". The drive has worked no problems on the PC since March so seems strange that it chooses now to do this....
Hardware & Devices
Access denied to external dvd/cd drive
My external dvd/cd drive (Sony DRX S7OU W) previously worked from this computer running on Windows 7 but I now receive the message "Windows cannot access the specified device, path, or file. You may not have appropriate permissions to access them." The same dvd/cd drive continues to work on other...
Hardware & Devices
Recognition and access to USB external
I have a 160 GB that I used in past for Data on my old HP. However in Ubuntu on plug in I immediately see the icon pop up on desk to. but denied permission. (This only for your info as I only want to use on win 7. There when I plug it in I hear audible click, but went to my computer but nothing...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:37.
Twitter Facebook Google+