Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB mass storage install failure

14 Feb 2012   #1

win 7 pro 32bit
USB mass storage install failure

Win 7 pro 32bit Lenovo x201 tablet: previously working USB thumb drives & Seagate 750G usb external drive now NOT recognized by Win 7 work fine c/ other win 7 systems. Tried uninstall /reinstall usb port but get driver error "this operation requires interactive windows station" also tried MS fixit repair but repair fails to complete. Any other solutions?


My System SpecsSystem Spec
14 Feb 2012   #2

windows 7 premium 64 bit

you may not have enough power, they make special dual usb port power cables

as seen here 2m USB Cable - Dual Power, 2 x Type A (50cm) to mini B, 10.31787

im not sure if thats the right cable for you, however they should make them for yours
My System SpecsSystem Spec
14 Feb 2012   #3

win 7 pro 32bit

No...I don't think power is an issue b/c this worked just fine up to about a 2-3 wks ago & the thumb drives don't need external power & this Seagate works fine on the older Lenovo X200 (win7 32) This is some win 7 snafu as I have had this machine for 6 mo. c/ all of this working fine. I did go back to the oldest restore point but this made no difference...Win detects usb but will not re-install or update the drivers b/c "this operation requires interactive windows station" what ever that means! If yo search that term on the MS website you get nothing, so even they don't know what it means.

Thanks for your help
My System SpecsSystem Spec

14 Feb 2012   #4

windows 7 premium 64 bit

unplug the drive, go into dos and type this


then when the device manager comes up go to view/'show hidden devices'

find the drive in question and 'uninstall', restart and try to plug it again after all that
My System SpecsSystem Spec
14 Feb 2012   #5

Windows 7 Home Premium 32 bit

^^ @aeadds, You are absolutely right.

Nobody seems to know exactly what causes this problem.

OK, what are the fixes tried?

One user says that he reinstalled Windows with the USB device plugged in and that worked. Looks like a drastic solution. He is emphatic that it is the only solution. All else failed. I chuckle.

Another user has the same problem when he plugs in his new USB Keyboard. He reinstalls Windows with the device plugged in. Problem resolved. My chuckle stops. May be there is some truth in it.

Microsoft suggests a clean boot to check whether any third party program is the cause. Also suggests that you disable any or all security software be it anti spyware, anti-malware, firewalls by whatever name they are called and so on.And then the usual SFC Scan now to repair any corrupted system files.

Another user says that disabling System Restore, resolved the problem.Someone else rebuts that it did not work for him.

Another User - I restored my system to a date prior to the appearance of this problem and it worked.

So the problem lingers.

So finally when one does not know the cause, one has to try and keep on trying all suggestions and so here is my bit - which no one seems to have suggested so far. Here it is
Verbatim 1TB External drive not recognised on boot

If it resolves your problem, you hit the jackpot and me the rep-pot.

BTW, how does stewartd change to aeadds? !!!!!!!
My System SpecsSystem Spec
14 Feb 2012   #6

win 7 pro 32bit

Thanks Jumaji I'll give your last suggestion a try, but I think it gets at the same thing as deleting INFOcash.1....I'll let you know if it works. Couldn't get dsk4's suggestion to run in dos. Other things I've tried to no avail....delete INFOcash.1 then restarted to generate new INFOcash.1, disabled System help & lost all of my older restore points, shut down firewall & anti virus, Regedit of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USBSTOR DWORD start value change from 3 to 4 & reinstall. I hate the thought of a repair install but it's looking more & more like the only other solution since I've wasted 2 days on this....MS should be ashamed of this but I'm sure they are NOT!
My System SpecsSystem Spec
14 Feb 2012   #7

win 7 pro 32bit

oh..depends on the computer...x201 stewartd desktop aeadds
My System SpecsSystem Spec
15 Feb 2012   #8

Windows 7

Quote   Quote: Originally Posted by aeadds View Post
oh..depends on the computer...x201 stewartd desktop aeadds
Yeah, you're right.
My System SpecsSystem Spec
15 Feb 2012   #9

Windows 7 Ultimate x32

Maybe its a hardware problem. Let your usb or tablet be checked by the experts. They may have previous problems like that and solved it. Give it a try!
My System SpecsSystem Spec
15 Feb 2012   #10

win 7 pro 32bit

Well sad to say I tried Jumaji's suggested fix & still "requires interactive windows station" error when the driver is trying to load! Ugh!!! very frustrating...thanks to all of the posters for the suggested fixes...this is a new machine & under warranty & I would take the last posters suggestion except Windows sees the new device so clearly the USB ports (all 4) are working... it just will not install & continues to give that nonsense interactive window error.

Looks like a Windows re-install is the only way out but if anyone has another suggested fix I'd be glad to try.
My System SpecsSystem Spec

 USB mass storage install failure

Thread Tools

Similar help and support threads
Thread Forum
problem during install win7 missing mass storage driver
Dear, i have a problem during install win 7 in HP PAVILION DV6700 this laptop was using vista so i want to change to win 7 its asking me the MASS STORAGE driver so i need this driver to continue install windows7 see the image file to understanding the problem
Unable to install Any usb mass storage drivers.
My dads laptop has suddenly stopped recognizing any type of usb device properly that has not been used before. This includes 2 memory sticks and a 250gb Hdd. What happens is the devices are visible in the device manager, However they are not being recognised as Usb mass storage devices and are...
Mass Storage Device error code 10. Drivers failing to install.
I keep getting a message saying drivers failed to install correctly and a yellow exclamation mark next to the USB mass storage device (error code 10) when I look in Device Manager... I've don't really know where to start with any of this but I am thankfully quite good at following instructions...
USB mass storage
Hi, I have windows 7 enterprise edition. Couple of days back I had plugged in external harddisk and after I am done with that, I did not find "Safely Remove...." icon on the tray. Normally if I can not stop the harddisk, (even if all the apps and windows are closed), I go to sleep mode, remove...
Hardware & Devices
W7, sp1 causes usb mass storage failure
To all: Have a dell inspiron 580, W7, 64bit desktop... got Jan 2011. All was fine until sp1 update... afterwhich none of my usb mass storage drivers worked... tried all kinds of things, uninstalling drivers, updating, rolling back, chipset and bios updates etc.. nothing works... only current...
Windows Updates & Activation
USB Mass Storage devices won't install
Hello all Well this is a strange one. Anytime I try to plug in a "new" (e.g. never plugged in to this computer before) USB Mass Storage device, device installation fails. When I click on the balloon that says device installation failed, it says "No driver found". If I manually choose a...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App