Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB 3.0 Ports don't work with my USB 3.0 external hard drive.

04 Apr 2012   #1
Skyward Demise

Windows 7 Home Premium 64bit
 
 
USB 3.0 Ports don't work with my USB 3.0 external hard drive.

I have 2 USB 3.0 ports on my laptop, they used to work with my LaCie Minimus USB 3.0 external hard drive, but since a few weeks they just stopped behaving as USB 3.0 ports.
Every other USB 2.0 device works fine with it, and my hard drive works fine with the USB 2.0 port I have. I have tried installing latest drivers to no avail.
Can anyone help me with this, I've been trying for 3 days now.


My System SpecsSystem Spec
.
04 Apr 2012   #2
cyclic

Windows 7 home premium x64
 
 

Can you be more detailed about the change in behaviour, what sort of speeds are you experiencing against what you have known\expect ?
My System SpecsSystem Spec
04 Apr 2012   #3
Skyward Demise

Windows 7 Home Premium 64bit
 
 

The change in behaviour is that my laptop doesn't see the hard drive at all when it's plugged into a USB 3.0 port. Not even in device manager.
My System SpecsSystem Spec
.

04 Apr 2012   #4
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

What is the make and model of your laptop? Do you have all the current updates and drivers for it? Have you checked for any possible infections of your laptop...ie virus and/or malware - spyware that may be lurking on your system unknowingly?
My System SpecsSystem Spec
04 Apr 2012   #5
Skyward Demise

Windows 7 Home Premium 64bit
 
 

I have a Sony Vaio VPCF22M1E.
I have all the current updates and drivers for it, I have not checked for spyware or malware yet. I will run a full system scan with Avast now.

EDIT
I ran a full system scan, nothing.

EDIT
I now did a factory reset, the problem is still there.
My System SpecsSystem Spec
21 May 2012   #6
slpet

Windows 7 Home Premium x64 and Ultimate x64
 
 

I've got the same laptop and the same problem. USB 3.0 doesn't work. But a usb 2.0 device does work on a usb 3.0 port.

I've heard that Sony knows about the problem but still nothing from theire side..
My System SpecsSystem Spec
16 Jun 2012   #7
Yarand

Windows 7 ultimate 64-bit
 
 
Same USB 3.0 problem with USB 3.0 port - different computer

Hi All.
I have a (UK) Rock laptop - effectively a Clevo 570MTU laptop, running W 7 64-bit, with SP 1.
I recently installed a Startech USB 3.0 ExpressCard, with Renesas/Nec drivers updated to latest version.
The ExpressCard shows up in Device Manager as USB 3.0 Host Controller and USB 3.0 Root Hub, with no errors.
I purchased a Western Digital ("WD") My Book Essential 2TB USB 3.0 and 2.0 external drive for back-up of the laptop.
I have tried numerous ways to do this but, as yet, I have not been able to get the WD to be recognised on the laptop AT ALL through the USB 3.0 ExpressCard.
The WD Does show up, and work (slowly) when connected to the laptop's USB 2 port.
Likewise, USB 2 devices work when connected to the USB 3.0 ExpressCard.
This is madness and maddening - why will a USB 3.0 device not work with a USB 3.0 port???
My System SpecsSystem Spec
18 Jun 2012   #8
BarryBGB

Microsoft Windows 7 Professional & Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Yarand View Post
Hi All.
I have a (UK) Rock laptop - effectively a Clevo 570MTU laptop, running W 7 64-bit, with SP 1.
I recently installed a Startech USB 3.0 ExpressCard, with Renesas/Nec drivers updated to latest version.
The ExpressCard shows up in Device Manager as USB 3.0 Host Controller and USB 3.0 Root Hub, with no errors.
I purchased a Western Digital ("WD") My Book Essential 2TB USB 3.0 and 2.0 external drive for back-up of the laptop.
I have tried numerous ways to do this but, as yet, I have not been able to get the WD to be recognised on the laptop AT ALL through the USB 3.0 ExpressCard.
The WD Does show up, and work (slowly) when connected to the laptop's USB 2 port.
Likewise, USB 2 devices work when connected to the USB 3.0 ExpressCard.
This is madness and maddening - why will a USB 3.0 device not work with a USB 3.0 port???
Just to rule out the USB 3.0 interface, try to use a USB 3.0 flash drive instead of the WD external. If that works in USB 3, then I would look at the external drive for the problem. I have several of these USB 3.0 flash drives and they are getting pretty low in price.
I have read many feedbacks on NewEgg about this WD drive dissappearing with many saying there is a problem with the interface.
Just a thought.
My System SpecsSystem Spec
19 Jun 2012   #9
Yarand

Windows 7 ultimate 64-bit
 
 

Well.
I replaced the Startech ExpressCard with a Freecom ExpressCard - which comes with its own power adaptor.
After driver installation and insertion of the ExpressCard I connected the WD USB 3.0 and it was instantly recognised by the laptop - BUT I got the following message: "This device will perform faster if you connect it to a super speed USB 3.0 port".
2 steps forward...
Any ideas?
My System SpecsSystem Spec
19 Jun 2012   #10
BarryBGB

Microsoft Windows 7 Professional & Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Wow, that is a new one. I was going to say to check the pins on the usb 3 port and see if there are any out of place pins or even bent. Since you have a new card, that shouldn't be the problem.

Did the Freecom ExpressCard come with a new USB 3 cable or do you have another one to try?
My System SpecsSystem Spec
Reply

 USB 3.0 Ports don't work with my USB 3.0 external hard drive.




Thread Tools




Similar help and support threads
Thread Forum
My external hard drive is always flashing and will not work.
I have a Toshiba external 1TB hard drive. It shows up as Local Disc in computer but clicking on it make the Windows Explorer box not respond. I have tried uninstalling/updating the the driver in device manager however it just endlessly uninstalling/updates. I have tried using chkdisc in cmd however...
Hardware & Devices
WD Elements 2TB external hard drive does not work through USB 3.0
Hi! My WD Elements Drive worked perfectly over USB 3 before i reinstalled my PC, now when i connect it to a USB 3 Port om my PC, the drive just sits there and slowly blinks(Indicating that no data is being accepted but power is being transfered) I coudn't find any USB 3 Drivers online for my...
Hardware & Devices
Getting External Hard Drive to Work
I have a Mac, but it's on it's last legs. I got an external harddrive (passport something or the other) and put all the stuff from the Mac onto it. I want to access these files on my Windows 7 Home Premium computer. I plugged the device in, the computer made a noise and installed a driver for it....
Hardware & Devices
Can I have an external hard drive work on both vista and 7?
So My new computer build is having trouble using a certain program I like to download stuff with but my laptop can use the program no problem. My external was always hooked up to my laptop which is running vista but when I try and view the files on my desktop (running 7) it cannot look into the...
Hardware & Devices
External hard drive doesn't work with W7,64bit
I just used my external hard drive on my old Slap Top, Windows XP, 32bit, and it worked fine.....but it doesn't work on my new Vaio, Windows 7, 64bit. I'm not a PC-know-a-lot'er, so if anyone has an answer, please make it simple. In advance, thank you :)
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App