Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 cannot access my WD 1.5T external HD no matter what i try

06 Apr 2012   #1

Windows 7 home premium 64bit
Win7 cannot access my WD 1.5T external HD no matter what i try


So i dropped my Western Digital external hard drive (3.5'', 1.5T) a few days ago (way past the warranty) and it opened up (the base fell off) so I just clicked the base back in. The usb 2.0 connector is warped but when i connected the external to my comp, everything worked fine. So a couple days after that I wiggled the part that connects the USB cable to the external and right after that point, I have been getting really weird problems with my external.

Here is what happens:

1) whenever i open 'my computer' when the external is plugged in, it takes FOREVER for my computer to respond (there is this green bar that fills up near the address bar). If i try to right click my external, the window automatically freezes and i waited for an hour and still doesn't respond. So i am forced to end task it. If my external is no plugged in, 'my comp' works fine.

2) if i wait long enough for my computer to load completely (takes about an hour) without touching anything, and i try to access my external in ANY way (through browsing for a file through my antivirus, or any software, the software will 100% become unresponsive (says 'not responding' and if i click the window, it goes all while).)

3) sometimes when i try to access my external i get the error "windows cannot access this ________(something, can't remember)'. This rarely happens, and I don't know how to get win7 to give me this error.

4) i tried to scan my external with bitdefender but when i tried to select my external, the window went unresponsive. I waited fora longtime....

5) i tried to get a program called "r-studio" but right when i plugged my external in my comp (after i opened r-studio), r-studio becomes unresponsive...

6) when i plug in my external, instead of saying "600GB free out of 1.3t' and the name i called it, it says "local disk f:\"...when i click it, it asks if i want to format it which i obviously don't want

7) i tried to rename the drive letter with disk management, but that didn't' change anything (changed from H:\ to F:\).

8) whenever i have my external plugged into my comp, my computer windows (windows explorer for example) doesn't refresh when i move/delete a file. I have to manually press f5 to see the changes. Does this mean i have a virus on my external or something??

9) in disk management, the external is shown as "raw". it never use to i think.

I have no reinstalled windows

I have no idea what is going on.
I scanned my comp 2 times with bitdefender. I think this is a virus but I have no clue.

any help would be awesome.


edit: i am trying testdisk right now and its taking so long to recognize my external, still just saying "still waiting"...

My System SpecsSystem Spec
06 Apr 2012   #2

Win 8 Release candidate 8400

Um, It is probably the drive. If there is nothing "life and death critical" on it, chalk it up to experience. If there is, you do have a back up right?

Drive recover can be quite expensive.
My System SpecsSystem Spec
06 Apr 2012   #3

Windows 7 home premium 64bit

well my external is my backup haha. I just don't understand how this think if i open it up somehow (no idea how) and just see if the wires not connected properly or something???

well the testdisk finish, and i followed the steps from this guide
Regain a lost drive using Test Disk - An Illustrated Guide

then i restarted, now my external won't appear in my computer....
My System SpecsSystem Spec

06 Apr 2012   #4

Windows 7 Pro X64 SP1

A couple of years ago, I dropped an external enclosure that had a WD 750GB drive in it. The drive was spinning at the time.

The drop was less than half a meter (20"). There was no visible damage to the enclosure. The drive was dead, though. I was never able to get Windows to mount it again.

Drives will probably take more mechanical shock if the heads are parked, but you may have exceeded that.

It may be worthwhile checking to see whether an internal connector has become loose, but I'd bet that the HD itself is toast.

My System SpecsSystem Spec

 Win7 cannot access my WD 1.5T external HD no matter what i try

Thread Tools

Similar help and support threads
Thread Forum
Cannot access external HDD on other PC after protecting it in Win7
I have a freecom external HDD that I use with user level-access protection on a win7 home premium64bit PC that just died completely. I have tried to connect it to both on XP Pro and new Win8.1 laptops but get "F:\ is not accessible access is denied" errors in both. Am I stuffed or is there hope...
Hardware & Devices
Dual Boot - Win7 and XP - Access denied to files when booting in Win7
Hi there, hoping someone can help... I've eventually managed to get a dual boot system going. I've installed Win7 on one hard drive and Win XP Pro on another. I've still got to figure out how to get a dual boot menu going, but in the meantime I press the F10 key during Boot-up of the machine...
General Discussion
Win7 on ASUS P5K-VM won't recognize any hard drives, no matter what !!
I've now spent an entire day, 20 plus hours, trying to get Win7 to install on a simple ASUS P5K-VM. I've tried EVERYTHING I can think of, the Windows installer simply will not see any hard drives NO MATTER WHAT. I've downloaded the specific drivers from the motherboard site, put them on a USB...
Installation & Setup
Win7 x64 Crashes on Internet Access or File Access
Hi all, So i'm writing this from Safe Mode with Networking as that seems to be the only way to keep the system stable. I was working on my computer last night with zero problems. I shut it down and then today I have the following symptoms. Once i boot, i can open folders on the desktop and...
BSOD Help and Support
Cannot access files no matter what!
Hey guys, So here's the scenario: I had XP installed before. Skipped Vista completely. And then I did a clean install of Windows 7 Ultimate. For some reason, it created a windows.old folder. Now, other than taking up a lot of space, this folder didn't cause any problems and I deleted it. 3 days...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:10.
Twitter Facebook Google+