Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 4gb installed only showing 2.75 usable? is this right? what can i do?

25 Feb 2015   #11

windows 7 home premium 64bit sp1

gmemon, i am not sure what to say. I had the old bios, then upgraded to the current bios, the same that you have, and all of my memory was then usable. Maybe, just maybe, you could downgrade to and older version, restart, then REUPGRADE to newer version of bios. The new bios is what did it for me. that is the best i got.

My System SpecsSystem Spec
05 Apr 2015   #12

Windows 7 Ultimate x64
Installing new BIOS worked

I have a Dell Inspiron 530 on which I'm trying to install Win7 x64. I was running the 1.0.5 BIOS and I have 8GB (4x2GB identical sticks) of RAM. Windows said I had 8GB installed but only 3.25 usable. I tried msconfig > boot > advanced > max memory option but all that did was make things worse. My BIOS did not have the memory remap feature. I found a new BIOS on the Dell website, 1.0.18. Upgrading the BIOS, resetting to factory defaults, and rebooting twice fixed the issue. Now I have 8GB of usable RAM. Hope this helps someone else, I've been fighting this one all day.
My System SpecsSystem Spec

 4gb installed only showing 2.75 usable? is this right? what can i do?

Thread Tools

Similar help and support threads
Thread Forum
System Properties Not Showing Usable Ram
Windows 7 Professional, SP1, 3GB Physical RAM, 64-bit. System Properties has a label such as this on *OTHER* systems: Installed Memory (RAM): 4.00 GB (3.85GB usable) And you will see this "usable RAM" item in many Windows systems. However, there are some systems where it simply does not...
General Discussion
8 GB RAM installed (3.98) usable
Hi all, Have check everywhere for a solution do this. I have recently build my own pc and its going great But i have 2x4gb ram chips installed dual channel and its only detecting 4gb usable there is no memory mapping for my mobo and yes im on a 64 bit system have tried everything can...
General Discussion
4gb of RAM installed, but w7 says 256 usable
Earlier tonight I rebooted and noticed that it took an extremely long time to boot. Almost 10 minutes to get the desktop completely loaded. So I checked task manager > performance tab and it says I have only 256mb of RAM. So then I checked My Computer > Properties and noticed it said "Installed...
Performance & Maintenance
6 GB RAM installed 1.74 GB Usable I just recently replaced a 1GB RAM card for a 4GB RAM card. (I had one 1GB and one 2GB) And now I am having this issue of Windows not using my newly installed RAM. I have been searching old forum posts and making sure everything is updated...
Hardware & Devices
3 GB installed but only 1GB usable.
I just built a new system and decided to try out Windows 7. Everything is just amazing but I do have 1 problem. I have 3 GB memory installed and 7 recognizes this but says only 1GB is usable. My system is basically. i7 Quad 920 Gibabyte EX58-UD4P Motherboard 3GB DDR3 Corsair Memory ATI...
General Discussion
4 GB Ram Installed. Only 3.78 gb usable
Hi guys i was wondering why does my PC show this? (see the attachment) I'm running Windows 7 Ultimate x64, on the specs in my 'system specs' ;) How can i make all 4 gb usable? :confused:
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App