Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BC f4 error when heavily using my new HDD

26 Apr 2012   #1

Windows 7 Ultimate x64
BC f4 error when heavily using my new HDD


I recently bought at last a larger HDD, with the aim of replacing my old 250GB with a 3TB for my data, keeping my system, apps and docs on my 500GB. Currently as I've not yet transferred my 250GB disk across I've got 3 discs in my system.

The problem is when I try and copy my data across I get after a while source not found errors, soon followed by a system crash. the system, on the following reboot then comes up with terrifying message of "No Operating System Found". The reboot after it boots up correctly, with windows confirming if you want to use safe mode or not, etc. While I'm generally very familiar with computers and their architecture, I admit I know a lot less about hard drives and drivers compared to CPU and memory architectures. I'm surprised that this is causing problems with both my 250GB disk and with my system disk, unless it is related to the IO bus itself. All in all I need someone more experience in this corner to help me figure it out.

The error is as follows:

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 2057

Additional information about the problem:
BCCode: f4
BCP1: 0000000000000003
BCP2: FFFFFA8008423060
BCP3: FFFFFA8008423340
BCP4: FFFFF800031C85F0
OS Version: 6_1_7601
Service Pack: 1_0
Product: 256_1

I've also attached the minidump.

Sys details as follows:
OS: W7 Ultimate x64 Service Pack 1 (and usual updates)
Mobo: ASUS P5Q3 Duluxe dual onboard WiFi
Bios: 2105 (26 April 2009)
CPU: Intel Core 2 Quad Q9400
RAM: 8GB Corsair something (it's compatible and has worked for 1.5 years), DDR3 1333
GFX: Sapphire HD4870 Toxic 1GB
PSU: SilverStone Strider Gold 1000W (note: also brand new and changed recently)
SATA1: Western Digital WD5001ABYS
SATA2: Maxtor 6L250S0
SATA3: Seagate Barracuda ST3000DM001 (Brand new, suspected)
SATA4: DVD drive (Previously SATA 3)
SATA5: DVD drive (Previously SATA 4)

I can provide Channel / Location / partitioning info if needed

Things I also think are of relevance:

- My cooling (I've seen this error related to many things, overheat included.

I recently migrated my pc to a new case. my pair of 120mm fans (front inlet, rear exhaust) upgraded to a pair of 200mm (front inlet, top exhaust) and I've cleaned my pc and upgrade my CPU heatsink. Everything seems ice cold, but I was concerned that there is now less cooling around my HDDs, an there are 3 rather than 2 with a gap between. It is possible that the new airflow pattern is not as optimal for the chipset and bridge cooling, although with the huge heatsinks they have I wouldnt be concerned about that. Still, a 90gb single transfer between 2 disks is hell of a load.

- Timeline

I have gotten this error on 3 occasions: once the day I bought the disk, and twice in the last day (I stopped to wait for my second case fan to arrive in case it was a heat issue). The changes to my system when I first got the disk were a new PSU, new case (different cooling), and the new disk. As part of this my dvd drives moved SATA port, I also hooked up my new e-sata port on the case, although I don't have any external disks. The changes yesterday were the fitting of the front case fan in front of the hard drives and a new CPU heatsink and fan. There were 2 weeks between these events and these are the only two times I have attempted the copy of data to the new disk. The first two times I tried the whole block, the last time this morning I only tried to copy 1 folder of 10gb.

- Event logs

Searching deeper into my system logs I see a around 15 disk errors for each event reporting bad blocks. However, the old disk has never had problems in the past. Along with this are a lot of ATA api controller errors, and a "bugcheck" error which initiated the blue screen. An example of each is attached. Doesn't look pretty.

- Bios

Yes my Bios is old. I find something quite terrifying about a Bios flash and have always held the policy of NEVER update the bios if it is working at the moment. However, when checking the hardware monitors for my new cpu fan (which was so quiet i thought it wasn't working) I noticed the new disk appears in Bios as 856GB. I also hold the policy of if the Bios isn't working upgrade / downgrade as necessary, and if this is related I will go hunt a stable version down.


Any light shed on this will be welcomed. What puzzles me most is the randomness of it. I have had no problems with formatting or deleting data from the new drive, only when copying large amounts of data to it. It is a large margin bigger than my other disks, it's packed in with other disks, the bios is old and I do plan to hammer it. I suspect it's less of a nuclear disaster than the event logs show but it's quite clear the system isn't too happy about it and I want to fix it.

Thanks in Advance

PS: on a lighter note when joining it asked as a confirmation "how many hours are there in a day". I put 24, but today definitely feels like 30+!

Attached Files
File Type: zip (23.4 KB, 5 views)
File Type: zip error (1.9 KB, 4 views)
My System SpecsSystem Spec
27 Apr 2012   #2

Windows 7 Ultimate x64

Still awaiting help on this. I do have a little new news though. I just had a pair of crashes (instant power off, no error messages) from normal disk use of the 250GB disk, and as a test I just successfully copied 50GB from my 500GB main disk to the new 3TB disk without an issue. I now can't deny the possibility that the 250GB disk is actually the one on its way to death (Luckily the stuff I want to copy across is because it saves me weeks of redownloading on a slow connection...nothing there is hard to replace).
My System SpecsSystem Spec
27 Apr 2012   #3

Windows 7 Ultimate x64

Welcome! Put some thought into that signature, huh? Pretty amusing, I must say!!

As you've got your data secured (although only within the case), you can start by testing that 250GB disk via the system's BIOS. Reboot, get into the BIOS, and see what options you have in there for testing your hard drives.

For a more definitive test, download SeaTools | Seagate and run full tests with it.

There are also issues with drives larger than 2GB, and maybe you've already taken them in to account as there a a number of stories on this. Check this link for starters:

Everything You Need to Know About 3TB Hard Drives | PCWorld
My System SpecsSystem Spec

28 Apr 2012   #4

Windows 7 Ultimate x64

Cheers for that, but I have no tools within my bios for disk analysis. I had a feeling I needed to get myself a disk analyser but as I've not had a HDD problem since 2001 I couldn't remember any.

I'm quite worried at the moment about my 250GB Maxtor. Overnight I ran a checkdisk (I've been doing lots of diagnosis while waiting for an answer) and found some bad sectors. In response I've removed the system paging and temp folder from there and onto my 3TB, no problems from that it seems, and no problems backing up 200gb of data onto the new drive from my's only copying from the 250GB that has failed.

I can think that the bad sectors I found were in files I've not used for a very long time...except to copy them to the new drive. Is it possible that this is the change that led to this error appearing...rather than the hardware change? If so I'd put more and more suspicions on my old drive.
My System SpecsSystem Spec
28 Apr 2012   #5

Windows 7 Ultimate x64

First bit of interesting news from SeaTools: my 250GB fails the short DST very quickly, and it's "power on hours" is logged at just over 50,000 hours compared to the 20,000 and 250 hours of my other disks. I had forgotten this disk was pushing 9 years old now, I should have expected something

And yes, the sig is true. It's actually why I changed the psu: because the old one was starting to show the effect of the beating, and the case to a case with a bit of better armouring.
My System SpecsSystem Spec
28 Apr 2012   #6

MS Windows 7 Ultimate SP1 64-bit


Does you bios correctly handle a 3 TB disk?

I recommend visiting the website of your mobo mfg.

I also recommend reading:
Everything You Need to Know About 3TB Hard Drives | PCWorld
My System SpecsSystem Spec
28 Apr 2012   #7

MS Windows 7 Ultimate SP1 64-bit

Be sure to check for a bios update for your mobo.
My System SpecsSystem Spec
28 Apr 2012   #8

MS Windows 7 Ultimate SP1 64-bit

One solution which worked for another person is partition the 3 TB into 2 TB and 1 TB.
My System SpecsSystem Spec
28 Apr 2012   #9

Windows 7 Ultimate x64

If that 250GB drive has any more data on it that you want, I wouldn't run chkdsk on it again until verifying there are no physical problems with it. From my experience, chkdsk does work well under normal circumstances, but if there are physical/electronic problems with a drive, it can absolutely mangle the data on there.

Unless you had unsaved data on the PC that you needed to recover, there is no need to worry about the pagefile. The temp folder, of course, is your choice, especially if you ever saved files there yourself.

I wouldn't think this has anything to do with installing another hard disk. It might simply be that it's that HD's time to fail (how old is it/how has it been handled, etc.). I would download Seatools and check that disk out.
My System SpecsSystem Spec
28 Apr 2012   #10

Windows 7 Ultimate x64

Wow! Four posts since I started composing my previous one!!!
My System SpecsSystem Spec

 BC f4 error when heavily using my new HDD

Thread Tools

Similar help and support threads
Thread Forum
FPS dropped heavily and then BSOD while playing WoW
My computer has had a few BSODs in the past few months. My GPU driver is kind of buggy with me not being able to access Catalyst Control Center because it closes itself. Also not being able to play any modern games because of severe graphical glitches or just crashing. I've tried completely wiping...
BSOD Help and Support
BSOD while using the internet heavily (streaming, downloading... etc)
Hi Guys, I got a new PC recently and it's been BSODing ever since I got it, but it's not recording the BSOD messages :S The first time it crashed I pressed any key to stop it writing the BSOD error thinking that it was just because I was installing my games and stuff. I have 64GB RAM so...
BSOD Help and Support
Newest windows 7 update slowed down my comp heavily.
Hello there Last week there was one of those install new update popups where you're allowed to wait another 4 hours before it pops up. My problem is after last weeks update my computer slowed down heavily, and I cannot see anyway to fix it. I have checked core temperature, gpu temperature...
Windows Updates & Activation
Frame rate suddenly drops heavily
Hi all, I would to start off saying that I hope I've posted this thread in the correct section. Since some time, I've been having problems playing SP and MP games. For example, just a few minutes ago I was playing CS:GO with around 200fps (I know the human eye only sees about 25fps; and I...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:06.
Twitter Facebook Google+