Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SSD disappears from Device manager and Disk management

04 May 2012   #11

Windows 7 Home Premium 64bit Sp1

Windows is now fully up to date.
After updating,
I tried backing up my Lightroom catalog to D: again and lightroom encountered a problem and had to quit and so did Steam which is installed on the D: drive also. I checked my computer and D: was gone again.

It seems that every time I reconnect the drive to a different port it is found on the computer and then fails within a half hour. It doesn't turn up again just by restarting the computer, I have to actually reconnect it to a different port.

My System SpecsSystem Spec
04 May 2012   #12

MS Windows 7 Ultimate SP1 64-bit

Need a diskmanagement display.

Run disk management:
key with Microsoft logo on top.

Maximize the output of Disk Management:
key combo | X key (selects Maximize) |
Drag the field separators (such as between Status and Capacity) to show entire field.

Make a snapshot:
Drag the cursor around the area you want to snip.
File | Save as | select save location and name | Save

Post the snapshot:
Post a File or Screenshot in Seven Forums


Upload the files mentioned here:
Install CCleaner:
CCleaner - PC Optimization and Cleaning - Free Download


CCleaner | Tools
icon | Startup button | Windows tab |
click on Save to text file button (bottom right side) |
accept Startup.txt as file name | SAVE button


CCleaner | Tools
icon | Startup button | Scheduled Tasks tab |
click on Save to text file button (bottom right side) |
enter Scheduled Tasks as File name | Save button


CCleaner | Tools
icon | Uninstall button |
click on Save to text file button (bottom right side) |
accept install.txt as File name | Save button

UPLOAD the startup.txt file
UPLOAD the Scheduled Tasks.txt file
UPLOAD the install.txt file.

Post a File or Screenshot in Seven Forums

Go tho he gigabyte website.
Fetch,install the latest bios update for your motherboard (VERY IMPORTANT)
fetch,install the latest chipset driver
fetch install other drivers.
My System SpecsSystem Spec
04 May 2012   #13

Windows 7 Home Premium 64bit Sp1

I tried updating the BIOS but it said that the file size is wrong.

Attached Thumbnails
SSD disappears from Device manager and Disk management-diskmangmt.png  
Attached Files
File Type: txt install.txt (10.2 KB, 8 views)
File Type: txt Scheduled Tasks.txt (1.1 KB, 11 views)
File Type: txt startup.txt (5.2 KB, 8 views)
My System SpecsSystem Spec

04 May 2012   #14

MS Windows 7 Ultimate SP1 64-bit

The go back to the gigabyte site and redownload.

Make sure you are downloading the bios for your motherboard.
After that: update the chipset driver
after that: update the other drivers.

My System SpecsSystem Spec
05 May 2012   #15

Windows 7 Home Premium 64bit Sp1

Did it again same results. It says that the file is the wrong size.
I also tried @BIOS and it stops at 100% with an error message Runtime Error abnormal program termination

all other drivers are up to date.
My System SpecsSystem Spec
05 May 2012   #16

MS Windows 7 Ultimate SP1 64-bit

Contact the Gigabyte site and ask for an explanation.

Be sure to read their procedure very carefully.
My System SpecsSystem Spec
10 May 2012   #17

Windows 7 Home Premium 64bit

I believe I am experiencing the same issue. I am using Win7 64 home, have been using a crucial m4 128 as my boot drive for over 6 months. 2 days ago I woke up and my PC was frozen (it's always on). Power down, then turn on and it says non-system disk, press any key. If I press a key the computer boots up as normal, works flawlessly for about an hour then locks up again. Each time if I power down then turn on again I still receive the non-system disk error, but it still works perfectly for about an hour (I haven't timed it but it's close). If I boot off my regular drive and disconnect the SSD the PC works fine, no press any key, no freezes. If I connect the SSD and boot off the regular drive it will see the SSD for about an hour. On the bright side the pc doesn't lock up the SSD disappears just as you describe. Time for us to make sure we have everything backed up from our SSD I think :). I wonder if crucial will replace them when they work ok for an hour :).

Edit: update - I updated the firmware from 0009 to 000F ( as well as making sure all windows updates/drivers are to to date. I still got the press any key non-system disk message but the PC hasn't crashed in over 3 hours. Let's see how long it lasts when I fire up some world of warcraft :).

update: seems like the firmware+drivers+updates corrected the problem going strong for 12 hours of heavy use. not sure what triggered the issue though as it worked fine for the past 6 months.
My System SpecsSystem Spec
27 May 2012   #18

Windows 7 Home Premium 64 Bit

For people having this problem: Try doing a power cycle of the SSD. The following steps should be carried out and take ~1 hour to complete.
  1. Power off the system.
  2. Remove all power supplies (ac adapter then battery for laptop, ac adapter for desktop)
  3. Hold down the power button for 30 seconds to close the circuit and drain all components of power.
  4. Reconnect all power supplies (battery then ac adapter for laptop, ac adapter for desktop)
  5. Turn on the system and enter the BIOS (see your manual for the steps to enter the BIOS)
  6. Let the computer remain in the BIOS for 20 minutes.
  7. Follow steps 1-3 and physically remove the SSD from the system by disconnecting the cables for a desktop or disconnecting the drive from the junction for a laptop.
  8. Leave the drive disconnected for 30 seconds to let all power drain from it.
  9. Replace the drive connection(s) and then do steps 4-8 again.
  10. Repeat steps 1-4.
  11. Start your computer normally and run Windows.

The above steps were a result of: Why did my SSD "disappear" from my system? - Crucial Community

While that may not be your drive, a power cycle should be the same on all SSD drives. See how the system responds after the SSD power cycle.
My System SpecsSystem Spec
31 Jul 2012   #19

Windows 7 Ultimate x64

Similar issue to Quatra: Crucial M4 256GB working fine as boot drive for several months then system freezes (with mouse moving but not being able to click anything) followed by a crash/reboot to a 'non-system' disk error. In my case, a 'reset' wouldn't work (M4 disappears from BIOS) but a power shutdown then start leads to normal boot. After about an hour, the process repeats. I was on Firmware 0009.

The power cycle process described by writhziden (and in the crucial forums) worked. I did it with the drive data cable disconnected throughout the whole process and simply booting into the BIOS with sata power cable only. I also repeated the process 3 times for good measure.

After the drive was back to normal, I updated the M4 firmware to the latest 000F. This required switching from AHCI to IDE in the BIOS (both in the SATA section and the controller section), otherwise the updater doesn't see the drive.
My System SpecsSystem Spec
09 May 2013   #20

Windows 7 Ultimate x64

Sorry for resurrecting an old topic but i solved similar problem myself and can't find any similar solution on web. Here's my problem and solution:

I bought an Kingston HyperX SSD (SH103S3/120G) and installed on my desktop computer with ASUS (M4A785D-M Pro) motherboard.

I only installed games on drive, installation was ok but after a while, SSD drive started to disappear randomly (while reading/writing) from computer and reappearing after reboot. I checked firmware, bios and windows updates, but they were all up to date.

After a while, I was trying to find a solution desperately in bios settings and find out there are 2 sata controllers on mainboard. First with IDE/AHCI and RAID support on SATA port 1 to 4. Second one with only IDE support and using SATA ports 5 and 6 and i have installed SSD on port 5.

Which means this was the solution. I just unplug my SSD from SATA port 5 and plug to SATA port 1 (just in case :) ) My SSD working fine from then.

Hopefully this might helps someone else too.
My System SpecsSystem Spec

 SSD disappears from Device manager and Disk management

Thread Tools

Similar help and support threads
Thread Forum
disk not initialized in Disk Management. Device Not Ready.
I have a internal 3.5" HDD WD Black 2 TB and try to hook it up in the PC but it doesnt not appear anymore in My Computer. It was working few weeks ago. When opening Disk Management it says the disk is not initialized and it didnt state how many GB available on the hard disk (unallocated). Disk...
Hardware & Devices
Secondary Hard Drive Disappears in 'Computer' Shows in Device Manager
Hi there, I've been having a hard time with my secondary hard drive showing up when I go into the "computer" option under my start menu. It does appear under Device Manager though. I've reseated my cables numerous times, purchased and used new Sata cables, and I'm also running a new motherboard....
Hardware & Devices
HDD shows in "Device Manager" but not in "DiskPart"or" Disk Management
Hi Guys, any ideas how to access my external hard drive device manager can see it but it does not appear in disc management. I use this HDD perfectly in my car HDD player. But when I try to connect it to my Laptop, it does not show up in disk management. Please check the attached screen...
Hardware & Devices
External drives show in Device Manager & Disk Manager but not Computer
Two of my USB external Hard drives, a Fantom 600 GB and a Western Digital My Book 500GB cannot be seen in My Computer. I can see them in Device Manager and that says that they are working properly and the drivers are up to Date. In Disk Manager the 2 external drives had a black bar unlike the...
Hardware & Devices
cant see hard drives in disk management or in device manager.
hi few days back i have completely formated my hard disk with the help of seagate seatool.Then i have installed windows xp sp3. i have made 4 partitions at that time ie. c,d,e,f. After that i have installed windows 7 now i cant see my hdd in disk management or in device manager. both device...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:33.
Twitter Facebook Google+