Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Ports on laptop seem 90% dead

26 May 2012   #1

Windows 7 Home x64
USB Ports on laptop seem 90% dead

So I always seem to get good response on this site. Hopefully you guys can help me out again.

I bought a cheap powered USB hub off ebay. Connected to PC and when I plugged anything in was getting "malfunction" "unknown device" etc. So it was faulty. I then tried on the laptop to make sure. I then thought I'll try using some different leads to see if it was just the lead they sent me. When I connected an alternative power lead (I stupidly didnt check the v + A), it caused the laptop to switch off completely. I couldn't get the laptop back on for a sec. Was pretty sure the battery was at least half full. Eventually got it back on the the USB port I had the hub connected to wasn't working.

The other USB ports all seemed fine. I read about disconnecting everything taking the battery out and leaving it for 30mins may solve it. So i tried that but had no luck. So left it all unplugged disconnected over night.

Now today none of the uSB ports are working. I've tried plugging lots of devices in and am getting no response. Usually some of these devices would light up and stay lit while connected. When plugging in now to any USB port on the laptop the light might flicker on then off quickly. That's about it.

I've tried uninstalling USB related stuff in device manager, then restarting etc.

Any suggestions. Is my motherboard ****ed?

Unfortunately the laptop doesnt have any express/pcmcia card slots so thats not an option.

It's strange how at first it was only the port that I had the hub connected to that was faulty, now all of them are.

Any suggestions would be appreciated. Even comments on my stupidity of plugging the wrong power lead in to the HUB. Let me know what you think.

My System SpecsSystem Spec
27 May 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Yeah, there is a very good chance you fried the electronics up to or including the Southbridge Controller. It depends on what you did and the voltages involved.

I'm not clear on this:
"When I connected an alternative power lead "
What is that?

The best way to tell if you are dealing with a hardware problem (fried component) or a software problem (altered or corrupted drivers or OS settings) is to download, burn, and run a "Live CD" like Ubuntu or Puppy Linux. If the USB ports do not work while running Ubuntu then you will know it is a hardware problem.
My System SpecsSystem Spec
27 May 2012   #3

Windows 7 Home x64

Would mass storage device work like normal in Linux? (ie autoplay) I did try running LUBUNTU, i think its the lite version of Ubuntu but it was all command Prompt based like DOS. So i didnt know how to work it.

The faulty USB HUB has 2 leads (power and data) the data is a standard printer cable, so I was trying different cables there and I tried a different power cable (that's what i meant by "When I connected an alternative power lead "). The cable I used which seemed to cause the problem was from a SATA HDD Docking station. Which is probably much higher powered.

The reason I thought it was ok to do this, was recently I bought a cheap IDE external enclosure and it wouldn't work until I switched the power cable. That time I just used one of those 3-pronged (not sure how to describe) power leads that goes in the back of a desktop PC. And it worked.

So if i am dealing with a hardware problem. I've got two questions, how come at first it was only one port but now it's all of them? And is there a possible DIY fix? The laptop is out of warranty but its less than 2 yrs old. So I can't really justify a new one. I can live without the USB but would rather fix it obviously.
My System SpecsSystem Spec

28 May 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Ubuntu is a graphical user interface:
Home | Ubuntu
As is Puppy Linux:
Puppy Linux Community Home - Getting Started
unlike the many, many different flavors of Linux out there.

And yes, the above programs will recognize your external devices just like Windows would.

You should not switch power supplies for any electronic devices (Phones, tablets, drives) without checking the power rating to be sure they match, or at least are very close.
But that procedure should have wiped out the Hub, not the laptop. There is a possibility that a power surge shorted something out and in doing so sent a charge up the data cable (jumping circuits).

These electronic devices are very complex in design. There are several protective circuits designed in that are meant to protect the device from run-of-the-mill errors. Some of these do act like circuit breakers and I seem to recall that the Southbridge circuit is ground fault protected on better motherboards. That might explain what you experienced somewhat.
Try resetting the laptop (worth a shot): Disconnect the Power, Remove the battery, then press and hold the power button down for 15 seconds or so. If the reset is successful you will need to go into the BIOS settings and enter the correct date and time.
If the system is protected by circuit breaker type device that might reset it.

But if the protection is more of a fuse type device, or the circuit is shorted and burnt, then repair will involve some electronics skill and equipment. This is where you bring it to a qualified repair shop and drop it off. They can test the circuits to determine the cause and tell you if it can be repaired with an estimate. That is where you decide if buying a new laptop makes more sense than repairing the old one.
My System SpecsSystem Spec
28 May 2012   #5

Windows 7 Home x64

I'd tried the resetting a few times when it first happened. That made me lose more ports.

There is good news. I messed about some more, mainly repeating steps (removing USB drivers from device manager) got no where. Left it to hibernate and the next morning I got the 2 out of the 3 back working ! :) The one the faulty hub was connected to is still not working but I'm happy to have any at this point.

It is strange how they stopped working and have now begun working. Weird eh?
My System SpecsSystem Spec

 USB Ports on laptop seem 90% dead

Thread Tools

Similar help and support threads
Thread Forum
2 Dead usb ports. low speed on others on HTPC
I'm running a compaq HTPC with M2N68-la motherboard. OS on SSD working ok. 2 of 6 usb 2.0 ports are dead the others act like 1.1. for 2 different external HD's I'm getting message "this device can perform faster on 2.0" (tray balloon.) No errors in device manager. it shows standard enhanced...
Hardware & Devices
Laptop goes dead after about 10 min.
This started a couple of days ago. First it crashed after 3 min. Now it is slowly getting longer. I did start in F 12 and managed to do a diagnostic boot. There was nothing found. I can get on line and managed to see some e-mails. My F2 I cannot use because it is locked with a password I cannot...
BSOD Help and Support
Laptop and Dead GPU
Hi. I have a HP G62 laptop with a ATI HD5470 and Intel's iGPU. The dedicated ATI died and my screen is always black (everything else works and I can boot and blindly type my password and hear Windows starting). Using safe mode (where Intel's GPU work by default) it's impossible to...
USB Ports dead?
My USB Ports seem to be dead as whenever I plug any USB device in my ports, they don't do anything. Heres what I tried (and failed): -Disable Selective Suspending -Restart -Scan for Hardware changes -Uninstall the USB Ports -System Restore -Yank out the power cord (only made it worse)....
Hardware & Devices
help with dead laptop
my apologies if this is in the wrong area my acer 4230 seems to have died, it was working fine then today it wont start up, i get no post beep at all, the fan comes on for about 20 seconds then stops and the lights on the lappy stay on but nothing shows on the screen. also if i take the HDD out...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:44.
Twitter Facebook Google+