Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Flash Drive power issue? (connect/disconnection loop)

29 May 2012   #1

Windows 7 x64
USB Flash Drive power issue? (connect/disconnection loop)

Hi Guys

first of all, i want all to know that i am pretty darn good at computers, i build and fix computers for a living, and i research and even make technical reviews myself.. reason i say this now so that my fellow experts here would not bother "spoon feeding" me and stuff.. we can go ahead and talk Geek here..

ALright , w/ that said.. here's my situation..

I'm having abit of a problem w/ my flash drive

connecting it to usb , it powers up, and the OS recognizes the drive w/o a hitch.. default drivers installed and autoplay runs to show me my options..

opening the drive, it shows all my folders and files at the root level.. everything seems normal, and detailed list view reveals size, dates , etc.. all seem normal.

[this is where the problem starts ]

as soon as you do ANYTHING, the darn thing disconnects, and then reconnects..

i tried:
- openning a file
- openning a folder
- renaming a folder (F2 or right click)
- checking properties of any file or folder (either by right click properties, or alt+enter shortcut)
- tried accessing it via DOS mode (inside windows environment)
- tried accessing it using DOS based file explorers from Hiren's boot CD and etc

all i can do is just stare at my files.. so close , yet so far lolz

even if i simply select 1 file (not double click, single click only) as soon as Windows tries to access the file for info-summary on explorer's status bar, it disconnects..

i am able to get properties from the drive though, all seems normal

see: Droplr • Screenshot on 5.30.2012 at 12.20.27 AM.png


FIXES i've tried (and i have tried a lot these are jst some of the main attempts)
- device manager driver manipulation
- tried testing the voltage and mA outputs of my usb ports via software AND hardware testers.. all normal
- tried openning the drive in over 10 computers, different hardware, from windows xp to Ubuntu OS, usb 2 and usb 3 etc..
- tried using my dos based recovery tool, acronis, and other tools, as an attempt to recover data, or atleast make a snapshot image of the drive..

but nothing.. as soon as i do ANYTHING on the drive, it powers off and on.....

i tried leaving the drive folder open (ROOT) where it shows everything.. and just kept it like that for hours, it didnt power off.. but as soon as i did something like go into a folder, powers off and on..

etc etc etc

now, at this point i have diagnosed it to be a flashdrive hardware problem, perhaps in its power management side..

So now im really out of ideas.. so i run here for some help haha..

but given my diagnosis... here's what other advance stuff i wana try on it......but need your feedbacks..

- i wanted to try putting more POWER to the flash drive.. 5.2v at 3mA? i think this is a safe increase in power, w/o frying the darn thing.. if so.. HOW DO I DO THIS? do you guys know of a software/board combination that can do this ? set output power to the usb port?

if not, i also thought about using a POWERED usb hub, i even thought of openning the flash drive, and tapping directly into its power pins to add a bit of power and amps to it.. POWER ASSIST... 1.5v battery, some capacitors, etc should do it..

- hoping that the actual FLASH MEMORY CHIP is OK and intact, and that the proiblem is w/ the power relay/management of the device, the usb interface or others, i plan to TRANSPLANT this memory chip to another similar or exact working flash drive.. in theory this should work...

these are my last 2 courses of action to attempt data recovery from the drive.. i'd do it but all these requires a lot of work, and i just wanted to hear your thoughts and feedbacks about this before i get my hands dirty...

Regards to all


My System SpecsSystem Spec
29 May 2012   #2

MS Windows 7 Ultimate SP1 64-bit

As for as data recovery is concerned:

Would you please boot up PuppyLinux and see if you can use the flash drive.

Puppy Linux Community Home - Getting Started
My System SpecsSystem Spec
29 May 2012   #3

XP / Win7 x64 Pro

He says he's already tried accessing it in Linux to no avail. What happens when you access it in Linux or a command-line based utility? Does it disconnect just the same or is there a different type of error?

Have you tried simply imaging the drive via Linux "dd" and then trying to access the files?
My System SpecsSystem Spec

29 May 2012   #4

MS Windows 7 Ultimate SP1 64-bit

I specifically recommended PuppyLinux and for very sound reasons, including success.
My System SpecsSystem Spec
29 May 2012   #5

XP / Win7 x64 Pro

What does PuppyLinux offer over Ubuntu (or any other) Linux in this situation?
My System SpecsSystem Spec
30 May 2012   #6

Windows 7 x64


thanks for your responses

re PuppyLinux, umm yes I would like to know also if it is worth a try, since this runs on Linux base anyway just like ubuntu...

What happens when you access it in Linux or a command-line based utility? Does it disconnect just the same or is there a different type of error?

Have you tried simply imaging the drive via Linux "dd" and then trying to access the files?
I am not very good at Linux stuffs, but if you think this offers a chance to image the drive, i will.. but does it? considering i already tried DOS BASED imaging tools already. I dont' see how linux based imagers can differ

yes i tried command-line based utilities from DOS w/in Windows, DOS mode alone, and a few other tools from hiren's boot CD collection.. it simply disconnects/powers off as soon as i do anything more than just stare at the root folder..

there are times though using DOS command line, that i can go into a folder and it will show the files and folders within, something i cant do on windows explorer...
My System SpecsSystem Spec
30 May 2012   #7

XP / Win7 x64 Pro

I would try imaging the device via Linux. Obviously there is something going on when you attempt to access the files within Explorer. If it can image the device, then you can mount it as a virtual drive in Windows and extract the files that way.

Boot up Ubuntu and insert the USB drive. Open a terminal and type "sudo fdisk -l". It should list all available media devices. Find your USB device in the list, it should be something like /dev/sdb1 or something like that. Once you know that, you can issue the following command:

dd if=/dev/sdb1 of=image.iso conv=noerror,sync

That will create the "image.iso" file of the USB drive in the local directory you're working in. Next, perform the following:

mkdir /mnt/myusb
mount -o loop image.iso /mnt/myusb
cd /mnt/myusb

That creates a directory "myusb" to store your usb files, extracts the iso image (files) to that directory, and takes you there. Now you can check to see what files are available and copy them to whatever device you'd like to in order to save them. If you plug in another USB drive to save them, you can do something like the following:

cp -r /mnt/myusb /media/<USB Drive> (whatever the name of your newly inserted USB drive is)
My System SpecsSystem Spec
31 May 2012   #8

Windows 7 x64

Awesome FliGi7, i will surely try that. wil report back
My System SpecsSystem Spec
24 Apr 2014   #9

don't know
Hi Brownchild - did it work?

I have the same situation (well, not quite as bad, I can copy small files out of my damaged flash, but not big ones, before it blinks). Ray
My System SpecsSystem Spec
26 Apr 2014   #10

Windows 7 x64

wow i forgot to reply sorry, but no it didnt work for my case..

Because when i attempt to image the drive it also gets disconnected.. anything that i do or when it starts to draw more power for some sort of operation, it shuts off or something..
My System SpecsSystem Spec

 USB Flash Drive power issue? (connect/disconnection loop)

Thread Tools

Similar help and support threads
Thread Forum
Remote Desktop Connection won't connect after disconnection!
Hi, I'm running Windows 7 Ultimate x64 on my computers. Whenever i connection via Remote Desktop Connection, it works fine. If i try to connect again, it won't work where it times out! I have tried to shutdown the service and start it again but it doesn't work! The only way to fix it is...
Network & Sharing
flash drive format issue win7
flash drive or any card reader is perfectly working in windowx xp but when i insert in my windows 7 it show drive is not formated . then I formated on windows 7 it works but when i restart windows 7 it again show flash drive is not formmated . every time i restart windows 7 it does not open...
Hardware & Devices
Hello, Whenever I connect a pendrive/flash drive to my laptop I get this error message.:(But the most irritating thing is that it does not go !!:mad::mad:. CLICK, CONTINUE or TRY AGAIN it wont go. It wont go. Even after I disconnect my drive it shows error. I have to take that error window below...
Hardware & Devices
Windows is running really slow! + USB FLash Drive issue
Hi guys I have been using Win7 for about a week and it has been getting incrementally slower every day. Here are the steps I have taken so far: I have disabled every service I can disable without compromising the functionality of the OS. This includes Superfetch and Indexing. I have...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:32.
Twitter Facebook