Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot initialise HDD keep getting I/O Error...?

01 Jun 2012   #1

Windows Vista 64-Bit
Cannot initialise HDD keep getting I/O Error...?

I'm in a very odd situation that I think the HDD is toast... but I need a second opinion because I've tried just about everything I know and it will not kick into life. that makes matters even worse. The BIOS shows the channel and port and detects the HDD. DiskPart can see the HDD as well and I run a quick format which was successful...? This is where I get lost. If DiskPart can see the HDD and you can format the HDD than, there is communication via data cable and PWR to the HDD is there otherwise you wouldn't be able to format the HDD would you.

There are things that I haven't tried yet... running Seatools in DOS such better for fault finding. changed the data cable and the PWR SATA cables. any other suggestions would be appreciated

My System SpecsSystem Spec
01 Jun 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

Is the partition you created in Diskpart visible in Windows Disk Management? Can you manipulate the partition there---shrink it, expand it, etc?

Do a refresh and rescan from the action menu in DM.
My System SpecsSystem Spec
02 Jun 2012   #3

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

First, a couple questions:
  • Is this a SATA drive?
  • Is this a secondary drive, or is it a primary drive that you are trying to install the OS on?
My (limited) understanding is that Windows 'initializes' a disk by rewriting the MBR. So if Windows reports that it can't initialize the disk then that means it can't find a valid MBR to rewrite - for whatever reason.

One reason may be that the MBR is not in the correct location on the disk (which is normally on the 2 byte end marker - 0x55 0xAA - reportedly) and this is all that is necessary to throw Windows into a snit.

The solution may be in doing either a full format, or to wipe the drive (a process that writes all zeros across the drive) and then doing the full format. That should create a new MBR in the correct location for Windows and allow it to be initialized.
My System SpecsSystem Spec

02 Jun 2012   #4

Windows 7 Home Premium 32 bit

Download, install and run HDD LLF Low Level Format Tool -

This will zerofill each and every sector of your HDD and reinitialise the Hard disk to the factory condition. (Depending on the capacity of the HDD, this process may take quite sometime. Be patient and do not abort it midway through.)

You can also use Diskpart - Clean all to do the same. Disk - Clean and Clean All with Diskpart Command

Good luck.
My System SpecsSystem Spec

 Cannot initialise HDD keep getting I/O Error...?

Thread Tools

Similar help and support threads
Thread Forum
Cannot Initialise Disk - Device not working properly
Hi all, I have a HGST Touro Mobile Pro portable HDD. I have had it for 6 months and use it to store media which I play through my TV. It worked fine until I plugged it in the TV on one day and it said it recognised a USB device, but it needed to be initialised. I plugged it in the PC, it...
Hardware & Devices
3TB usb drive wont initialise
just purchased a 3tb drive but am unable to get it to initialise!! both laptop and my system pick it up in bios but when l try to initialise using either GTP or MBR (obviously l tried GTP first due to its size) l get incorrect function error. l cant open up my system and sort it because it would...
Hardware & Devices
BSOD - cannot initialise disk for crash dump
From yesterday, something made the PC show the BSOD. Since then, then PC boots up and gets into windows OK. However, within only a minute or two, the HDD light will turn solid and the PC will stop responding to mouse clicks (though it will show the mouse movement). Within a minute or two after...
BSOD Help and Support
Seagate Momentus 5400.6: Failure to Format and Initialise
Hey all. A while ago, I got this hard drive from a freind to try and get some data off for them. THey said that they had tried various times to get data off it and had failed. After letting me loose on it for a few hours, I had copied most of the data across (the rest was corrupt and was causing...
Hardware & Devices
Hard drive wont initialise
i have a 800 gig western digital 3.5" hardrive. i was busy copying files then it failed and wont startup again. it shows in disk management as not initialised but when i try to initialise it says incorrect function. other forums say the drive is dead but does any one know of any solutions for this?...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:49.
Twitter Facebook