Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bios Acer 5750G doens't recognize SSD in Optical bay caddy

10 Jun 2012   #1

Windows 7 Home Premium x64
Bios Acer 5750G doens't recognize SSD in Optical bay caddy

Hi, my first post here but I've been reading a lot on this forum and always found the solution to my problems. Except now, I can't find any post related to my problem:

I've been improving my girlfriend's Acer Aspire 5750G (i7-2630QM - 8GB RAM (upgraded from 4GB) -NVIDIA GeForce GT540M - HD: WD6400BVPT @5400rpm) and I wanted to install a Kingston SV100S2/256G (version: SSDNow V100) with Win7 Home Premium on the SSD of course.
Roadmap to my problem:

The SSD doesn't fit in the normal HDD bay: There are 2 plastic pins above the SATA connector so the SSD doesn't fit in there (the SATA connector of a normal 2,5" HDD isn't covered by the casing like the SSD). I found someone on the webs who just broke these pins off but I don't want to lose the warranty on the laptop... yet.

Solution 1: I bought an optical HDD Caddy for the SSD so I could reinstall Windows with the Acer erecovery program which gave me the next problem: The stupid program doesn't let me choose where to install Win7!

Solution 2: I downloaded all drivers seperatly from the Acer site and installed a second Win7 (from a USB stick) on the SSD. Next problem: I tried to install the 100MB partition with the bootmgr on the SSD but that didn't work when I only booted from the SSD without the normal HDD in it. I realised then that the BIOS didn't recognize the SSD in the optical bay. The BIOS only 'sees' the WD HDD.

Solution 3: I deleted the 100MB partition on the SSD, reinstalled Win7 on it and used EasyBCD 2.2 to only boot from the SSD. I wanted to delete the windows on the original HDD (C: drive) but I couldn't (tried with disk management, diskpart and Easus Partition Master). I ended up shrinking the Windows partition on the normal HDD (with Easus) and making a new partition for extra data. I could remove the asigned drive letter from the 100MB partition but not from the windows partition (= C: ). The windows partition on the SSD is asigned to drive letter A:.

So far my system works... Until I tried the WEI just out of curiosity and it gave me an error that it couldn't find a place to store the results (My windows is in Dutch so I didn't translate the whole error message). I'm just wondering now if I have a stable system and if everything is going to keep on working properly.

Is there anybody that can tell me if I made some serious errors? Is there something I should do or shouldn't have done?

Thing I'd like to fix if possible:
- Make the BIOS recognize my SSD.
- Change the drive letter of the SSD to C: and remove the windows partition on the normal HDD.

Overall I've been pretty disappointed with Acer: No place for an SSD upgrade in the normal HDD bay (this mobo should have 2 SATA III interfaces and none of them is used) and their software is not upgrade-friendly at all... .

Anyway, tips & tricks are very welcome... .

My System SpecsSystem Spec
17 Jun 2012   #2

Windows 7 Home Premium x64

I also posted this message on the microsoft technet forum... This is what I found out in the meantime (some thing I repeated because the next text is a combination of 2 answers to 2 replies on the technet forum).

I already updated the BIOS to the last version (1.20). In the 75750G's BIOS the AHCI controller is already enabled (only SATA-ports on this laptop, no IDE). In the BIOS menu the SSD doesn't show anywhere. It should be on the ATAPI CD-ROM but nothing to see there. If I change the boot priority to the ATAPI CD-ROM, it doesn't work (with or whitout the WD HDD in it). It didn't even work when the bootmanager was still on the SSD.

I guess the only option I have is to wait until my warranty is over (october 2013) and then try the SSD in the normal HDD bay or hope that eventually Acer releases a BIOS update that will recognize the SSD.I asked Acer if they could help me with the BIOS problem so I'll see if they can help me out in any way... I'll let you know.

I know the problem is not in Windows. It's just that I have a strange system built up now. I just wanted to be able to boot from the SSD without having the bootmanager on the normal HDD and change the SSD drive letter to C:\.

I tried this now:
A different SSD and a normal HDD in the optical bay caddy: nothing recognized in the BIOS. I also tried the optical bay caddy in my Sony Vaio and no HDD to see there either.

So the only conclusion is that the BIOS isn't programmed to look for a HDD in the optical bay... too bad. I think I just have to wait until my warranty's expired so I can cut of the plastic pins to fit the SSD in the normal HDD bay.
My System SpecsSystem Spec
15 Jul 2012   #3

Windows 7 Professional 64 bit

First of all, you will not void your warranty if you change HDD, RAM or Wifi card ( I have the same notebook ).

Secondly, can you read/write on SSD from Windows, or it's not recognised at all?
My System SpecsSystem Spec

14 Aug 2012   #4

Windows 7 Home Premium x64

Quote   Quote: Originally Posted by g4bryel View Post
First of all, you will not void your warranty if you change HDD, RAM or Wifi card ( I have the same notebook ).

Secondly, can you read/write on SSD from Windows, or it's not recognised at all?
Thanks for the reply but you're questions were already answered in my problem description.

Anyway, problem solved: I cut off the plastic pins (=probably voided my warranty) and put the SSD in the normal HDD bay. Result: BIOS recognised SSD, reinstalled Windows and a smooth system...
My System SpecsSystem Spec

 Bios Acer 5750G doens't recognize SSD in Optical bay caddy

Thread Tools

Similar help and support threads
Thread Forum
Optical mouse works in bios but not with windows
Hello I custom built a PC today using an MSI motherboard. I started it up and checked the bios settings but changed nothing as the default settings were fine. I can use the mouse on the msi bios. I then exited bios and installed the OS windows 7. During the install I was unable to use my logitech...
Hardware & Devices
Acer Aspire 5750G Shutdowns
I keep getting sudden shutdowns on my new Acer Aspire 5750G notebook. I literally bought this model 1 month ago, although I was told it was a showroom model for some time. Usually what happens is that I'm browsing internet/folders (not using any high-demanding programs) and after sometime the...
BSOD Help and Support
How do i install Win XP on an optical-less Acer Aspire One Netbook?
I just bought captioned lappy off ebay without OS. I want to install Win XP. It has no dvd drive and I don't have an external drive. I have Win XP pro on a cd, and 7 ultimate on a dvd and as well as it's image in my toshiba laptop. I actually intend to follow the instructions to dual boot but my...
Installation & Setup
My Acer Aspire 5750G Shuts Down After a Few Hours Due to Blue Screen
Hello everyone, I registered on this forum to get some help. Acer support did not provide me assistance (I have warranty till june 2013). So the problem is that my computer shuts down after some hours when in stand by. It has happened more than ten times already. I followed the procedure...
BSOD Help and Support
DVD Optical Drive Not Recognized in Windows or BIOS
I noticed that sometime after I installed windows 7 that my dvd optical drive was not showing up. I have done a lot of research on the matter and have yet to find a working solution. I checked my BIOS and the drive is not listed there, but I'm pretty sure it is properly connected. I have an HP...
Hardware & Devices
Install W7 w/ Restore Discs on Acer Aspire (no optical drive)
Is it possible? I have another computer and no external optical drive and would like to avoid buying one. thanks
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App