Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HDD on Asmedia SATA port shows as removable device

23 Jun 2012   #1

win 7 64
HDD on Asmedia SATA port shows as removable device

As you probably know the issue is that the HDD shows as removable device in the taskbar.

I have the lastest drivers available from Asmedia and it does not remove the icon from the taskbar.

I also try the MS register fix
My internal SATA device appears in Devices and Printers and in the - Microsoft Answers

1- Since the sata port is not Intel , would the register location be the same for the proposed solution above to work?

2- I tried channels 0..5 , should I try any other number? The solution says that the channel in device manager it is not always the correct one. Under device manager , general tab it displays "Location 0 (Channel 1, Target 0, Lun 0)"

I will appreciate in suggestion.

thank you

My System SpecsSystem Spec
23 Jun 2012   #2

Linux Mint 17 Cinnamon | Win 7 Ult x64


This is normal if you have AHCI enabled as AHCI supports hot-swapping.

If AHCI is not enabled, and you have an intel chipset motherboard IIRC, you need to install the Rapid Storage Technology drivers. I've not proven this myself as I always have AHCI enabled.

My System SpecsSystem Spec
24 Jun 2012   #3

win 7 64

Quote   Quote: Originally Posted by TanyaC View Post

This is normal if you have AHCI enabled as AHCI supports hot-swapping.

If AHCI is not enabled, and you have an intel chipset motherboard IIRC, you need to install the Rapid Storage Technology drivers. I've not proven this myself as I always have AHCI enabled.

Yes, I know about the hot swapping and that is normal. For the Intel SATA ports the Intel RST takes care of that and the disks do not show as removable device.

Even if they did, there is the MS register change (link in OP msg) that can get rid of the issue.

My problem is that with the Asmedia SATA port the register change does not work or I do not know what else to try in the register change (re-read my original post)

My System SpecsSystem Spec

03 Aug 2012   #4

Windows 7 Ultimate x64

I had the same problem as you once I built my new system. I then went and downloaded the latest ASMedia ASM106x drivers and found there is now an option to turn off "safely remove".

It is located in the following location:
- Device Manager
- IDE ATA/ATAPI controllers
- Asmedia 106x SATA Controller

Double click on those controllers and select the "Policies" tab and see if the option is there to deselect "Enable safely remove disk".

You might have a different motherboard than me, but if you have the latest drivers install, it could be a possibility that the option is now there and selectable.

I am currently running with a "Asus Sabertooth z77"

This was the place I downloaded my latest ASMedia drivers from:
ASMEDIA drivers & firmwares

There is also more options to select for different motherboard manufactures that use these ASMedia chips.

Hope this helps some that haven't figured this out yet

I also noticed in my manual that it showed a way to enable/disable hot-swapping on the ASMedia controller from the BIOS. Mine still showed up when I booted into Windows even though I had it disabled in the BIOS.

This fix will allow you to enable/disable right from Windows (*Restart Required) if it is needed in the future for any reason.
My System SpecsSystem Spec

 HDD on Asmedia SATA port shows as removable device

Thread Tools

Similar help and support threads
Thread Forum
Autorun on removable disks/cards no more shows what to do menu !
Hi, suddenly I do no more get a menu windows asking what to do when I insert a removable media ! I get a pop-up window asking whether to check / test the media / drive or continue without analysis, but no more the other pop-up window asking what to execute Earlier ( wednesday...) I got...
General Discussion
My front USB 3 port doesn't read USB 3 device, but reads USB 2 device
I have ASUS P8Z77 V motherboard and the front USB 3.0 headers are not working when I plug in a USB 3.0 device. When I plugged in my Kingston USB 3.0 Flash Drive into the front USB 3.0 header it didn't work. As in, when I tried to move a file into the flash drive, the drive disappears and it makes...
Hardware & Devices
HDD - Sata Port 2 Device Error, Press F1 to continue on start up??
Hi All, I have been given a 3TB Seagate HDD as the original owner believed it to be faulty. So I thought I would take a look after installing it I get this error on boot up. 'Sata Port 2 Device Error, Press F1 to continue' After continuing to windows its not visible in disk management....
Hardware & Devices
after change to SATA AHCI mode in BIOS the drive shows removable
So after I changed to SATA AHCI mode in the BIOS, the main boot internal hard drive shows as a removable device in system tray. So how do I fix this issue, and I did follow the instructions in the Microsoft Knowledge Base article 922976, to enable the...
eSATA drive shows up empty and as four removable disk drives
I have an eSATA drive that has stopped functioning properly. I was trying unsuccessfully to install some completely unrelated software when I noticed that my eSATA drive was presenting differently. Under My Computer it now said that the drive was empty and there were four drives that appeared that...
Hardware & Devices
Removable devices USB port drive letter issue
I have two monitors that have ports for USB and memory card built into the side of them. When the monitor is plugged into the CPU they are assigned drive letters and become available for use. The problem I'm having is that they are sometimes interfering with my network assigned drive letters...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App