Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Vertex 2 hangs BIOS after merging two partions on SSD

24 Jun 2012   #1

Windows 7 Pro 64bit
Vertex 2 hangs BIOS after merging two partions on SSD

Vertex 2 hangs BIOS after merging two partions on SSD

Hello! I have been the owner of a Vertex 2 120 GB for a year now and everything was perfect. I am using Windows 7 on the SSD (AHCI mode); my computer has also a 1 TB hard disk. Last week I created a second partiion on SSD and installed Windows 8 Consumer Preview (dual-boot with Windows 7). After few days I decided to stay with Win7 , so I format the 2nd partition and merge it with the first (using Paragon Partition Manager). The operation completed successfully, however, after restarting, the BIOS hangs at:

Controller Bus#0, Device#1F, Function#02: 06 Ports, 02 Devices

(although there are 3: the SSD, the HDD and the DVD-RW)

If I remove the other two devices and try only the SSD, I get

Port-00: No device Detected.

Without the SSD connected, the computer boots from the HDD. If I plug the SSD while the operating system is running from the HDD (I also have Windows installed on it), the drive is recognized and shown in Windows Explorer. I tried flashing the firmware on SSD from this Windows and succeeded, but still no change. The SSD light is green, I reseted the CMOS by removing the battery on mainboard, I reseted the BIOS to the default settings...nothing works!

Then I changed in BIOS from AHCI to IDE mode and I can boot now from SSD! However, Paragon Partion Manager shows me this:

"Invalid Partition - Unknown : Paragon Hard Disk Manager™ has discovered problems with this partition. It must have been caused by an incorrect geometry. In order to resolve the issue, please collect LOG-files and send them to our Support Team

Howevere, Disk Management in Windows shows no error, so..... But how do I get back to AHCI? I tried to activate it again and the SSD hasn't been recognized again...

Do I have to Secure Erase the drive using OCZ Toolbox and reinstall Windows? If I change back to AHCI in BIOS after Secure Erase, will the SSD be recognized???

Thank you!

My System SpecsSystem Spec
24 Jun 2012   #2

Win7 Ultimate X64

While you are up and running i would take a system image of your current install/SSD then worst case you can wipe the entire SSD and restore from saved image with no need to reinstall/re-setup
My System SpecsSystem Spec
24 Jun 2012   #3

Linux CENTOS 7 / various Windows OS'es and servers

Hi there
I think your problems came with "Merge Partition functionality -- since normally W7 and W8 create a hidden system boot partition at install time and by "Meging" the partitions you might have hosed up your boot mechanism.

The other thing that could have caused a problem is the partition you are trying to boot from is not flagged as "Active". The BIOS should still see the drive but it won't be bootable.

I think your best mechanism would be to logon wth say gparted or another free bootable partition manager -- format the SSD and then if you have an old W7 image use whatever image copying program you have to copy the image to the SSD.

Unless you've got a zillion products to install -- I'd just go for a fresh install -- W7 instals on an SSD in a few minutes !!! and W8 even quicker.

Dont forget to set AHCI in the BIOS before install as you won't be able to change it after installing.

There isn't as the previous poster says any problem with restoring an HDD partition / image to an SSD (provided the destination partition has enough space. Decent imaging programs can also let you dynamically change the size too.

My System SpecsSystem Spec


 Vertex 2 hangs BIOS after merging two partions on SSD

Thread Tools

Similar help and support threads
Thread Forum
BSODs and now bios hangs for a miniute then loads
the bios hangs while loading usb devices for 1 or 2 minutes, then windows loads. Win loads slower than before the bios hang issue appeared (this morning). When win appears to load completely, I get this error message (screen shot attached). Also attached is the DM Log Collector. TIA, John
BSOD Help and Support
Update Hangs, BIOS Changes, Date & Time changes
Hello all! Thanks in Advance to all who replies. So to start this off I have done alot of OS switching in the years ive owned this computer ( purchased sometime late 2011 ) I went from the original OS Windows 7 Home Prem SP1 x64 to many different linux distro and windows installs. I decided...
Windows Updates & Activation
BIOS: Dell Studio 1535 A06 Installation Hangs
PROBLEM: Dell BIOS 1535_A06.EXE update utility hangs during BIOS flash process. DESCRIPTION: 1. Open Dell BIOS 1535_A06.EXE update utility from saved location on desktop by right-clicking and running as Administrator. 2. Click button on "Dell BIOS Flash" update utility dialogue box asking...
Merging partions back together.
i have no luck with this i have my 1 terabyte drive split into 3 partions i want to merge them back together. i have tried computer management partion magic nothing will work or the options arent there or highlighted i really need to fix this. thank you all.
Hardware & Devices
Build 7229 hangs in Bios on AHCI
I installed the most recent version of Win 7 7229 on my vertex 60Gb V 1.3 SSD the other night and after the first reboot the bios stopped when trying to discover the drive which is on '0'. The bios is set to AHCI (as it has always been with previous builds). If I change it to IDE then the drive is...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:43.
Twitter Facebook Google+