Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: CANT access Usb Flash Drive

25 Jul 2012   #1

Windows 7 Ultimate x64
CANT access Usb Flash Drive


If someone could help me would be very appreciated.
My usb flash drive was working without problems until today.
(I dont know if the problem can be caused by the laptop that run out of battery.)
So now when i enter My computer it loads a while, and when (if) drive letter appiers i can rightclick the drive and chose to open it gives message : Please insert driver

I tried to chkdsk and it will give me message that: cant open volym for directaccesss.
Now i also tried to see in prog GetDataBack for fat, and it wont find the drive letter.
i used another prog as well wich gave me the following error: File or device error: the parameter is incorrect.

so i think the drive lost its formatting. can i get the data back that was stored on it? Now when i rightclick the driver in properties there is 0 bytes in free space, 0 bytes used.
I have done somehting similiar before but it was a usb hd not a usb stick.
This one is a verbatim Store n go

Pls help me to get back the data.

My System SpecsSystem Spec
29 Jul 2012   #2

Windows 7 Ultimate x64

someone out there who have a clue
any ideas would be appreciated.
Maybe there is some magic tool to get my data back.
My System SpecsSystem Spec
29 Jul 2012   #3

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Hard to follow from your description - I would try bootice - check what it says about the mbr and the format, and filesystem.

Attachment 223765
My System SpecsSystem Spec

29 Jul 2012   #4

Windows 7 Home Premium 32 bit

To recover data from the pendrive first try Recuva. That should be the easiest to use. Recuva - Undelete, Unerase, File and Disk Recovery - Free Download

If it does not help, you may try PhotoRec in Test Disk which is a powerful tool but requires a bit of learning curve. TestDisk - CGSecurity

Both the above do not write anything to the drive being recovered and absolutely safe to try.

For PhotoRec you may refer to the guide here apart from the documentation in the Test Disk site.
To be specific to your problem the following screenshots should help. (provided PhotoRec can catch your pen drive :))

CANT access Usb Flash Drive-1pressn.jpg

CANT access Usb Flash Drive-2select-enter.jpg

CANT access Usb Flash Drive-3no-partition-enter.jpg

CANT access Usb Flash Drive-4other-enter.jpg

CANT access Usb Flash Drive-5select-enter.jpg

CANT access Usb Flash Drive-6recovery-c.jpg

CANT access Usb Flash Drive-7recoveryinprogress.jpg

CANT access Usb Flash Drive-8recov-complete-q.jpg

CANT access Usb Flash Drive-9selquit-enter.jpg

Then there are other programs like Minitool Partition Recovery and EaseUs Partition Recovery but the free versions will most probably recover only 1GB of data.

Recover ntfs hard drive with MiniTool Partition Recovery.

Free Partition Recovery Software - Recover Deleted FAT/NTFS/HFS/HFS+/HFSX/Ext2/Ext3 Partition in Windows and Mac OSX.

I shall leave it to other experts here in case Recuva and PhotoRec fail to bring results in your case.

My System SpecsSystem Spec
06 Sep 2012   #5

Windows 7 Ultimate x64

thanx i will try
My System SpecsSystem Spec
04 Oct 2012   #6

Windows 7 Ultimate x64


Thanx Jumanji, i tryed both tools they didnt help me. the recuva didnt find path when i searched with it,: path doesnt exist. all tho the path was in my computer.
Testdisk didnt find that disk neither.All other disks it did find except that. The other last 2 progs i didnt try coz the drive contain more than 1 gb files.
I also did got bootice as SIW2 suggested , it loooks very chines.
any other tools? it must be able to fix, if a hdd can be fixed and files broght back from a raw filesys on then this must be able to fix.
pls help
My System SpecsSystem Spec

 CANT access Usb Flash Drive

Thread Tools

Similar help and support threads
Thread Forum
Access is denied. Trying to format a flash drive (in cmd)
Hello everyone! :) I've been trying to format a 32GB flash drive. I'm using DiskPart to format it, but still have no success. I've been trying and trying, but I always encounter the same error. "DiskPart has encountered an error: Access is denied. See the System Event Log for more information"....
Hardware & Devices
Cannot access files within USB flash drive
When I place the device to the USB port, it is displayed under Devices with Removable Storage section of Computer window but I cannot access the files within the device. How can I recover the data within the device in such a case?
General Discussion
Can't access USB flash drive
I suddenly lost access to a USB flash drive while using my laptop on the road. The laptop went into hibernation; when I woke it up, the flash drive had suddenly disappeared. Plugging it into different USB ports didn't help ... or, for that matter, plugging it into USB ports on a different...
Hardware & Devices
Cannot access files on USB flash drive
I just reinstalled my OS and inserted the flash drive. It installed properly, but after I checked it the files looked like in the screenshot I attached and I can't open them. I don't want to format it because I have a lot of important files on it. I'm not sure but I think it has something to do...
Hardware & Devices
USB FLASH drive loads but no access to files
New to the forums here because I just recently started using Win7. Last week I purchased three HP Compaq Elite 8300 computers with Win 7 Pro, for a client to upgrade their small business network. Last night I went out to set up the last two (first one stand alone system). Everything went well...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:09.
Twitter Facebook Google+