Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB ports only recognizing certain devices

04 Aug 2012   #1

Windows 7 Home Premium 64 bit
USB ports only recognizing certain devices

Hi all.

Here's one for you:


My USB ports recognize all storage devices (large or thumb drive). They recognize my usb splitter hug. And they recognize my game controller.

They do NOT recognize: (all these devices work fine on other computers)

My external sound card (although it does draw power).
My other external sound card (no power here).
Any of the 3 USB mice I've tried (2 wireless and 1 wired).

With the non-working devices, usually it just says "device not recognized" and in the device manager I get error 43.



Running Windows 7 Home Premium 64 bit on my Toshiba Satellite a505-s6986.

A little while back I had a virus or something (antivirus was popping up with something every couple of seconds). Tried to get rid of it and wasn't sure what was up. When I tried to restart, I'd get blue screens of death. So I backed up my data and decided to restore to factory condition.

Computer was acting a little weird; I may have messed up the install when I thought it was hanging (it kept restarting and telling me it was "starting for the first time" every time). Eventually it ran sysprep, told me something different ("preparing to start for the first time" I think) but hung there. So I said, ok, new strategy.

Long story short, I ended up taking the laptop to a friend with a completely reformatted drive (partition gone). We did a fresh install of Windows 7, this time with SP1 right in there. Computer is running great, but now the USB problem.


THINGS WE'VE ALREADY TRIED (that haven't worked)

1) Loaded every driver I can find on the Toshiba site.
2) Installed Windows again, this time with said drivers (like the chipset driver) on the CD.
3) Updated the BIOS. Reverted BIOS to old version and updated it back.
4) Booted the computer up in Linux. Same problems with the USB are evident.
5) Uninstalling all unknown devices.
6) Shutting down the computer, taking the power cord and battery out, letting it sit for a few minutes, and booting up again.
7) Took it to a shop. Shop guy was unsure of the problem after working on it for some time. Said he believed it was probably a hardware issue of some sort but agreed it was bizarre. Said replacing the USB ports (they are not soldered onto the motherboard) might work. Or it might not.
8) Turned off USB selective suspend.
9) Sacrificed several small animals.



Running Device Driver finding software, it always points me back to the chipset drivers. I have run the install for this several times.

In the readme for the chipset drivers, it mentions this kind of problem and says there is a hotfix available. However, the hotfix refers only to Windows Server 2003 and Windows XP.

Personally I am not so sure it is a hardware issue, since I wasn't having this problem prior to the reinstall. Also, it doesn't make sense to me that SOME devices would work and others would not.

On the other hand, I'm told booting up in Linux ought to work around any driver problem. Maybe accurate, maybe not. I don't know.

It is possible that I may have messed something up a couple weeks ago when I opened up the computer to glue the USB drives back in place (note: they were working fine before and after. They had just fallen off the mount making them difficult to reach inside the casing). I might have shorted something - as I reconnected some of the hardware (keyboard and touchpad) I did cause the computer to restart (I know, dumb go leave things running while I put this back on). However, the computer worked fine for days after my misadventures, so a delayed reaction like this seems odd. Neither of those parts are having issues, either.


Well, that's it. What do you guys think? I'm lost.

My System SpecsSystem Spec
04 Aug 2012   #2
Layback Bear

Windows 7 Pro. 64/SP-1

I'm thinking on your problem. It would be of help if you would fill in your system specs ((My System Specs)) completely. Remove you splitter hub and try all devices again. One at a time.
My System SpecsSystem Spec
04 Aug 2012   #3

Windows 7 Home Premium 64 bit

Thanks, Bear.

I filled out the specs as well as I knew how. They should be there now.

As for the splitter, I haven't been using it much. I bought it for when two of the drives were inaccessible before I remounted them inside the computer. The devices that do and do not work are consistent. Although occasionally one of the devices I listed as working seems to trigger the "not recognized" popup and then work anyway.

I'm wondering if the splitter might have caused some kind of short. When I restarted it before the initial crash, I believe it was the first time I've booted up with that guy in there. The connection is a bit touchy at times (I knew because devices connected through it would sometimes disconnect briefly). I wonder if this caused the problem.

I located the parts online for the USB hubs. I am tempted to order one to try it out (I know how to get in there from my previous experience repairing the USB mounting). But I don't know if it would work and I just don't have much money right now.

Anyway, very interested in any thoughts. The whole thing is bizarre.

One other thing I haven't tried would be to buy the $30 copy of the original partition that Toshiba sells on their site. The computer is running a lot faster than it ever has, though. And, once again... money I just don't have. If I had money I'd just buy a better computer anyway. :/
My System SpecsSystem Spec

04 Aug 2012   #4

Windows 7 Home Premium 64 bit

Another quick note: iPod Touch connects and functions properly via USB.
My System SpecsSystem Spec
04 Aug 2012   #5

Windows 7 Home Premium 64 bit

Great news!

The eSATA usb drive works. I didn't even realize I could plug USB into this thing.

Between that and my USB splitter, I'm in business.

Any idea what the implications are for the rest of the USB ports with this new information?
My System SpecsSystem Spec
04 Aug 2012   #6

Windows 7 Home Premium 64 bit

Keeps getting weirder.

It keeps getting weirder...

I have discovered that if I plug non-functioning devices into specific tendrils of the USB composite device, they now work.

What could this mean? Something to do with how they're drawing power maybe?

At least things are functional!
My System SpecsSystem Spec
04 Aug 2012   #7

Windows 7 Home Premium 64 bit

No, wait... eSATA functions like the others.

BUT if I plug non-fuctioning devices into specific inputs on the splitter, they DO work.


What could this mean?

At least I can get things working!!!
My System SpecsSystem Spec
04 Aug 2012   #8
Layback Bear

Windows 7 Pro. 64/SP-1

I have not and will not use a splitter on my computers. A usb port has x amount of amps and x amount of volts. They were designed to install one thing at a time, not to split off for several things.
My System SpecsSystem Spec
04 Aug 2012   #9

Windows 7x64 Home Premium SP1

I have never had problems with my Logitech USB powered hubs. In fact each hub output USB port has better load specs than a standard USB(500mA). I'd rather the powered hub fail than the internal.
My System SpecsSystem Spec

 USB ports only recognizing certain devices

Thread Tools

Similar help and support threads
Thread Forum
Issues with devices; (error 28) not recognizing wireless adapter
Hey hows it going? My problem with my computer is that under device manager my ethernet, USB controllers and wireless adapter appear w/o their drivers. I never had this issue before. But funnily enough, I everything is fine except for my wireless adapter. Windows cannot recognize it and so I can't...
Windows 7 not recognizing my phone devices
My windows 7 computer is not recognizing my android or windows 7 phones (I have Zune set up to work with the windows phone). The usb drives work when I connect a thumbdrive or ipod to them, and the the phones charge when connected. I've tried checking drivers and nothing helped (may not have...
Hardware & Devices
USB 3.0 ports not reading 2.0 devices
I just received my new computer and everything is great, When I use the two front USB ports which are 3.0 with a 2.0 device it won't read it at all? I checked all the drivers where up to date. It reads 3.0 devices but not 2 and I have no idea what to do. Anyone know what I could do? I've tried...
Hardware & Devices
Asus AT5IONT-I USB 3.0 ports not recognizing WD portable hard drive
For over a year, things were good and then recently it just stopped recognizing my USB 3.0 WD portable hard drive. I tried connecting the drive to another computer with USB 3.0 and it works fine there so I've ruled out the hard drive being the issue. The port still powers the drive and hdd light...
Hardware & Devices
USB 3.0 Ports Not Working with USB 3.0 Devices
Greetings! Sorry if this has been covered but Seven Forums search isn't working atm -- I search for USB 3.0 and I get no results! I went through pages of posts and read all relevant posts but they haven't resolved my problem. Anyway: OS: win 7 pro 64 sp1 mobo: asrock x58 extreme6 cpu: i7...
Hardware & Devices
win 7 not recognizing usb devices
the issue here is I have several usb devices(external HDD and flash drives), when I insert the devices into the usb port either of 2 things happens, it takes at least 20-30 seconds to show or nothing happens(in this case I can sometimes get the device to be recognized if I go into administrative...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App