Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Asus USB-N13 network adapter problems

21 Aug 2012   #1

Windows 7 Ultimate 64 bit
Asus USB-N13 network adapter problems

Hi, I'm running Windows 7 32bit with a MSI ms-7698 motherboard. I'm trying to install the drivers for an Asus USB-N13 network adapter. I have no cd drive so I've downloaded the drivers from the Asus site. When I run the setup file for the driver it says it can only be ran on windows 7 (which is what I'm using). I've also tried using device manager to manually select the driver and install but that doesn't work either. I've also installed the "Asus WLAN Control Center" thinking there would be an option to install drivers through that. But when I try to run it it says that it will run once the network adapter is plugged in, which it is. Under "devices and printers" it shows my adapter as "unspecified" so my pc is recognizing that it is plugged in...any suggestions would be appreciated, I've exhausted all resources.

My System SpecsSystem Spec
21 Aug 2012   #2

Windows 7 Ultimate 64 bit

Just copied everything off from the disc onto flash drive using friends pc. Then installed off flash drive and it works perfectly.
My System SpecsSystem Spec

 Asus USB-N13 network adapter problems

Thread Tools

Similar help and support threads
Thread Forum
Asus laptop: Network Adapter Not Found
I am unable to connect to the internet using wifi. When I go to Intel My Wifi Technology, it tells me that a Network Adapter Not Found. When I try to troubleshoot my internet connection, I receive the message troubleshooting couldn't identify the problem. When I go to Device Manager and check...
General Discussion
Problems with wireless network adapter and network connection driver
Hi, So recently I have removed a nasty zeroaccess rootkit virus(es) from my laptop. My Windows Firewall, Defender and Updates would not work (still won't), my browser kept redirecting to unrelated websites, and I was just overall having a TON of irritating issues. I installed MalwareBytes and...
Network & Sharing
Complex Network Adapter Problems
Please bear with me. Our house has an old Linksys Wireless-G Router that came with external USB Network cards. I found that using one of those, my desktop can connect to the router, but gets about two bars of signal strength and provides a sluggish at best netowrk connection. Eventually I...
Network & Sharing
Asus n53sv-xe1 atheros network adapter not working.
Sorry if the title of this thread did not provide to much information. I just have so many problems they would not fit into the title... Lets start from the beginning. So i recently purchased an Asus n53sv-xe1. When i got it, the internet connection was working fine for a couple months.. Until...
Hardware & Devices
Problems in Network adapter (Code 10)
Hello, I have devices that aren't working in network adapter : Microsoft 6to4 ISATAP Adapter , Microsoft teredo tunneling pseudo-interface , microsoft Adapter , Microsoft Adapter #2 , Microsoft Adapter #3 . In properties, I see error (Code 10). The devices are up to date. I have uninstalled...
Network & Sharing
Belkin G+ Network adapter problems
Hey sevenforums im new here =]. Anyways i just got my windows 7 ultimate working and everything is working fine expect my network adapter. I installed the vista drivers found on the belkin website. Which did the trick and made it work. But i noticed every 2 hours or so the adapter would...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App