Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB 3.0 External HD gets corrupt on shutdown

15 Oct 2012   #1

Windows 7 Pro x64
USB 3.0 External HD gets corrupt on shutdown


I have a Seagate 2TB external drive for backup up. It is partitioned into W: and X: each 1TB. W: is used only for weekly backups with Windows Backup, and X: is used daily only by FreeFileSync to mirror my important data files.

I have been getting this error ID 4103 from Window Backup: "The backup did not complete because of an error writing to the backup location W:\. The error is: The last backup was not successful because the backup location has a corrupted file system. (0x81000008)"

I ran chkdsk /r W: and it repaired W: and marked 1 bad cluster. Backup worked after that.

But the disk just gets corrupt again. chkdsk /f W: fixes it (but takes 4 hours), but later in day gets error ID 55 and a few days later error ID 11 and when starting up get a notice that W: should be checked. Backup fails with the drive.

After chkdsk fixes it, SeaTools tests on the drive all PASS. Can the bad cluster be the source of the problems (the vendor will replace the drive if I want)? Or could it be a USB problem? Windows says all the drivers are correct.

Also I noticed in the log that various errors have been occurring lots (started in August 1 month after I got the drive) - usually the first message below, but sometime others

ID 11:
"The driver detected a controller error on \Device\Harddisk2\DR2."
"The driver detected a controller error on \Device\Harddisk2\DR3."
"The driver detected a controller error on \Device\Harddisk3\DR3"
"The driver detected a controller error on \Device\Harddisk3\DR4."

ID 136: "The default transaction resource manager on volume W: encountered an error while starting and its metadata was reset. The data contains the error code." (also some on X:, one for C: )

ID 137: "The default transaction resource manager on volume W: encountered a non-retryable error and could not start. The data contains the error code." (once for X: )

ID 51: "An error was detected on device \Device\Harddisk2\DR2 during a paging operation."

ID 55: "The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume W:." (also X: )

ID 57: "The system failed to flush data to the transaction log. Corruption may occur."


My System SpecsSystem Spec
16 Oct 2012   #2

Windows 7 x64 Professional

Quick question have you tried formatting the external hard drive at all?
My System SpecsSystem Spec
16 Oct 2012   #3

Windows 7 Pro x64

No. I don't want to loose all my backups.
My System SpecsSystem Spec

17 Oct 2012   #4

Windows 7 x64 Professional

Does it work after you try recovering it or is it corrupt now every time you try to use it?
My System SpecsSystem Spec
18 Oct 2012   #5

Windows 7 Pro x64

Hi Swifty, After I run chkdsk W: /f it is ok, but after a few days it becomes corrupt. I just did chkdsk today and immediately ran backup which worked. I suspect after I shutdown and login a few times, it will become corrupt again. If I try and safely remove it, I always get a pop up that says it is in use. How can I find what program has a lock on it? Maybe this is the source of the problem? I've included the log below. 'file 9' had the error in it. This was the same file in the previous chkdsk log. How can I tell what file this is?

This is the chkdsk log:
Chkdsk was executed in read/write mode.

Checking file system on W:
The type of the file system is NTFS.
Volume label is Backup .

CHKDSK is verifying files (stage 1 of 3)...
20736 file records processed.
File verification completed.
0 large file records processed.
0 bad file records processed.
0 EA records processed.
0 reparse records processed.
CHKDSK is verifying indexes (stage 2 of 3)...
20888 index entries processed.
Index verification completed.
0 unindexed files scanned.
0 unindexed files recovered.
CHKDSK is verifying security descriptors (stage 3 of 3)...
20736 file SDs/SIDs processed.
Cleaning up 6 unused index entries from index $SII of file 9.
Cleaning up 6 unused index entries from index $SDH of file 9.
Cleaning up 6 unused security descriptors.
Security descriptor verification completed.
77 data files processed.
CHKDSK is verifying Usn Journal...
The remaining of an USN page at offset 0xc46108 in file 0x41
should be filled with zeros.
The remaining of an USN page at offset 0xc79620 in file 0x41
should be filled with zeros.

Repairing Usn Journal file record segment.
13083064 USN bytes processed.
Usn Journal verification completed.
Windows has made corrections to the file system.

976760917 KB total disk space.
255845676 KB in 2320 files.
1060 KB in 78 indexes.
4 KB in bad sectors.
129313 KB in use by the system.
65536 KB occupied by the log file.
720784864 KB available on disk.

4096 bytes in each allocation unit.
244190229 total allocation units on disk.
180196216 allocation units available on disk.
My System SpecsSystem Spec
19 Oct 2012   #6

Windows 7 x64 Professional

Can you do me a quick test, try putting your computer on sleep, and then wake the computer again to see if it still operates. To confirm its only on reboot when the device becomes corrupt.
My System SpecsSystem Spec
19 Oct 2012   #7

Windows 7 Pro x64

Hi Swifty, this morning when I started my machine again, the drive seemed ok. I ran chkntfs W: and it reported "file system NTFS W: is not dirty." There had been no errors in the log. I then put the machine to sleep as you suggested. I resumed from standby at 8:21.20. I then ran chkntfs W: and it reported something different: "file system is RAW W: is not dirty." I also checked the other partition on the drive and it said it was RAW too. I notice in the system disk log at 8:23.11, 20 instances of error ID 50 "An error was detected on device \Device\Harddisk2\DR2 during a paging operation." I ran chkntfs W: again and this time it reported something like drive W: not found!, but both X: and W: show up windows explorer. I ran chkntfs W: again! and this time it reports "file system NTFS W: is not dirty." I also just ran SeaTools short drive self test and it passes. Anyway I hope this is helpful to you, it sure is puzzling to me! Thanks.

I tried to shutdown the machine at about 8:55 and it just hung at "windows is shutting down." I left it and came back at 9:15 and it was back to the login in screen. I checked the log, and found system bugcheck ID 1001

"The computer has rebooted from a bugcheck. The bugcheck was: 0x0000009f (0x0000000000000003, 0xfffffa8010a78060, 0xfffff80000b9c3d8, 0xfffffa80101a2c10). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: 102012-5506-01."

I looked at MEMORY.DMP and got this:

Microsoft (R) Windows Debugger Version 6.2.9200.16384 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: SRV*C:\symbols*
Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17944.amd64fre.win7sp1_gdr.120830-0333
Machine Name:
Kernel base = 0xfffff800`03010000 PsLoadedModuleList = 0xfffff800`03254670
Debug session time: Sat Oct 20 09:15:07.941 2012 (UTC + 13:00)
System Uptime: 0 days 1:07:18.174
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
* *
* Bugcheck Analysis *
* *
Use !analyze -v to get detailed debugging information.
BugCheck 9F, {3, fffffa8010a78060, fffff80000b9c3d8, fffffa80101a2c10}
Probably caused by : usbccgp.sys

Followup: MachineOwner
0: kd> !analyze -v
* *
* Bugcheck Analysis *
* *

A driver has failed to complete a power IRP within a specific time (usually 10 minutes).
Arg1: 0000000000000003, A device object has been blocking an Irp for too long a time
Arg2: fffffa8010a78060, Physical Device Object of the stack
Arg3: fffff80000b9c3d8, nt!TRIAGE_9F_POWER on Win7, otherwise the Functional Device Object of the stack
Arg4: fffffa80101a2c10, The blocked IRP

Debugging Details:
IMAGE_NAME: usbccgp.sys
MODULE_NAME: usbccgp
FAULTING_MODULE: fffff88005c94000 usbccgp
fffff800`00b9c388 fffff800`030f96d2 : 00000000`0000009f 00000000`00000003 fffffa80`10a78060 fffff800`00b9c3d8 : nt!KeBugCheckEx
fffff800`00b9c390 fffff800`03099c3c : fffff800`00b9c4d8 fffff800`00b9c4d8 00000000`00000000 00000000`00000001 : nt! ?? ::FNODOBFM::`string'+0x33ac0
fffff800`00b9c430 fffff800`03099ad6 : fffff800`03236f20 00000000`0003f327 00000000`00000000 fffff880`0f71f009 : nt!KiProcessTimerDpcTable+0x6c
fffff800`00b9c4a0 fffff800`030999be : 00000009`66f09117 fffff800`00b9cb18 00000000`0003f327 fffff800`03204768 : nt!KiProcessExpiredTimerList+0xc6
fffff800`00b9caf0 fffff800`030997a7 : 00000003`0603f0c2 00000003`0003f327 00000003`0603f033 00000000`00000027 : nt!KiTimerExpiration+0x1be
fffff800`00b9cb90 fffff800`03086cca : fffff800`03201e80 fffff800`0320fcc0 00000000`00000001 fffff880`00000000 : nt!KiRetireDpcList+0x277
fffff800`00b9cc40 00000000`00000000 : fffff800`00b9d000 fffff800`00b97000 fffff800`00b9cc00 00000000`00000000 : nt!KiIdleLoop+0x5a

FAILURE_BUCKET_ID: X64_0x9F_3_lvuvc64_IMAGE_usbccgp.sys
BUCKET_ID: X64_0x9F_3_lvuvc64_IMAGE_usbccgp.sys
Followup: MachineOwner
My System SpecsSystem Spec

 USB 3.0 External HD gets corrupt on shutdown

Thread Tools

Similar help and support threads
Thread Forum
Bsod on shutdown win32k.sys and corrupt files in sfc/scanow
Hello, all ive been running in to a few issues on this machine for a while occasional bsod's, and ive noticed sfc/scannow reports coruption of files in cbs.log on reboot or shutdown i recently just had "page fault in non paged area" win32k.sys and for the last few weeks i noticed stange...
BSOD Help and Support
Corrupt/lost data on NEW external HDD
Hi, Firstly sorry for long thread but i thought it best to give as much info as possible....... I recently purchased a Barracuda ST3000DM001 HDD for use as storage within an external Thermaltake 5G USB3 enclosure. I connected it directly to one of my PC's and installed Win 7...
General Discussion
Corrupt External HDDs except when used on my laptop
Hi all, I apologise for the crap title and i accidently posted before I even started! I was given two External usb HDDs both 80gb each, my friend said they were totally unusable on his laptops they were corrupted but using them on my laptop I successfully formatted and am using them as we...
Hardware & Devices
need to rescue corrupt(?) external hard drive
Hi all, I know this is a topic that generates questions all the time, but I haven't yet found a solution that works from all the searching I've done. My external hard drive (1TB Seagate FreeAgent GoFlex) is, as far as I can tell, corrupted in some manner. I don't remember exactly the...
Hardware & Devices
Corrupt files on external hard drive
Ok, So, today I left my computer on while i went out for a little while as it was making an archive of a file (located on my internal hard drive). I came home to find the computer locked up on the screen saver, tried a "Ctrl-Alt-Del", and nothing happened. I waited a little bit to see if it would...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:47.
Twitter Facebook Google+