Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Rig crashed due to a failed PSU --> Replaced with new Corsair AX1200

22 Oct 2012   #1

Windows 7 Ultimate 64 bit
Rig crashed due to a failed PSU --> Replaced with new Corsair AX1200

Rig crashed due to a failed PSU --> Replaced with new Corsair AX1200 and now the Win 7 Ultimate 64bit is not recognizing the 12 gb Corsair Dominators (shows only 4 gb). I've searched the forums for this issues and the common responses was - to go to BOOT Advanced Options and uncheck the maximum memory.

The Dominators are fine because they are detected by CPU ID. The MOBO is only showing 4 gb as well. I tried the 12 gb memory modules in a friends computer and it works fine! Any input is appreciated

i7 920
Asus Rampage 2 gene
12 gb Corsair Dominator 1600
WD Black 1 TB
EVGA GTX 280 Physx
Corsair AX1200
Windows 7 Ultimate 64 bit

My System SpecsSystem Spec
22 Oct 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1

Helo jeromesm3. Welcome to the forum.

The first thing that stands out is "failed power supply". It would not be unusual for a sudden failure to take out components with it. You should brace yourself for this possibility.

The first thing to do is run Memtest86+ - Advanced Memory Diagnostic Tool on it.
First, run the test with all RAM installed. If Memtest only sees 4GB you can quit.

Second, remove all sticks of RAM except 1 stick in the A1 (first) RAM slot, and run Memtest on it (at least 3 passes). Do this for each stick of RAM - test it in Slot A1. You are trying to determine if any of the RAM modules are damaged.

Then test one tested and known good stick in each RAM slot. You are testing to see if any of the RAM slots are damaged.

Let us know what you find.
My System SpecsSystem Spec
22 Oct 2012   #3

Windows 7 Ultimate 64 bit


Thanks for the reply! I ran the memory test and it ran just fine. I also borrowed another 6 gb DDR3 from a friend and my rig only shows 4 gb. Not sure if reinstalling Win 7 Ultimate would help. So per CPU ID - all the memory modules are working. The only thing I can think of is probably one of the CPU pins are bent or the DIMM slots are defective (which is unlikely).

My System SpecsSystem Spec

22 Oct 2012   #4
Microsoft MVP

Win 7 Ultimate x64

Seeing as it was working before, it is possible that you knock the heatsink slightly out of place while changing the power supply, and that can also cause all the memory not to be detected. Maybe start with resetting the heatsink (and can also check the pins in the socket at the same time) and see if that fixes it.
My System SpecsSystem Spec

 Rig crashed due to a failed PSU --> Replaced with new Corsair AX1200

Thread Tools

Similar help and support threads
Thread Forum
BSOD 0x116 (stop error) Replaced GPU, replaced RAM, replaced PSU
My monitor goes black and I am forced to reboot. After rebooting I get a blue screen prompt telling me that i've recovered from a BSOD. I've been monitoring them since October. In October, I RMA'd my graphics card. Oct 27. You can see that after I got a new GPU, my BSOD's halted... so...
BSOD Help and Support
Windows Updates Failed BITS failed to start error code 2147024894
anybody have any ideas? have tried sfc /scannow also the steps in this but to no avail, i still receive the error message i have also used take ownership on the downloader file in...
Windows Updates & Activation
Upgraded PC system crashed, Win7 reinstall failed, hardware stopped..
Hi i have 3 yrs old Pacard Bell IXTREME X6620 UK. Over year ago I upgraded power supply to Corsair GS600 and graphic card to ASUS GTX560TI DirectCUII Top. After upgrade I reinstalled (clean) system and all was in good working order. Last week my PC froze while browsing internet and the only thing...
Installation & Setup
Replaced failed hard drive on Acer Aspire 5734z. Windows validation.
My hard drive failed on an Acer Aspire 5734z that I have. I replaced the hard drive and reloaded Windows 7 Home Premium 64bit from a downloaded copy. Since this is the same OS as originally came on this laptop, how do I get it validated? Or, alternately, how do I get a replacement OS without having...
Installation & Setup
64bit laptop crashed and wont start on safe mode,system repair failed
please help i just crashed som1 64 bit lennovo laptop while i opperate a 32 bit pc dont have any windows system with me,it wont start on safe mode,and system repair has failed many times.the laptop was running on low battry and it shut itself,when i tryed to reboot it,it automaticly went to system...
General Discussion
Crashed Updating Nvidia GTX 260. Can't start Win7.StartupRepair Failed
So about 2 hours ago on my PC. I was playing WoW and had a hard crash and lock up. So I restarted my PC. Everything seemed fine. Just a mysterious crash. So I went on to updating my graphics drivers since it had been on my mind to do so. About half way into the update my desktop then crashed...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App