Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Intel 825879LM Gigabit Network Card - Cannot start (Code 10)

14 Nov 2012   #1

Windows 7 Professional x64
Intel 825879LM Gigabit Network Card - Cannot start (Code 10)


I have recently purchased a new system, and since the first time I booted it up the on board gigabit network card is unable to start. I get the following error when in device manager:

Device cannot start (code 10)
In order for the device to work, whilst in device manager, I must uninstall the driver and then scan for hardware changes. Doing this re-installs the driver and the network card will connect to the network. All is fine.

I'm running an Asus P8Z77-V with a Intel Core i7 3770K and a Corsair 16GB DDR3 Vengeance. The on board network card is an Intel 82579LM.

I have already updated the BIOS to the latest version, and I have tried installing the latest drivers from ASUS and Intel directly with no luck. Interestingly I only will get this error on a cold boot, if I sleep or restart the computer I do not get this issue, and the network card connects automatically, which is why I'm thinking its probably a software/driver issue...

Just wondering if anyone else has any further ideas to try and debug this?

My System SpecsSystem Spec
15 Nov 2012   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

update the network driver.
First, download the network card driver from manufactuer's website, Intel Download Center
Then reinstall the driver:
  1. Click the Start Button, type "devmgmt.msc" (without quotation marks) in the Start Menu Search box and press Enter.
  2. Double click to expand "Network adaptors".
  3. Right click your network card and click Uninstall.
  4. Check "Delete driver software for this device" check box, click OK.
  5. Restart the computer
  6. If windows does not auto configure the appropriate drivers at startup, install the downloaded one manually.
If it does not work, Go for a System Restore.

Let us know the results.
My System SpecsSystem Spec
15 Nov 2012   #3

Windows 7 Professional x64

I have followed your previous advice, and I'm still having issues from a cold boot.

I haven't bothered doing a System Restore, because I have had this problem since the first time I installed windows, so I can't see the point.

Interestingly when I searched for my device on the intel downloads page there was a tool to update the NVRAM for the ethernet to which I have downloaded and ran using the instructions.

The first time I ran it a BSOD appeared - DRIVER_VERIFIER_DETECTED_VIOLATION - after restarting the machine I ran the same tool again, this time no BSOD was given but it said that 0 products needed updating.

I've attached the log and the report from running that tool and the mini-dump of the BSOD.

thanks in advance.

Attached Files
File Type: txt log.txt (1.3 KB, 37 views)
File Type: txt report.txt (213 Bytes, 20 views)
File Type: zip (24.5 KB, 34 views)
My System SpecsSystem Spec

25 Mar 2013   #4

Windows 7 Ultimate 64

Hi Clangers,

I have the exactly the same problem. did you find a cure, because it is driving me mad. Your help please.

Thank you
My System SpecsSystem Spec
30 Mar 2013   #5

Windows 7 Ultimate x64 / RHEL6.4

Quote   Quote: Originally Posted by RobinGB View Post
Hi Clangers,

I have the exactly the same problem. did you find a cure, because it is driving me mad. Your help please.

Thank you
Hi !
I have the exactly the same problem for hp 8570w with intel 82579LM network adapter.
This problem not only happens in Windows but also the linux (which I builded the RHEL6.4 in my machine),
Did you fixed this issue already?
Sorry for my bad English!
My System SpecsSystem Spec
24 Sep 2013   #6

Windows 7 Professional 64 bit
Intel gigabit network have similar problem!!!!


My problem is the same as Clangers. My network device cannot start on bootup but if I disable and then enable it in device manager or reboot, it will work again. So, the problem is not with the hardware. I have tried everything related to drivers like rolling back to older versions then updating, reinstalling drivers and I got the file straight off Intel's webpage. Anyone of you have this problem solved?I need help desperately.
My System SpecsSystem Spec
24 Sep 2013   #7

Windows 7 32 bit

Arc's suggestion worked for me.

I'm using Windows 7 Pro 32 Bit.

I went to Intel's download center.
Downloaded the driver for Windows Vista 32bit as I was unable to find a Windows 7 version.
My System SpecsSystem Spec
20 Nov 2013   #8

Windows 7 64bit

Hey Guys,

Try installing chipset driver before installing the NIC drivers. Without the chipset drivers some drivers might not work or even install properly.
Hope this helps!
My System SpecsSystem Spec
07 Apr 2016   #9

10 Pro x64

Did anyone ever find a solution for this? I have to same problem. NVRAM update doesn't work (says no device needs updating).

The problem only exists when doing a cold boot.
My System SpecsSystem Spec
05 Mar 2017   #10

Win 10 x64

So I know that this is old, but just in case someone still wants to know, I think I might have figured it out. In device manager bring up the intel 82579LM network adapter properties. Click on the Power Management Tab. UNCHECK "Allow the computer to turn off this device to save power". Seems to have fixed my issue.

Update: Never mind, issue is back. I guess no one ever figured this out?
My System SpecsSystem Spec

 Intel 825879LM Gigabit Network Card - Cannot start (Code 10)

Thread Tools

Similar help and support threads
Thread Forum
Network connection stuck at 100Mbps (Gigabit card installed)...
Hi all, I cannot work out what could be causing a network card to only connect at 100mbps (full duplex). The setup of the office is as follows: WAN -> Router = 100Mbps Fibre Router -> Switch = 1000Mbps port Switch -> Patch Panel = Cat5e Cable (Switch port configured to Auto) Patch Panel...
Network & Sharing
Intel dual gigabit 1000/pro PT PCIE network adapter not working!
Ok so I just got a used Intel Dual Gigabit 1000/PRO PT PCIE network adapter. My Hardware is as follows: Intel i7 3770k ASUS Z77V-PRO mobo 8GB Ram AMD Radeon HD 7850 video card Audigy2 ZS PCI sound card
Hardware & Devices
Intel LAN Card - Cannot start (code 10)
Hello, Earlier today while gaming my Corsair Cx500 power supply failed shutting off my pc and forcing me to replace it with a Corsair Cx750m power supply. Upon rebooting my computer I noticed that I didnt have internet connection and that a hardwired connection was not available under adapter...
Hardware & Devices
82578DC Gigabit Network Adapter - Error Code 10
Hello Last night Win 7 did an automatic update and it's causing havoc with the network adapter. I'm not 100% sure what information you need but this is what I think will help. I'm hoping someone here can help me. Adapter = 82578DC Gigabit adapter from Intel. Core = i5 (I mixed up which...
Network & Sharing
Gigabit nic stuck at 100mbps in Gigabit network.
Cannot get gigabit performance out of Nics in Win 7.. Locked 100 mbps. My motherboard is an Evga 590 Sli Am2 motherboard, with dual gigabit nics. Having established that there is really no benefit to using both nics at the same time in another post, I am now posting because it seems I am only...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:20.
Twitter Facebook Google+