Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Creating a new file in C: drive gives error 0x80070522

21 Nov 2012   #1

Windows 7 Ultimate 64-bit (Service Pack 1)
Creating a new file in C: drive gives error 0x80070522

If I try to create a new file in C: drive, I get this error:
Error 0x80070522: A required privilege is not held by client.
I first noticed this error after doing a 'frugal' install of BackTrack 5R3 (Linux distribution) setup on C: using UNetbootin. I thought it must be preventing me from creating files so that they don't interfere with the Backtrack setup.

I ran the setup, but did not install BackTrack. And after that, I installed UNetbootin. Uninstalling removed newly-created 'frugal' install files and UNetbootin boot entry.

UNetbootin had changed permissions for C: (It seemed so). I tried to revert them manually by changing one permission from 'Applies to: Subfolders and filers' to 'Applies to: This folder, subfolders and files'.

On some forums (including Microsoft Answers), people were recommending to use
takeown and cacls. That did not solve my problem. And the commands they suggested applied on all subfolders and files as well. I have no problem with subfolders.

The previous Owner was 'TrustedInstaller'. After using
takeown, icacls and cacls, I could not revert the Owner back to TrustedInstaller, or to SYSTEM (as the owner of other partitions is 'SYSTEM') using command-line.

I have checked the permissions and the permissions for C: seem to be the same as for D: or E:, and they work fine.

And, yes, a point of note:

This error appears when I try to create a file by using
Right-click > New > Text document. Or when I use notepad (or any other application) to save to C: drive. But, if I run notepad (or other applications) as administrator, the file is saved without error.


- System Restore does not solve the problem.

My System SpecsSystem Spec
21 Nov 2012   #2

Windows 10 Pro (x64)

It was perfectly normal for you not to be able to create a file in the root of C. It is setup that way by default. Administrative power is required (aka, Run as Administrator) to create file (folders can be made, however!) in the root of C.
My System SpecsSystem Spec
22 Nov 2012   #3

Windows 7 Ultimate 64-bit (Service Pack 1)

Oh God... I wish I knew that earlier.... I wasted days trying to fix a problem which wasn't a problem in the first place....

Thanks for your reply.
My System SpecsSystem Spec

16 May 2015   #4

Windows 10 Pro (x64)

So your solution is to turn off UAC? That is not a valid solution, in my opinion.
My System SpecsSystem Spec
27 Aug 2015   #5


Thank for you help

but when i use this setting (means turn off the uac) to my win 10pro x64 pc it will off microsoft edge

please guide me.
My System SpecsSystem Spec
27 Aug 2015   #6

Windows 7 Home Premium x64

The question is, do you really need to create a file in the root C: directory? You can probably create it in another folder if it's a text file or image or something. I can understand if there is a direct need to create in C: but if there isn't then there's no point in going through all this.
My System SpecsSystem Spec

 Creating a new file in C: drive gives error 0x80070522

Thread Tools

Similar help and support threads
Thread Forum
2 boot locations, partitioned disk with error 0x80070522
Hi, A friend of mine is in dire need of help. Her computer has a 1tb hard drive that she is not able to use because every time she tries to save a file on C: she get error 0x80070522, I noticed also that when rebooting the computer boot screen comes up ( good 'ol MS DOS looking screen) that...
Performance & Maintenance
Stop creating file.db and recent.db on USB drive
When I plug in a USB flash drive, it's creating 2 files: file.db and recent.db These database files will open in notepad. File.db seems to be a list of all files on the flash drive and recent.db is a list of recently accessed files on the drive. If I delete them, it just recreates them. I don't...
General Discussion
Error 0x80070522 (no solution?)
I'll describe the scenario under which my issue occured so that maybe it will by chance give someone an idea of what actually happened (because I don't understand it at all). I networked my desktop and laptop computers the other day. I shared my entire hard disk on my laptop with my desktop....
Network & Sharing
Creating a bootable flash drive from ISO file
First and foremost, I would like to apologize, as this is in regards to WinXP.... I have a friend that need to install Windows XP 32Bit, SP2. I do not have a hard copy, but I do have an ISO file, its about 640 MB. Its a custom computer that does not have USB bootable capabilities, But I'm...
Installation & Setup
Weird Error 0x80070522: A required privilege is not held by the client
I have a weird Error 0x80070522 error on one of my partition. Why is weird ? Well because I cannot save anything on the partition because I receive this error. However sometimes, randomly i can copy files on that partition after I receive the ''You need to provide system administrator privilege.......
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:15.
Twitter Facebook Google+