Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB FLASH drive loads but no access to files

13 Dec 2012   #1

Win 7 home, Win7 pro
USB FLASH drive loads but no access to files

New to the forums here because I just recently started using Win7. Last week I purchased three HP Compaq Elite 8300 computers with Win 7 Pro, for a client to upgrade their small business network.

Last night I went out to set up the last two (first one stand alone system). Everything went well with getting them to communicate, but then I pulled off the data from the old computer (Win XP Pro) to a new flash drive. I inserted the flash drive into the new computer. It proceeded to find it, load the driver and tell me it was available. But when I go to get the files, it tells me that it is empty.

I need to run home for something else so I take the flash drive with me and check it against my computers at home XP pro and Win 7 home, it shows up and gives me access to the files. No big deal (I think ), I'll just use my external HDD, so I take it back and transfer the folders and files to it. I get the same issue, W7 finds it loads the drivers tells me it's available for use but tells me there are no files or that I don't have access to the drive.

I try to take control of the drive through the security but still no love. I've tried searches for this issue and I've found some who have said that they went into disk management and changed the drive letter...did that, no change. I've gone into the security settings within W7 and gave everyone access permissions.

This HP computer has some sort of HP security system built in (I can't remember the actual name). I've been through the settings in it and gave permissions to access removable drives. Nothing I've done makes any difference. Now, sometimes, when I insert the flash drive it doesn't even show up in "My Computer".

Even after all this, I didn't think it would matter, since they have this computer backed up with Carbonite, but we had trouble downloading the data.....but that is another issue.

I'm at the end of my rope. Please, any help to resolve this problem would be greatly appreciated. Sorry for the long post, but felt like you needed all the info I could supply. Oh, I won't be going back out there until this evening (Thursday 12/13)

My System SpecsSystem Spec
13 Dec 2012   #2

Windows 7 Home Premium SP-1, 64-bit

Is this a major brand flash drive bought from a reputable dealer?

The market is flooded with cheap fakes from Asia, usually marked with brands such as Sony. They are counterfeits, using low-end chips that are modded to display a large but fake capacity. When you try to save files to them, failures are common. You'll see loads of eBay listings for such counterfeits, with prices unrealistically low for large capacity when compared to the legit brand name models.
My System SpecsSystem Spec
13 Dec 2012   #3

Win 7 home, Win7 pro

Yes it is a major brand bought at Staples (I don't remember the brand). It works in my Win 7 machine at home just fine. I'm thinking it has to do with rights....

This afternoon I got a call from the people and they had tried again with a 4Gb (the one I had was 8Gb) flash drive and it read it just fine. Is there a limit on size in Windows 7? Well no, can't be I just said it works on my Win 7 machine. Something isn't making sense.
My System SpecsSystem Spec

13 Dec 2012   #4

Win 7 home, Win7 pro

It is a PNY 8Gb flash drive.
My System SpecsSystem Spec
13 Dec 2012   #5

Win 7 home, Win7 pro

Update...I spent another three hours working on the computers tonight and found that some other flash drives work perfectly while others don't. I was able to retrieve the data I needed from the old computer using a different flash drive.
My System SpecsSystem Spec

 USB FLASH drive loads but no access to files

Thread Tools

Similar help and support threads
Thread Forum
Cannot access files within USB flash drive
When I place the device to the USB port, it is displayed under Devices with Removable Storage section of Computer window but I cannot access the files within the device. How can I recover the data within the device in such a case?
General Discussion
Can't access USB flash drive
I suddenly lost access to a USB flash drive while using my laptop on the road. The laptop went into hibernation; when I woke it up, the flash drive had suddenly disappeared. Plugging it into different USB ports didn't help ... or, for that matter, plugging it into USB ports on a different...
Hardware & Devices
Cannot access files on USB flash drive
I just reinstalled my OS and inserted the flash drive. It installed properly, but after I checked it the files looked like in the screenshot I attached and I can't open them. I don't want to format it because I have a lot of important files on it. I'm not sure but I think it has something to do...
Hardware & Devices
CANT access Usb Flash Drive
Hi If someone could help me would be very appreciated. My usb flash drive was working without problems until today. (I dont know if the problem can be caused by the laptop that run out of battery.) So now when i enter My computer it loads a while, and when (if) drive letter appiers i can...
Hardware & Devices
Flash drive driver loads-unloads-loads....
I bought a FlashVoyager 16GBGT in September for use with my XP pro machine and all was fine. I have now upgraded to Windows 7 Pro 32-bit and I can no longer use the flash drive. When I plug it into a port the Autoplay window pops up for a few seconds and then disappears, then reappears, then... and...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:15.
Twitter Facebook Google+