Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB device wont work after windows 7 patch - causes system to freeze

16 Dec 2012   #1

Windows 7 64-bit
USB device wont work after windows 7 patch - causes system to freeze

Hi everyone,

This is my first time posting, I'm hoping someone can help me with my issue here.

I have a Dell Latitude E6510, everything was working fine for over a year, I recently installed a set of windows recommended patches, after which myUSB port stopped working, what's worse, if I stick somethign in, like a memory stick, or even just a mouse, the response times start to get slow, and after about 10 minutes or so it usually freezes the laptop, requiring a hard boot.

Not sure if this is related, but I also had Intuit QuickBooks installed, and it got hosed up too. I was able to work through it after 3 hours with Intuis support, but seemed pretty crazy. They had to fix some .Net Framework, MSXML, and Visual C (or C++) related components. Both issues, QuickBooks and the USB ports, were affected at, or around, the same time.

Searching on google again I came across this site, and a thread that looked very promising, with a link to a Microsoft patch, however it looks like I don't have the same chipset, though edxperiencing the same problem. I'm wondering if anyone can point me to a similar fix for my system.

For reference, here is the link that was referred in that other thread: You encounter problems when you move data over USB from a Windows 7 or Windows Server 2008 R2-based computer that has an NVIDIA USB EHCI chipset and at least 4GB of RAM

I went in to device manager and deleted all USB components, did a reboot and let the system reinstall the drivers, but it still doesn't work.

Any help would be greatly appreciated.


My System SpecsSystem Spec
16 Dec 2012   #2

Windows 7 Home Premium 32 bit

Hi arigur,

Welcome to SevenForums.

Can you please enumerate the patches you installed. I am also curious to know who or where it was recommended.

As an immediate solution, check whether you have any System Restore point prior to the installed patches. If there is one, restore to that point.
My System SpecsSystem Spec
16 Dec 2012   #3

Windows 7 64-bit

Hi Jumanji,

Thank you for the quick reply.

Unfortunately there was no restore point, I wish there were. I thought it was on by default, apparently not (it is on now though).

I've attached a screenshot of the patches that were installed when this happened, I wonder if there may be some others that don't show up becasue they failed, but perhaps this will help.

I just ran through some instructions I found on another site (USB Driver - General Fix for Problems), but that did not work either. I attached a USB device at the step they mention and the system froze again...

Thanks again.

Attached Thumbnails
USB device wont work after windows 7 patch - causes system to freeze-patches.jpg  
My System SpecsSystem Spec

17 Dec 2012   #4

Windows 7 Home Premium 32 bit

Ok, these appear to be the regular Windows updates and not something that you have fished out from somewhere and installed as I had assumed. These regular Windows updates cannot generally be the cause of your problem. If it were, it would have affected many users and we would have come to know of it.

Having said that, I know nothing about QuickBooks and therefore cannot say anything about it - whether it is related to your problem in anyway.

So hang on till your problem catches the attention of better knowledgeable brains here.
My System SpecsSystem Spec
17 Dec 2012   #5

Windows 7 64-bit

I should have mentioned that during the original patch install, right before it stopped working, the system had hung. As a result I had to do a hard boot and that may, more than likely, have been the cause of the issues to begin with.

There are a few more patches that need to be installed under "important updates" but when I go to install them, it fails. It would come back after reboot forcing a safe-mode boot, and then rolling back. I ended up installing a few, one at a time (and rebooting between each), trying to determine which one was causing the issue, there are more in the list now, but at the time I had narrowed it down, I believe the one causing issues was/is:KB2749655.

Thanks for looking in to this though, and yes, hopefully someone else will come up with something.

In my google/bing searches for something similar, it does seem that there are quite a few people that have experienced the same thing. Try looking up "USB stopped working after upgrade" or some variant of that...
My System SpecsSystem Spec
17 Dec 2012   #6

Windows 7 Home Premium 32 bit

That additional info you had provided - system freeze during Windows update - should of course give a handle to other experts here to give a focussed solution. ( Personally I had never experienced an update failure and so have no education in fixing it. )

And again it would help if you try to install each and every failed update, note down the error message and post it here.

In the meanwhile, you may also run system file checker to repair any corrupted system files. SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
18 Dec 2012   #7

Windows 7 64-bit

I ran SFC /verifyonly and it came back that:
"Windows Resource Protection did not find any integrity violations."

I will try to work on adding a those patches again to isolate which one fails, though hopefully I can get this resolved soon.
My System SpecsSystem Spec
21 Dec 2012   #8

Windows 7 64-bit

As another sypmtom update, though I'm not sure if its related, it seems almost every other time when I try to access a network share, I get a similar system reaction - system freezes. whatever the main window is active goes white, at first I can still drag teh window, then that stops.

A pop-up appears about windows not responding, and do I want to close or cancel.

I can't launch the task manager, ctrl-shift-esc, or alt-ctrl-delete have no affect, and I'm forced in to a hard power-down.

Still hoping someone here can help me out, or point me in a direction to fix this, other than basically rebuilding the system.

My System SpecsSystem Spec
27 Dec 2012   #9

Windows 7 64-bit

Hi jumanji,

I hope you are still reading this thread, or maybe someone else is by now. I just came across the link to show me all of the failed updates, I thought maybe this would be helpful. Also, maybe there is some steps I can take (or maybe shouldn't take) in trying to resolve this... Should I somehow try to reinstall all of those failed updates (even though they don't show up on the list of important updates?) or maybe there is a way to force those to be removed? What state is the system in if they failed? ... so many question...

Attaching the screenshot of the failed patches (more then the previous list).

Thanks for your help.

Attached Thumbnails
USB device wont work after windows 7 patch - causes system to freeze-failed-updates.jpg  
My System SpecsSystem Spec

 USB device wont work after windows 7 patch - causes system to freeze

Thread Tools

Similar help and support threads
Thread Forum
Patch causing start-up freeze. Help to remove?
Hi, it would be great if anyone could help with this please: My Lenovo G570 laptop, running Windows 7 Home Premium, started to hang on the "starting windows" screen A few weeks ago. Sometimes it would start up okay, and sometimes it would not. Now it doesn't at all, although a couple of times...
General Discussion
system repair wont work windows wont load
not sure if im in the right place but computer wont do anything but load up with options to do system repair or whatever its called but it says it cant fix the problem i dont have disc for it or any pw's im on a reg user account it wont load in safe mode but by doing different things i have access...
Hardware & Devices
Computer wont Boot system repair doesnt work
I tried getting back on the computer this morning and it went to the loading screen just sat there all black screen with the words starting on it like usual but then it took me back to boot up menu saying that it recommended i use system repair. So i did and it just ran for about 2 hours while it...
BSOD Help and Support
System restore wont work.
Hi, I dont know much about system resotre, but everytime i try to do one, i get this error. Any help appricated :)
Backup and Restore
Regedit wont run, and grant admin full control context menu wont work
For some reason, my logon background image isnt showing up anymore, and when I try to change back to the way I had done it, regedit wont run, I've searched the forums for an answer, with no luck. And when I go to click grant admin full control, it brings up an open with menu, so I need a command...
General Discussion
JUNK mail patch wont install
Hi All: I am running win7 pro there were 3 update patches 2 of them installed the junk mail patch KB979895 wont install gimes me an error cod57a did a search but could not find any fixes or what causes this issue..Any help would be appreciated Thanks Eddy
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App