Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The Active Directory Domain Services is currently unavailable

24 Dec 2012   #1

Windows 7 Home Premium 64 bit
The Active Directory Domain Services is currently unavailable

Hi - Fixing my elderly father's W7/64 desktop. Attempting to print form MS Word to an HP3390 does not give any errors but does not print, either. Attempting to "find printer" from MS Word gives "The Active Directory Domain Services is currently unavailable." I went to services.msc to turn on that service but it does not appear in the list. Driver for the printer is already included in Windows 7, according to the HP support site. Printer is USB connected directly to the computer.

BTW Computer is running MW Word 2003 if that makes any difference.

Any ideas/advice? Thanks!

My System SpecsSystem Spec
24 Dec 2012   #2

7 x64 Ultimate

Try this?

The above notwithstanding, I just went through all the same hoops here - in my case trying to get my laptop to hook up with the HP printer attached via USB to a desktop on the network. Inevitably with HP printers, I went to hell and back trying to install it, and just at just about the point where I was ready to attempt to fling the printer over the horizon - it inexplicably connected and printed just fine.

I think at some point I have been there with almost every printer I have ever owned. Why you can perform the same operation 19 times and get a different result on the 20th ... I have no idea.
My System SpecsSystem Spec
24 Dec 2012   #3

7 x64 Ultimate

Just to add - this may actually be a network / firewall issue. If you are running on a network, try rebooting your router or temporarily disabling your firewall.
My System SpecsSystem Spec

26 Mar 2014   #4

Win7 Pro 32-bit and XP Pro (17 windows machines)

The problem may instead be that when you installed MS Office, you didn't already have a PHYSICAL or VIRTUAL printer already installed as the default. That's been the problem with the last six Win7 machines I've installed to. I forgot how I solved it with the others, so when trying to install my sixth machine over the weekend (yes, started last FRIDAY), finally yesterday I remembered what worked.


1. Uninstall all MS Office-related products. Only complete uninstallation corrects the problem, at least if you're using MS Office 2003 and prior. ALL components must be uninstalled. Also, if you installed MS Office to some drive other than C:, uninstall and reinstall to C. (Adobe doesn't work rightly with Word, if the latter isn't completely installed on the C drive.)
2. Make sure that in WINDOWS you have a physical or virtual printer set as your default, and that it works (i.e., print something). If you've uninstalled your pdf converter, install it now UNLESS you want it to create add-ins for Word (Acrobat 6-7,9 create Word add-ins, as does SmartPDF Creator Pro).
3. Then, reinstall MS Office products one by one, testing whether your default physical printer is recognized by them.
4. If 3 is successful, then install your pdf converter. If not, then you've some other problem I don't know how to fix.

5. Your pdf converter, if it installs add-ins, then needs to be tested inside and outside Word. With Adobe Acrobat, usually only the add-in works, but Adobe still can't convert outside Word. If you convert to Acrobat inside Word, be sure to uncheck the 'reflow and accessibility' boxes, and to check the 'links' boxes that you want to port through. Else, they won't. Somehow, reflow conflicts with links, and prevents them from being recognized when viewed in Adobe Acrobat.

6. The result of #5 is that one of the two conversions (inside or outside Word), works correctly. I've never seen both of them work correctly.

7. Before you allow Windows updates, clone your hard drive. Windows updates tend to damage pdf conversion, and I can't say why or what kind of updates. I only know it happens, because it's happened to me many times since November last. So now I've learned that when I have this problem, to just clone before applying updates, then if the problem recurs, to clone back to my hard drive using Clonezilla, turn off the machine afterwards, and then boot up.

I wish I could stop the updates, altogether. Finally, this procedure was used on 32-bit Windows, though since you're using MS Office 2003, even on 64-bit, you should have the same problems as I did.
My System SpecsSystem Spec

 The Active Directory Domain Services is currently unavailable

Thread Tools

Similar help and support threads
Thread Forum
Can't install printer : "Active directory domain services is curren.."
Have just reinstalled Windows 7 32 bit over Windows 7 64 bit and my computer doesn't now recognise the same printer that it recognised under the 64 bit OS. Could someone please help me with this?
Hardware & Devices
Active Directory Domain Services unavailable - print error
HP 3015 All-in-One has worked fine for years, plugged into wife's PC. Yesterday it stopped communicating and the error message; "Active Directory Domain Services unavailable" is cryptic. This error is discussed in various internet fora but no solution found is pertinent to my problem. ...
Hardware & Devices
active directory domain services is currently unavailable error
Purchased my Dell Studio 1749 laptop on Mon. and trying to add my printer/copier at my office. when I go to the print page in Word 2007 there is an Find Printer button. I've used this feature before to install printers. but, when I click on the button I get this error message - Active Directory...
Network & Sharing
the active domain services is currently unavailable
I have been having problems with my printer since i installed windows 7. It used to be that the printer was the default printer and when i tried to print something it would freeze somewhere between 6%-99% and would not print. I then checked to see that i could still "see" the printer in the 'add...
Hardware & Devices
The Active Directory Domain Services -error
Hi, I'm new to these forms, my name is Kcaz. Today I was trying to add wireless printers to my computer (Toshiba running Windows 7 64 bit). At home, I have one wireless printer (Cannon) which works fine. To install that i think I downloaded the drivers from a CD. Now I was trying to download...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:36.
Twitter Facebook Google+