Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Does not recognise my External HD after installing SSD

27 Dec 2012   #1

Windows 7 Home Premium OEM SP1 64bit
Windows 7 Does not recognise my External HD after installing SSD

Hi all,

I am sorry to raise this issue again, but I have searched the forum and tried everything I can find. I recently tried to upgrade my computer by installing a new OCZ Agility III SSD. I didn't really want to reinstall windows as it is an OEM install and I dont have the disk. I therefore took the supposedly easy way out and bought a OCZ SSD Upgrade kit which contained Acronis True Image HD software to "Easily Clone and Transfer Data" as per the front of the box.

The existing drives were 2 Seagate 500GB drive in a RAID0 Configuration

All seemed to go well with cloning the drive, booting off the SSD until I noticed that no mass storage devices I have were being recognised anymore, all of which worked perfectly with the old RAID0 drives.

I have tried everything that I can find on this forum to no avail, however, I am not a computer expert, but a reasonably competent home user. On my motherboard (Foxconn H67MP), I have 2 yellow and 4 blue SATA ports. At the moment, I have the SSD in a blue port and have left the old disks in a RAID array on the yellow ones as I think they are the only ports that support RAID.

During the installation, I repartitioned the RAID drives to create a backup partition which may or may not be relevant?

I have 3 External HD, 2 WD and an Iomega all of which worked before installing the SSD. The WDs are USB powered and the Iomega (shows in device manager as Samsung HD503HI) is externally powered but none of them show in disk management.

I can see the drives in device manager with a yellow warning triangle, however not in disk management. I have tried uninstalling the drives, the USB controllers, disabling power management

Any suggestions would be gratefully received as I am at the point of giving up.

Edit: I do have the original recovery disk

My System SpecsSystem Spec
27 Dec 2012   #2

W7 Home Premium 32bit

We need clarifications on some steps you took.

Size of the Agility? Total used space on your RAID?

Let's get started with the Acronis. You can't "clone" 1000g of hd storage onto an ssd capacity much less than that. Did you actually image the RAID? Explain how you did the image backup.

Is the ssd booting okay to desktop and everything is working? (Except the external hd issue)
Can you put everything back the way it was? I mean just the RAID, and working?

Why on earth would you repartition the RAID for backup purposes when you have three externals to handle that job?

Please follow up with these answers, and I'll try to get you up and running.
I'm guessing you have a broken W7 from that clone that you did.
My System SpecsSystem Spec
27 Dec 2012   #3

Win 7 Pro x64, VM Win XP, Win7 Pro Sandbox, Kubuntu 11

A good idea would be to contact the computer MF and see if you can get (purchase) the original OEM disks for that specific computer. The MF usually will be able to sent them to you for a small price along with shipping. Then you can do a clean install which just might have all the drivers needed for your system. . .just a thought.

BTW, "Welcome to the Seven Forums." . . .
My System SpecsSystem Spec

27 Dec 2012   #4

Windows 7 Home Premium OEM SP1 64bit

Thank you both for your replies, and the welcome to the forum. I have found the OEM disk that came with the PC and have decided to start from Scratch. Ive not done anything to this PC before and my previous PC had a single hard disk so not really used to RAID etc. The SSD is 120MB and my system disk had less 80MB on it after I partitioned it. I did use the clone function in Acronis but obviously messed it up. Luckily I had the sense to back up my data.

The SSD was booting up fine, and my keyboard, mouse, printer and network adapter were all working fine. Only mass storage wasnt being recognised.

However, I realise I have made a pigs ear of it, so have reformatted the SSD and will start from scratch. My 3 external hardisks are all pretty full as I use them to back up 15 years of photographs multiple times and use them for media on 2 Tv's.

Really appreciate you taking the time to reply, and may be back tomorrow if I mess up again. Mechanical engineer not IT
My System SpecsSystem Spec
27 Dec 2012   #5

Windows 7 Home Premium 64bit SP 1

SSD / HDD : Optimize for Windows Reinstallation

Clean Reinstall - Factory OEM Windows 7

Here are a couple of tutorials you might find helpful. Good luck!
My System SpecsSystem Spec
28 Dec 2012   #6

Windows 7 Home Premium OEM SP1 64bit

Thanks for your help, I have now reinstalled windows and all is working fine.
My System SpecsSystem Spec
28 Dec 2012   #7

Windows 7 Home Premium 64bit SP 1

Glad to hear things are working for you now! Happy Holidays!
My System SpecsSystem Spec

 Windows 7 Does not recognise my External HD after installing SSD

Thread Tools

Similar help and support threads
Thread Forum
External Hard drive, computer does not recognise and I/0 device error
Hello, I believe last week I had the similar problem with my Memory card but I could still gain access and now my External HDD is acting up. I am not sure if I downloaded a file which may have caused a virus and damaged it. Basically I don't even know if it is possible for me to data recover my...
Hardware & Devices
Windows will not recognise microphone input from external sound device
Hi, I'm running Windows 7 Home N SP1 x64. I'm using an M-Audio Fast-Track Pro device to record audio into a music sequencer (Cubase 5), through a Shure SM58 Microphone. The M-Audio box is connected to the computer via USB. I've been using this set-up for about a year now and it hadn't caused me...
Sound & Audio
Laptop will not recognise external HD
Hi everyone, I am using a SAMSUNG NP-S3510-A03 laptop. The problems I have had with this laptop are unreal, I wouldn't recommend anyone to buy it. Anyway, my current problem is that the laptop will not read my external HD that it was previsouly reading fine before. I recently got a whole...
Hardware & Devices
windows 7 won't print recognise external hd can't access control panel
hi my laptop was working now it won't print i can't access print manager, it won't recognise the external hard drive i can't get at the control panel, i've run a full scan alls well!? tried various prompts anyone anywhere any ideas? cheers:mad:
Hardware & Devices
Windows will not recognise my backup image on external hard drive?
Hey guys, I restored my computer from the windows 7 CD that came with my computer and when I went to restore my computer to a backup that I had put on my external hard drive, windows will say that it cannot find any backups. Is there anyway I can fix this? I know my backup works because I first...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:59.
Twitter Facebook Google+