Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB 3 ports do not work

03 Jan 2013   #11

Windows 7 Home 64bit

fireberd: thanks for sticking with me.

I went back to the Intel site and manually downloaded the chipset. The single USB2 port still works, the three USB3 ports do not work. A change in the description appeared in the Device Manager: The (two) Standard Enhanced PCI to USB Host Controller is now called,
Intel 7 Series/C216 Chipset family USB Enhanced Host Controller - 1E26 (the second one is called 1E2D).

My Microsoft Office 2000 is the edition that would not work in WIN-8.
When I tried several months ago to install AutoCad14 on my desktop WiN-7 Home Edition, it would not do anything except refuse. I did not know at the time about Compatibility Mode. I did find out later that AutoCad14 would install in WIN-7 PRO in "XP Mode" on this new laptop. That is one of the reasons I removed WIN-8.

I was going to paste the screenshot of the Device Manager, but I don't know how. I could do it in Microsoft Word, but not here. I copied by clicking "prt sc" and then I could paste in MS Word, but not here on this forum. There are probably instructions somewhere on the forum, but I didn't take the time to look.

My System SpecsSystem Spec
03 Jan 2013   #12

Windows 7 Home 64bit
try this

USB 3 ports do not work-screenshot1.png

My System SpecsSystem Spec
03 Jan 2013   #13

Windows 7 Home 64bit
again with .jpg

USB 3 ports do not work-screenshot2.jpg

On the HP trouble shooting page, it suggests un-installing the "USB Root Hubs" and then restarting the PC. I did this and it automatically reinstalled them exactly like they were. I am now wondering if I need to plug in some USB3 device and then expect the PC to recognize the port. Up to this point, I have just plugged in the Logitech cordless mouse to test the different ports. Since it is an old device, maybe the USB3 port will not recognize it. The mouse does not work in any of the USB3 ports, but does work in the USB2 port.

My System SpecsSystem Spec

03 Jan 2013   #14

Windows 10 64 bit

The USB3 controller is still not installed according to what I see in the Device Manager, along with other items. You are going to have to find drivers that will work for these devices.

The "Enhanced Controller" entries indicate the USB2 ports ar operating at USB 2 speed.

My USB 3 ports will recognize whatever is plugged in, not just USB 3 devices. If a USB 2.0 device is plugged in then they will work at USB 2.0 speed. If a USB 3.0 device is plugged in then they work at USB 3.0 speed.

It may come down to the fact that HP has got you over a barrel and drivers for the USB3 and others simply are not available and will never work.

If you can return the PC, the best recommendation is to reinstall Win 8 back to how it was originally and return it for a different model that will fully support Win 7. Do your homework first and make sure whatever you are considering does have the PC Vendor's support and drivers for Win 7.
My System SpecsSystem Spec
03 Jan 2013   #15

Windows 7 Home 64bit
Thanks fireberd!!!

Thanks fireberd. I will quit bothering you for now. I may go back to HP and see if they will provide USB3 drivers, even though I have mutilated their product. I do not intend to return the laptop to Fry's or reinstall WIN8. I consider it my problem since I did not do enough homework before the purchase. It works well otherwise. I do not need the USB3 port for my purposes, at least not today. Since the ports were there, I just wanted them to function. Thanks again for your help and "patience". Joe
My System SpecsSystem Spec
03 Jan 2013   #16

Windows 10 64 bit

You are not "bothering" me. This is the whole purpose of the "users helping users" forums. I'm a retired computer geek and I still do this to keep my brain working.

If you knew the manufacturer of the USB 3, there is probably a driver around somewhere.
My System SpecsSystem Spec
03 Jan 2013   #17

Win7 Home Premium 64x

Do you have a blank CD and the skills to burn an ISO file to it? if so, you could try a Ubuntu Live CD. (if you need help with this, we can help)

Desktop | Ubuntu

Boot from it and see if the USB ports work. They should work.... ubuntu won't use your windows drivers. If they work there then it is a driver issue in windows.
My System SpecsSystem Spec
03 Jan 2013   #18

Windows 7 Home 64bit
Problem solved

Thanks to all, especially fireberd. I posted on the HP Forum and a guy named Paul directed me to a USB3 driver download. Now, all three USB3 ports work and even the USB2 still works. Amazing.

Here is the link in case anyone else is interested:

HP EliteBook 8570p Notebook PC*-* Intel USB 3.0 Driver - HP Business Support Center

The Device Manager now shows:
Intel USB 3.0 eXtensible Host Controller
Intel USB 3.0 Root Hub

These did not appear earlier, so the old man was confused when looking for USB3 ports.
Thanks again
My System SpecsSystem Spec
03 Jan 2013   #19
Microsoft MVP

Windows 7 Ultimate X64 SP1

I helped none at all, but so glad to hear you were able to upgrade to w7 and find compatible drivers.
My System SpecsSystem Spec

 USB 3 ports do not work

Thread Tools

Similar help and support threads
Thread Forum
Front USB ports not working, but rear USB ports work…
This is a brand new custom built PC for web browsing for a motel lobby. Win7 Home Premium AMD A4-3300 Llano MSI A55M-P33 FM1 Rosewill FBM-02 MicroATX Mini Tower Running latest BIOS and latest drivers downloaded directly from manufacturer's website. I tried switching between all 3...
Hardware & Devices
USB ports don't work
A few minutes ago my TOSHIBA C655 USB ports were working fine not any of the two of them work now. I have tried many cords too. Can someone PLEASE help me?!
Hardware & Devices
USB 3.0 ports refuse to work as USB 3.0 ports
A few days ago I installed a USB 3.0 card (to be precise, this one: 2-Port USB 3.0 SuperSpeed PCI-E Controller Card - Free Shipping - DealExtreme). It uses the very common NEC µPD720200 USB 3.0 controller. I installed the required drivers for Windows 7, and the card worked fine for the first...
Hardware & Devices
LIBusb, USB ports doesn't work. Safe mode also no work
After I install LIBusb I could work futher. But after I put him off en reboot an hour later my wired mouse en keyboard didn't work anymore. When I restart in safe mode both still doesnt work. OS: W7 Home Premium 64b Computer: HP Pavilion p6250 Please Help!!
All ports of the USB does not work
All ports of the USB does not work She was working before ! :cry: My motherboard is (( PC-AM3RS790G - PURE CrossFireX 790GX ))

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:06.
Twitter Facebook Google+