Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB controller going bad?

19 Jan 2013   #1

Windows 7 Ultimate x64
USB controller going bad?

For the past 3-4 months, I have been having problems with what I believe to be my USB controller (not a gamepad, the IC on the mobo). I should mention now that I am using a USB WiFi adapter, specifically a Belkin Play USB Adapter. The first symptom was downloads in chrome randomly stopping; giving a "network error".

Then youtube videos restarting randomly or cutting to a green screen and rapidly skipping forward to the end of the video or just pausing and not being able to time-seek to any point in the video. All other video streams would give similar results.

Next, the WiFi signal strength tray icon would show limited access and show only the network I was connected to, instead of the usual list of ~7 I get. When I disconnect from the network, the icon changed to show a "ethernet disconnected" icon instead of the "networks available" icon. When I tried to open the network and sharing center via right click from the tray icon, nothing would happen. When I went through control panel to get there, the explorer window would freeze and crash. I went into device manager and my wifi adapter was not listed.

I tried to unplug and re-plug the adapter back in to the same USB port. Half the time this would work and return everything to normal, other times the computer would not recognize it; no "USB device connected" sound, nothing new in device manager, nothing. Sometimes if I tried a different USB port it would work until it did the same thing and then I neither port would recognize it. I should note that this symptom (the one described in this and the previous paragraph) usually only happens with high internet traffic; ~2-3MBps download and 700+ MBps upload.

I tried a different USB WiFi adapter; a Netgear N300 with the exact same results.

The next symptom is devices, specifically an xbox 360 controller, iPod, and Google Nexus 7 randomly disconnecting and then immediately reconnecting with windows giving me a message balloon saying "this device can perform faster if connected to a USB 2.0 port. " I know all of my ports are USB 2.0, and 2 more from a second controller on my mobo being 3.0; and yes, I tried plugging my WiFi adapter into those as well, same result.

Just recently while playing farcry 3, the screen froze and audio looped and then ended. After restarting my pc, the same "ethernet disconnected" icon was in the system tray. I could open network and sharing center this time and then clicked "change adapter settings." My WIFi adapter was not listed, just my ethernet port and the VMware adapters for VMware player. Another restart with the adapter removed and the re-connected after windows had finished booting returned internet connectivity.

My PC specs are:
Windows 7 Ultimate x64
Asus Cross Hair IV Formula
AMD Phenom II X6 1090T
8GB Gskill ripjaws PC1333
2x AMD Radeon HD 5870
1TB Seagate barracuda
1TB Samsung spinpoint
ASUS DRW-24B1ST 24x DVD burner

Any help would be appreciated. I'm tired of having to download every file onto my nexus 7 and then copying it to my pc.

Thanks in advance.

My System SpecsSystem Spec
19 Jan 2013   #2

Microsoft Windows 8.1 Enterprise 64-bit

Can you install an add-in PCI card that gives you USB ports and see if those work for you? This is how I determine if the onboard USB is going bad...
My System SpecsSystem Spec

 USB controller going bad?

Thread Tools

Similar help and support threads
Thread Forum
AMD Driver problems - SM Bus Controller, Ethernet Controller
Hello guys, I've been having a lot of issues with my AMD drivers, specially when it comes to chipset and video drivers. I recently had to downgrade my video drivers to June 2015 release date, that was the only solution found so I could run games properly (with recent drivers, games that should run...
Missing some driver: SM Bus Controller, PCI Device, Network Controller
Hey I just recently switch my hard drive ( 320gb HDD 5400 rpm ) to a Samsung 840 EVO 250 Gb. I'm currently missing some files and I can't seem to find those drivers help? Btw it's a laptop here the model if you wanted to know : Asus X401A Network Controller ...
Network Controller and PCI Simple Communications Controller issues
Hi System: Windows 7 Home Premium 64bit Acer Aspire 5820T Hard drive blew so had to replace it and reinstall windows, however these two devices Network Controller and PCI Simple Communications Controller issues are not installed correctly with error message in Device Manager of (Code 28)...
Hardware & Devices
Missing Ethernet controller and PCI simple communications controller
Hi there, this is my first post on the forum as I found this site while browsing on my iPod. Now why would I have to use my iPod when I have a beautiful new computer sitting in front of me? Well as the title says. I have no controllers, ergo, no Internet. I bought it second hand, absolutely...
Mass Storage controller and Media Controller Windows-7
I installed windows 7 on Sony VGC LT15E. I installed Nvidia driver. its good working but Im looking for driver for and mass storage controller and media controller Where do I find it Thanks for advance!

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App