Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: WD my passport not initializing

25 Jan 2013   #11

Win 7 Home Premium 64bit

it takes a while to be recoginzed and makes a sorta ticking or clicking sound whilst it's getting recognized... maybe it is faulty and I need an RMA?

My System SpecsSystem Spec
25 Jan 2013   #12

Windows 7 Home Premium 64 Bit

Quote   Quote: Originally Posted by Rashmanadon View Post
it takes a while to be recoginzed and makes a sorta ticking or clicking sound whilst it's getting recognized... maybe it is faulty and I need an RMA?

Use WD tools to check the disc for errors.
My System SpecsSystem Spec
25 Jan 2013   #13

Win 7 Home Premium 64bit

which WD tool? I've got DriverUpdate, Firmware Update and quick formatter...

Driver update says fine, Firmware says I/o error and quick formatter says firmware won't allow disk change..

I plugged it in to an xp machine and it shows up as Mass storage device when you connect it, but doesn't show up under disk management... not even as an uninitialized device
My System SpecsSystem Spec

25 Jan 2013   #14

Win 7 Home Premium 64bit

Not sure if this ss helps either. Shows the device listed as uninitialized on win7 disk management, and the properties found under Devices and Printers section. It doesn't have any volume apparently and is unpopulated?

Attached Thumbnails
WD my passport not initializing-wdhdd2.jpg  
My System SpecsSystem Spec
25 Jan 2013   #15

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Um Rashmanodon Mate try Partition Wizard and see if the drive come up in that - if it does run a surface test on it.
If that works then we can do a disk wipe and reformat etc etc

Best Free Partition Manager Freeware and free partition magic for Windows 7, Windows 8, Windows Vista and Windows XP 32 bit & 64 bit. MiniTool Free Partition Manager Software Home Edition. < extremely handy tool for heaps of things.

There is another option yet but try this one and ley us know.

But I am beginning to think you have a controller problem on that drive
My System SpecsSystem Spec
26 Jan 2013   #16

Win 7 Home Premium 64bit

My computer keeps freezing every time i try to open up the program, just says the program has stopped responding, tried it on the other machine and got teh same thing?
My System SpecsSystem Spec
31 Jan 2013   #17

Windows 7 Home Premium 64bit


I a having the same problem with my 1 TB Western Digital My Passport. It doesn't get detected with my Windows 7, 64 bit or Ubuntu 12.04. Here is how it shows on Computer Management
WD my passport not initializing-right_click.png

If I try to initialize it, WD my passport not initializing-initialize_disk.png

this window keeps popping
WD my passport not initializing-i_o_error.png

I tried Western Digital Data LifeGuard Diagnostics. It does show up but with 0B capacity.
WD my passport not initializing-wd_diag.png

I also tried Windows Disk Partition withe same result as Rashmanadon. I don't have much important data it. Is there any way to format and recover it?

My System SpecsSystem Spec
31 Jan 2013   #18

Win 7 Home Premium 64bit

yay someone else having same problem haha... I'll give it til the end of this wkend to see if anything I can do fixes it otherwise I'm returning it monday on warranty, just a pain in the butt having to spend money shipping a warranty issued product
My System SpecsSystem Spec
01 Feb 2013   #19

Windows 7 Home Premium 32 bit

Just curious to know whether both of you are using the original cables that came with your drives since I remember to have read somewhere that WD Passports use a sort of proprietory cables with an extra power wire.
My System SpecsSystem Spec
03 Feb 2013   #20

Win 7 Home Premium 64bit

yeah original cables, no other cable i've seen has the connection like the original one
My System SpecsSystem Spec

 WD my passport not initializing

Thread Tools

Similar help and support threads
Thread Forum
system restore is always initializing
Hello there I'm looking for some help with my Windows 7 system restore. I love restore when it works but since I got my pc I have never been able to get it working. Every time I run it all I ever get is "please wait while your windows files and settings are being restored system restore is...
Backup and Restore
Stuck on initializing
when I try to restore my computer it gets stuck on initializing. I did the sfc /scannow thing in cmd and got this: POQ 88 ends. 2015-02-04 16:38:24, Info CSI 000001eb Verify complete 2015-02-04 16:38:24, Info CSI 000001ec Verifying 100 (0x0000000000000064) components 2015-02-04...
Backup and Restore
My Passport External Hard Drive Initializing Error
Hi Everyone! So here the problem, I got a Western Digital My Passport 1 TB External Hard Drive with 700 GB of Important Data. Guess what? No backup and the Hard Drive is not functioning! ..and I need the Data Back and possibly the drive working too! I have tried the drive in several PCs so...
Hardware & Devices
which is best hard drive . My passport or my passport essential se ?
i wanna know which is the best hard drive . This one (Western Digital My Passport 1TB external HDD USB3) or this one (Western Digital My Passport Essential SE 1TB external HDD USB3) and what is the advantages and disadvantages of both h
Hardware & Devices
Max Payne 3 Initializing?
As per topic, I installed Max Payne 3 which took exactly 2 hours 15 minutes. After launching the game, it asked to update as new update was available so did that as well. On welcome screen, when I press enter. It says initializing and remains like that :confused::confused: Anyone else had...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:06.
Twitter Facebook Google+