Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Flash Devices issue... (Win 7 Ent x64)

04 Oct 2009   #1

Windows 7 RC1 x64
USB Flash Devices issue... (Win 7 Ent x64)

I am a MS Technet Plus subscriber and was using the RTM version of 7 Ultimate x64 and all was well.

I Formatted and tried 7 Enterprise x64 on my machine and everything went smooth. However I have an issue where Windows is prompting me to format whenever any USB Flash drive is plugged into the system. If I format, the size of the drive is only 200MB.

I have tried 4 different USB flash drives, all different sizes. Formatted to Fat32, NTFS, no success either way. The size of the drives were 256MB, 4GB, 8GB, and 16GB. Even if the drive has been previously been formated in NTFS with data on it, windows immedatly prompts me to format...

Any one else expirance this issue?
I have replicated this issue with Windows 7 Enterprise on 2 totally different machines.

For FYI, my machine specs are as follows
Core i7 920
6GB DDR3 1600
Gigabyte Mobo Intel X55 Chipset (Intel Drivers Installed, tested 3 versions, default win 7 mobo drivers, Intel drivers, and Intel drivers)
2x GTX 285's

Other Machine
Intel Core 2 Quad Q9550
4GB DDR2 800
Gigabyte mobo Nvidia 9400 chipset w/ latest drivers
On board video

My System SpecsSystem Spec
05 Oct 2009   #2
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Try going into the Disk Management tool and right clicking on the NTFS volume once a flash drive is plugged to assign a drive letter to it. You might have to initialize the volume first however in order to have Windows mount the volume.
My System SpecsSystem Spec

 USB Flash Devices issue... (Win 7 Ent x64)

Thread Tools

Similar help and support threads
Thread Forum
Ethernet Controller issue, cant install drivers or detect devices
Guys, ive encounter some really frustrating issue here , recently just changed my cpu from an phenom x4 955 to a fx 8350 . After the pc got booted up, the horror began as im using an ethernet card , the internet cant be connected . No matter what drivers I tried , it just show that the driver...
Is there still an issue with using IDE/Pata devices?
I have a computer with all sata connections and have a brand new ide/pata HDD, I found laying around. I was going to get an adapter and install the HDD. I have read that people were having problems getting Windows 7 to recognize the device. I couldn't find a clear answer to anyone's problem with...
Hardware & Devices
Storage USB devices driver issue
Hi all, Since 2 weeks I have a strange USB storage driver issue. Notice that it works perfectly before (as usual before not work :-)) This issue occurs with all my USB storages devices (Disk, Key) from a lot of different manufacturer (transcend, Kingston,...). The symptom ==> see USB1, USB2...
Issue with sound devices
I installed Skype messenger today and in the process of setting it up I seemed to 'mess up' my sound. My sound controls are being displayed as two different controls, my speakers and independent headset (see screen shot provided).Before installing Skype everything was normal in the sense that all...
Sound & Audio
Removable devices USB port drive letter issue
I have two monitors that have ports for USB and memory card built into the side of them. When the monitor is plugged into the CPU they are assigned drive letters and become available for use. The problem I'm having is that they are sometimes interfering with my network assigned drive letters...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:43.
Twitter Facebook Google+