Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7/64 "error printing" with HP 4350

02 Feb 2013   #1

XP Pro - Vista - windows 7 ultimate/64 - 8.1 - 10
Win 7/64 "error printing" with HP 4350

It was working fine until 10 days ago. Now when ever we try to print it fails, and when we look at the print queue it just says error printing. We are connected via USB cable; no error lights on the printer.

We have cleared the print queue, again and again with no success.

We checked the print spooler, says started (automatic).

We have cleared the files within the system32/spool/printers folder (stopping and restarting the print spool service).

we have removed the printer from the devices and printers option.

We have downloaded the latest drivers from HP, and re-installed the printer.

No joy with anything we've tried - anyone have any other suggestions?

I've googled extensively, but none of the suggestions I've read go beyond what we've tried and failed.

Or do we just do a re-install of Windows?

My System SpecsSystem Spec
02 Feb 2013   #2

W7 Pro SP1 64bit

Whenever I see that a person has "googled extensively", I fear that I'll just be repeating something already tried but here it goes:

Start > view installed updates
Look for any recent updates from HP.
If found, consider removing them as a test.

You can also uninstall everything related to HP and let the OS handle "installing" the drivers.
My System SpecsSystem Spec
06 Feb 2013   #3

XP Pro - Vista - windows 7 ultimate/64 - 8.1 - 10

Thank you for your suggestion. I removed all updates since the problem started. I also removed all HP programs. Also ran Malwarebytes which removed items referring to "Mywebsearch" and "Weatherblink". Installed a Canon printer which worked fine. Also printer worked fine with another PC.

Subsequently, allowing Windows to install the printer, caused the same problem (maybe notwithstanding the uninstall of HP) still some remnants left?). Clearly a problem in the OS.

So last throw of the dice, before a Win 7 re-install, downloaded the HP drivers again. It worked!!! One will never know which of the many things tried did the magic (probabaly a combination).

In summary:

Checked the print spooler service
Remove printer from devices/printers in control panel
Remove files within windows\system32\spool\printer folder (stopping and restarting print spool service)
Uninstall all Printer software.
Remove all updates since problem started
Run antivirus scans (malwarebytes)
Download the latest drivers and run.
My System SpecsSystem Spec

06 Feb 2013   #4

W7 Pro SP1 64bit

Glad it is working for you
My System SpecsSystem Spec

 Win 7/64 "error printing" with HP 4350

Thread Tools

Similar help and support threads
Thread Forum
Can't print: just says "Error - Printing" in queue
This is a new laptop, Windows 7 Home Premium 64 bit, and I have installed drivers for both my HP Laserjet CP1215 and Canon MP150 (and re-installed quite a few times now too...). Whenever I try and print a document, from WordPad, Adobe Reader, Word, whatever, it just appears in the print queue...
Hardware & Devices
Dymo label maker printing smeared says "spooling, guest"
I have a main computer tower which runs our software on itself as well as 4 laptops. The laptops communicate via a router. All the computers can print to one main printer and two Dymo label printers. Each label printer is set up for different uses. The main computer is windows 8. The laptop...
Hardware & Devices
"Windows Loading Files" infinite loop, Can't Boot USB "disk error"
hello, let's just get to the point, i had this problem recently where my pc can load windows, it keep looping pc's on - booting - then "Windows Loading Files" - restart it's infinite :cry: i don't know what to do, i don't have a cd rom, and i can't reinstall my windows from USB because every time...
General Discussion
Missing "Printing-Foundation-LPDPrintService" feature/service; Win7
I have a problem with a missing "Printing-Foundation-LPDPrintService" feature/service from Win7 from a RT7 Lite install. After dozens of tries I have narrowed the problem of not being able to install a printer driver apparently due to this missing feature/service. What I don't understand is...
Windows 7,HP Officejet G55 printer, Constant Error "error-printing"
Hi All, Windows 7 Ultimate 64-bit 8GB RAM ... stand alone PC...... up to date with all patches, virus checker and firewall in place. HP Officejet G55 connected via USB.......which worked perfectly with Windows XP Professional also via USB.... but on a previous PC and with HP drivers. ...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App