Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Plug and Play is enabled, but devices do not recognize that it is on.

17 Feb 2013   #1

Windows 7 x64
Plug and Play is enabled, but devices do not recognize that it is on.

Okay so basically some programs and devices started acting a bit goofy about a month ago, it was small stuff and I didn't really care. Now my Wacom Bamboo Create Tablet stops working, as well as my printer/scanner (Canon MP490). This was too much so I tried finding the problem, so I head to my Device Manager only to find that it is empty! Not one device shows up in my device list. So after doing some research and seeing that a possible problem is that my PNP is disabled so I go to my processes and see that PNP is enabled. That was a week ago or so. Today I encounter another problem a setting in Photoshop is bugging out, after research updating the driver for my graphics card seem to be the solution. So I download a graphics card detector from my card's manufacturer and try to open it only to receive the following error.

"Could not enumerate PNP devices. Is the plug and play process disabled?"

After digging around a little more I see that malware might be the cause, so I run a full scan, I'm clean. So it appears that Plug and Play IS enabled, it's just being recognized for some reason. I'd really appreciate any help! Thanks! :)

My System SpecsSystem Spec
17 Feb 2013   #2

W7 Home Premium 32bit

Malware may indeed be at work here. That one scan you ran may not be enough, What was it by the way? And, did you run a Full?

See if you can download, install, and run MalwareBytes, SuperAntiSpyware, and Rkill.
If you're prevented from doing so, you're infected.

If they all show nothing, time for a clean install.
My System SpecsSystem Spec

 Plug and Play is enabled, but devices do not recognize that it is on.

Thread Tools

Similar help and support threads
Thread Forum
BSOD when i plug USB Devices
Recently, i have BSOD everytime i plug USB Devices like External HDD or USB Flashdisk, it's not happen when i plug USB Mouse this the zip ------------ SOLVED Thanks Arc
BSOD Help and Support
Audio Devices Disabled/Enabled Simultaneously | Cannot Play Sounds
I have an unusual problem: my Audio Output Devices are all sorts of confused. I can't change the default device, nor disable/enable any devices, and no sound comes out. My notification tray shows there are No speakers of headphones plugged in....
Sound & Audio
plug and play bluetooth dongle not detecting devices and not able to f
i just bought a plug and play blutooth dongle . the first time i put it in it installed certain drivers but 2 failed and it said device unplugged. so i uninstalled the drivers and plugged in the dongle again. now it installed evrythin fine. but when i try to add a device it dosent discover...
Hardware & Devices
Win7 computer in IDE mode and cannot access USB plug and play devices
I recently noticed that I could not access any of my plub and play USB devices on my Windows 7 computer. I just also noticed that when I reboot, I know get a DOS message momentarily that says I am in IDE mode and my plug and play devices cannot be supported. It also provides me with the option...
Hardware & Devices
Plug and Play disable my USB devices
this problem is getting annoying.. i have to keep system restoring to a point where my keyboard and mouse which are both USB work in the beginning when windows 7 loads up... that is until Plug and Play tries to install the devices. after window is done installing and say it have been...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:31.
Twitter Facebook Google+