Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Safely removing USB External Hard Disk Drive

06 Mar 2013   #1

Windows 7 Home Professional 64bit
Safely removing USB External Hard Disk Drive

Please help -

I am experiencing trouble with trying to eject my external disk drive currently.

The situation is that I go to the task bar and go to eject it properly.

All my programs are currently closed - bar Internet Explorer - as I am typing this message.

I am just wondering how you can assess what is using the external hard drive - whether it may be a back up or virus scan.

I have just been turning my computer on then off as I do not wish to loose any information.

I have been told never to just pull the USB cord out

Attached Images
Safely removing USB External Hard Disk Drive-ejecting-problem.png 
My System SpecsSystem Spec
06 Mar 2013   #2

Windows 10x64 Build 1709

No , you shouldn't just pull the power. (Though I have before )

Since its a Seagate external, could that be its built in back up service working? The next time this occurs , right click on the taskbar and open Task Manager. See what applications and processes,if any, are open and running.
My System SpecsSystem Spec
06 Mar 2013   #3

Windows 7 Home Premium 32 bit

Hi Melissa,

I shall just refer you to this thread How do I safely remove USB hardware drives, when it says it's still in use?! - CNET Computer help Forums which deals elaborately on this problem. Please read through all the threads referred to in the first post by the ADMIN therein.

There are also a few programs that can kill any running processes and release your external drive.

Personally I use Unlocker. UNLOCKER 1.9.1 BY CEDRICK 'NITCH' COLLOMB

Other free alternatives : 3 Free USB Safely Remove Alternatives - Technology Flow
My System SpecsSystem Spec

06 Mar 2013   #4

Windows 7 Pro x64 Windows 10 Pro x64

Click Start / Computer / Right click on the drive and choose eject. It should then tell you the drive is in use and ask you to eject anyway, just choose yes and you SHOULD get the safe to remove message.
My System SpecsSystem Spec
06 Mar 2013   #5

Windows 7 Home Professional 64bit

Still getting the message in my computer and I am really confused would it be the as below - been doing research:

Can't eject USB Hard drive, drive always in use? - Microsoft Community

"Distributed Link Tracking Client" has gone nuts and is groveling the entire hard drive for who knows what reason. In my case, the drive hadn't even been used in this session of Windows. After stopping the service, I was able to eject the hard drive. For this sort of problem, you can get more information about which service svchost.exe is hosting is behind the activity by looking at the stack for a relevant item in the Sysinternals Process Monitor list. I found trkwks.dll in the stack, which is "Distributed Link Tracking Client", which maintains the "tracking.log" you mentioned. As you discovered, the Windows Event Log is no help at all, which unfortunately is very typical.

Or the WMPNetworkservice that I have altered?

I am not gain enough to download anything. One says it may contain bugs.

I will just for the meantime - shut down the computer and unplug.

It may be a back up - but that I can not see running or I do not know what to look for.

Thanks for the wealth of information.

I have tried going to the computer function and eject - but it is noted as a desktop external and will not allow an eject function.

I am getting over computers. This time I never touched anything.

Thank you.

I gather that I am to join Cnet's forum?

They seem to have the same issues.

Attached Thumbnails
Safely removing USB External Hard Disk Drive-eject.png   Safely removing USB External Hard Disk Drive-eject1.png   Safely removing USB External Hard Disk Drive-eject2.png   Safely removing USB External Hard Disk Drive-eject3.png   Safely removing USB External Hard Disk Drive-eject4.png  

My System SpecsSystem Spec
06 Mar 2013   #6

Windows 7 Home Professional 64bit

I also have done full print screens - just to show you what I am seeing.

I also tried going to Devices and Printers - tried ejecting from that - no luck.

Maybe a backup - maybe my media being shared - not too sure.

I also joined CNet - just to see what they can do - but most of the threads are similar to what is on here and I think I get better information on here. Friendly service.

Infusion next week - then surgery.

Attached Files
File Type: doc eject word document.doc (529.5 KB, 11 views)
My System SpecsSystem Spec
06 Mar 2013   #7

Windows 10x64 Build 1709

Good luck with the Infusion and surgery. Keep us posted!
My System SpecsSystem Spec
07 Mar 2013   #8

Windows 7 Home Premium x64

My two cents worth: I had the same problem several days ago. I used taskman/resource monitor/disk drives to see the external drive was being accessed by the OS, reading and writing. When the drive was no longer in the list, I tried again to eject, to no avail and the drive re-populated the list again moments later. I felt I had to shut down the PC to "safely" remove the drive.

A few days later and without urgency, I found the drive was indexed (I normally don't index). When I un-indexed the drive, I no longer had the problem in "safely" ejecting the drive.
My System SpecsSystem Spec
07 Mar 2013   #9

Windows 7 Pro x64 Windows 10 Pro x64

If you had the room, I would just copy over the data, verify it, shut the pc down, then power down the external. Disconnect the usb cable, restart the pc, connect the external, power it up and see what happens.
My System SpecsSystem Spec
07 Mar 2013   #10

Windows 7 Home Professional 64bit

Great idea.

I was told to try a clean boot - would not have a clue what to in that case.

I am still stuck doing shut down - unplug and restart.

I have put in all the processes that are running as well.

How do you stop the indexing - as there is quite a lot of data on the external USB 1TB Hard Drive?

Thank you all for your assistance.

Will perhaps look into some of the free downloads - I also have seen that people have trailed Process Explorer - but that looks quite in depth for me.

Any suggestions are sincerely appreciated.
My System SpecsSystem Spec

 Safely removing USB External Hard Disk Drive

Thread Tools

Similar help and support threads
Thread Forum
Removing Linux OS from external Hard Drive
I have acquired a 1TB Western Digital external hard drive that has a Ubuntu Linux operating system on it. The hard drive itself is, I believe, only a couple of years old and has only been used with Linux on it, from what I understand. I'd prefer to use this 1TB drive for file storage, but I can't...
Hardware & Devices
External Hard Drive not safely removable
I have a Dell Vostro 400 using onboard Intel G31/G33 graphics. When I log into admin user and try to remove my Western Digital My Passport it gives me a message that it could not be removed because a program is using it. I ran Process Explorer and the processes running on the drive were all system...
Hardware & Devices
Safely removing my external HDD is a chaotic mess.
Hello people, At the beginning of my topic, I would like to mention that this is (maybe) the first post for me, so, if I messed up with any of forums rules, just tell me. Well, let us get into the topic directly: * Problem Define: - Can not do a safely remove to my external hard drive,...
Hardware & Devices
Unable to safely remove WD External Hard Disk
Hi, Process list with "Unlocker" attached.
Hardware & Devices
unable to safely remove external hard drive
Hey guys I have a question involving an external hard drive and windows 7 libraries. I have this external hard drive (WD500GB My book) which has all my backup information (as per Windows Backup feature; great stuff) as well as all my music and movies. I really like the idea of using libraries to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:07.
Twitter Facebook Google+