Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB mouse doesn't work without USB Hub

08 Mar 2013   #1

Windows 7
USB mouse doesn't work without USB Hub


I am using Windows 7 32-bit on my laptop. I am trying to use a USB mouse that I recently was given through a USB port on my laptop. This doesn't seem to work, however, as my laptop doesn't even recognize that a device is plugged in. The mouse has a built in light which does turn on, though. I tried the other USB ports on my laptop, but there was no result. Other USB mice and devices work fine on my laptop.

So, I thought maybe the mouse was faulty. I tried the mouse in question on another computer with Windows 7 64-bit and it worked fine. It recognized the new device and installed the drivers. I was confused. I then tried using the mouse by plugging it through a USB hub which I plugged into the laptop. For some reason, this seemed to work. The laptop finally recognized the mouse, and installed the drivers.

I tried searching online for some solution, but couldn't really find anything. I did read that there may be a possibility of not enough power in my USB ports. But I'm not sure this is right because other devices work absolutely fine. Also, My USB hub does not have any external power, it just plugs into the laptop. I also tried to find drivers online, but there don't seem to be any.
Here is a link to the mouse in question (mine has a different company's name on it) - Prime Line® Promotional Products Supplier | form. function. fun. asi79530

Anyone know how I can use my mouse without the USB hub plugged in?

Any help is appreciated,


My System SpecsSystem Spec
08 Mar 2013   #2

Windows 7 Home Premium 32bit

Does the mouse use the default driver (mouhid.sys) or any other driver is needed to run it?
Uninstall the driver from device manager and a reboot may work if it uses the default driver. In the other situation an updated driver should work.
My System SpecsSystem Spec
08 Mar 2013   #3

Windows 7

The mouse does use "mouhid.sys" on the desktop computer on which it works. But since I can't install the mouse on the laptop, it doesn't even show in the list of devices. Other mice that I've used use "mouhid.sys" as well.
My System SpecsSystem Spec


 USB mouse doesn't work without USB Hub

Thread Tools

Similar help and support threads
Thread Forum
After starting the PC, mouse shows up but doesn't work
Hello, Each time I start my computer, the mouse shows up. But it doesn't do anything. I checked at Device Drivers and there I got this message after checking USB Mouse's properties: "The Drivers for this device are not installed. (code )." Then I clicked on Update driver but it didn't find any...
Desktop Background and mouse scrolldown doesn't work
Hi there, I'm using Windows 7 Home premium 64bit. I had changed my HDD recently and after installing new version of windows , I'm not able to change the desktop background it just appear black and also the scroll down or up in Mouse has stopped working. Kindly let me know if anything needs to be...
General Discussion
Bluetooth mouse doesn't work
Hi :) I recently bought a new laptop (ASUS K70IC) that has no Bluetooth (BT). I also bought a Bluetooth mouse with it, Genius 905BT and an USB Bluetooth dongle, I thought that would work. But it doesn't. Other Bluetooth devices show up when I search for them, but the mouse doesn't. I tried that in...
Hardware & Devices
Wireless mouse doesn't work... on ONE computer
I do not understand this. I've been buying and returning 'defective' wireless devices for my media center for the last few months. I bought a logitech wireless mouse (v220) a few days ago and it works on my E6410, E6510, Thinkpad T500, NC6230, and custom amd gaming machine. However, on the...
Hardware & Devices
Installed Ubuntu, now mouse doesn't work in Windows 7
before I upgraded from Vista to 7 I was dual booting Ubuntu 9. something and when I installed 7 I thought it deleted it, but now that the boot screen comes up again it's still there and works. Not sure if this could cause problems. When I was installing Ubuntu 10 a window kept popping up...
Hardware & Devices
PS/2 mouse doesn't work
Hi, I have USB keyboard and I installed PS/2 mouse to my PC. Mouse doesn't work and when I check the control panel -> mouse for errors it says this: "This device cannot start. (Code 10)" USB Keyboard: Microsoft comfort curve 2000 PS/2 Mouse: Logitech M-SPF90 - Tinke80
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App